Firefox's and Thunderbird's .desktop file does not contain translation domain info

Bug #512380 reported by Gabor Kelemen on 2010-01-25
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
Baltix
Undecided
Unassigned
firefox (Ubuntu)
Medium
Unassigned
thunderbird (Ubuntu)
Medium
Unassigned

Bug Description

The .desktop files of Firefox and Thunderbird do not contain translation domain info, because they do not use po files for translation, so they have no translation domain to be used here.

One easy solution would be to use the app-install-data domain. This template already contains the strings from this file, and is translatable in LP.

One small problem can arise: app-install-data is part of the language-pack-gnome-xx-base package, this could potentially leave the strings untranslated in Kubuntu. Therefore, moving this template to language-pack-xx-base may be necessary.

Changed in firefox (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Martin Pitt (pitti) wrote :

For firefox, translations of the .desktop file just need to be maintained "the old way". Hijacking app-install-data's gettext files sounds like a nice trick, if it has matching strings, but implementing this is not a priority.

Changed in firefox (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
tags: added: ct-rev
Gabor Kelemen (kelemeng) wrote :

Let's try a less destructive approach: add the domain, but do not remove existing translations. These will be available at install time, but have priority (not that nice, but still...). However, new translations can be added relatively painlessly (cf. bug #331794 :P).

As for a-i-d, it is already containing these strings:
https://translations.launchpad.net/ubuntu/lucid/+source/app-install-data-ubuntu/+pots/app-install-data/hu/+translate?batch=10&show=all&search=A+Web+Browser

https://translations.launchpad.net/ubuntu/lucid/+source/app-install-data-ubuntu/+pots/app-install-data/hu/+translate?batch=10&show=all&search=Mozilla+Thunderbird+Mail%2FNews

https://translations.launchpad.net/ubuntu/lucid/+source/app-install-data-ubuntu/+pots/app-install-data/hu/+translate?batch=10&show=all&search=Firefox+Web+Browser - oops, this is not here, but only because of bug #546533

The other (nice and longterm) solution would be to create a separate po directory and intltool-compatible infrastructure... do we have manpower for this?

Gabor Kelemen (kelemeng) wrote :

The previous patch is for Firefox, this is for Thunderbird.

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in firefox (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in thunderbird (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in firefox (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → nobody
Martin Pitt (pitti) wrote :

I call this "wont fix". As long as Firefox upstream doesn't use gettext, it'd be quite some hackish effort to try and squeeze its translations into gettext. The .desktop file is pretty well translated already, and new/updated translations should be added directly there.

Changed in firefox (Ubuntu):
status: Triaged → Won't Fix
Changed in thunderbird (Ubuntu):
status: Triaged → Won't Fix
Martin Pitt (pitti) wrote :

> add the domain, but do not remove existing translations

Please note that inline translations are preferred over gettext translations, so you couldn't fix translations in a-i-d that way.

Igor Zubarev (igor.zubarev) wrote :

I added translated to Russian Firefox shortcut. See attach. Please could you load it in bazaar branch of Firefox in Lucid?

Igor Zubarev (igor.zubarev) wrote :

Also see translated to Russian Thunderbird shortcut. Please upload it to Lucid bazaar Branch of Thunderbird.

Igor Zubarev (igor.zubarev) wrote :

Hello, Martin @ Gabor

I added manually russian strings to your patch for FF. Please check.

Micah Gersten (micahg) wrote :

@Igor Zubarev

Please file a new bug if you'd like to have the Russian translations included in Firefox and Thunderbird, this bug is about something else.

Igor Zubarev (igor.zubarev) wrote :

The same for Thunderbird.

Igor Zubarev (igor.zubarev) wrote :

I added russian translation of .desktop files to bazaar branches of FF and TB. Waiting for including in Lucid.

Igor Zubarev (igor.zubarev) wrote :

@Micah

I added bug for Russian translation. See https://bugs.launchpad.net/ubuntu-translations/+bug/569762

Changed in ubuntu-translations:
status: Triaged → Incomplete
status: Incomplete → Fix Released
Changed in ubuntu-translations:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers