Even after fixing translator-credits, some still remain untranslated.

Bug #503421 reported by Henning Eggers on 2010-01-05
70
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Launchpad itself
Critical
William Grant
Ubuntu Translations
Undecided
Unassigned

Bug Description

Bug 128324 has been fixed and the script that converts all existing entries has been run to completion. Unfortunately we know of several occurances where the credits remain untranslated:

* https://translations.launchpad.net/ubuntu/oneiric/+source/empathy/+pots/empathy/en_AU/+translate?show=untranslated
* https://translations.launchpad.net/ubuntu/oneiric/+source/gnome-media/+pots/gnome-media-2.0/bs/+translate?show=untranslated
* https://translations.launchpad.net/ubuntu/oneiric/+source/system-config-printer/+pots/system-config-printer/bs/+translate?show=untranslated
* https://translations.launchpad.net/deja-dup/20/+pots/deja-dup-help/ca/1/+translate
* https://translations.launchpad.net/bashare/trunk/+pots/bashare/pt_BR/+translate?show=untranslated
* https://translations.launchpad.net/bashare/trunk/+pots/bashare/de/+translate?show=untranslated
* https://translations.launchpad.net/ubuntu/karmic/+source/plasma-netbook/+pots/plasma-mid-appletbrowser/pt_BR/+translate?show=untranslated

This is also affecting the Ubuntu translations stats report [1] used in the Ubuntu release notes. Some languages will be reported to have a lesser translations coverage due to these untranslated strings, and they'll never be able to reach 100% translation in the report, which is using Launchpad data.

We'll have to look closer at this entry to see what is different about it and why the script missed it. Maybe we'll fix it manually but it could also be that there is a whole class of entries that were missed.

Please report any other untranslated credits here.

[1] http://people.canonical.com/~dpm/stats/ubuntu-11.10-translation-stats.html

Related branches

Emilien Klein (emilien-klein) wrote :

BaShare still has 2 languages for which the translator-credits string appears as being untranslated:

https://translations.launchpad.net/bashare/trunk/+pots/bashare/pt_BR/+translate?show=untranslated
https://translations.launchpad.net/bashare/trunk/+pots/bashare/de/+translate?show=untranslated

All the other languages are fine.

Changed in rosetta:
status: New → Triaged
importance: Undecided → High
André Gondim (andregondim) wrote :

Any news about this bug?

Jaap-Willem Dooge (japydooge) wrote :

Spotted it here today: https://translations.launchpad.net/rednotebook/trunk/+pots/rednotebook/nl/+translate?show=untranslated

Some packages keep coming by in "Translations you can help complete" with only the translator-credits.

David Planella (dpm) wrote :

Duplicate bug 866082 was tagged as regression. Could this one be marked accordingly as regression too?

David Planella (dpm) on 2011-10-05
description: updated
tags: added: regression
Changed in launchpad:
importance: High → Critical
Hendrik Knackstedt (hennekn) wrote :

Can somebody who is able to please fix the following package:
https://translations.launchpad.net/ubuntu/precise/+source/kcm-gtk/+pots/kcm-gtk/de/+translate?show=untranslated

This seems to be the last one that hasn't been fixed yet (at least for German translations).

Jared Norris (jarednorris) wrote :

Just to update, the initial string for enAU in Empathy [1] is still not translated in Quantal (or any series since the bug report). There is also the same issue still prevailing in evolution [2].

[1] https://translations.launchpad.net/ubuntu/quantal/+source/empathy/+pots/empathy/en_AU/+translate?show=untranslated
[2] https://translations.launchpad.net/ubuntu/quantal/+source/evolution/+pots/evolution/en_AU/+translate?show=untranslated

William Grant (wgrant) wrote :

Most of the recent cases are caused by a bug in the message sharing code. When a new PO file is created, a corresponding one is created in all of the sharing templates. But setTranslationCreditsToTranslated is only called on the initial new PO file, so any credit strings in the sharing templates that aren't also in the initial template will end up untranslated.

For example, if I have a template with translator-credits in precise, but the same template doesn't have it in quantal, and I create a new en_AU translation in quantal, a precise en_AU translation will be created with the translator-credits message untranslated.

Changed in launchpad:
assignee: nobody → William Grant (wgrant)
status: Triaged → In Progress
Launchpad QA Bot (lpqabot) wrote :
tags: added: qa-needstesting
Changed in launchpad:
status: In Progress → Fix Committed
William Grant (wgrant) on 2013-04-04
tags: added: qa-ok
removed: qa-needstesting
Curtis Hovey (sinzui) on 2013-10-18
Changed in launchpad:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers