Chuvash locale missing

Bug #451204 reported by Adi Roiban
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GLibC
Fix Released
Medium
Ubuntu Translations
Fix Released
Wishlist
Adi Roiban
glibc (Ubuntu)
New
Undecided
Unassigned

Bug Description

Glib does not have the Chuvash locale definition.

Togheter with Ali we will try to define it and send it upstream.

When we have it, we could enable the CV lang-packs.

Tags: needs-locale
Adi Roiban (adiroiban)
description: updated
Revision history for this message
Adi Roiban (adiroiban) wrote :

Ali, based on your info I have created this locale file.

It is not complete.

We still need the following:
 - define the alphabet and character ordering
 - define missing character substitution
 - define abreviated day name, full and abreviated month names
 - define date and time representation
 - define paper and telephone standards
 - define measurement system
 - define LC_NAMES and LC_ADDRESS

I have keep the UTF8 comments, and will fix them in the final version.

Revision history for this message
Adi Roiban (adiroiban) wrote :

This is the current file... not ready for usage

Changed in ubuntu-translations:
status: New → Incomplete
assignee: nobody → Adi Roiban (adiroiban)
importance: Undecided → Wishlist
Revision history for this message
Ali Savatar (blackfez) wrote :

The basic alphabet is: Aa Ăă Cc Ee Ĕĕ Hh Ii Jj Kk Ll Mm Nn Pp Rr Šš Ss Şş Tt Uu Üü Vv Yy
Ă can be substituted with A(
Ĕ=E(
Š=S<
Ş=S,
Ü=U:

Days of week:
vyrsarnikun (Sunday) - short vr
tuntikun (Monday) tn
ytlarikun (Tuesday) yt
junkun (Wednesday) jn
kĕşnernikun (Thursday) kş
ernekun (Friday) er
šămatkun (Saturday) šm

The week itself starts on Monday.

Month names:
kărlac (January) - short KĂR
narăs (February) NAR
puš (March) PUŠ
aka (April) AKA
şu (May) ŞU
şĕrtme (June) ŞĔR
ută (July) UTĂ
şurla (August) ŞUR
avăn (September) AVĂ
jupa (October) JUP
cük (November) CÜK
raštav (December) RAŠ

lang_name=Căvaš
lang_ab=Căv
lang_term=chv
lang_lib=chv

Country name in Chuvash is "Raşşej", abbreviated to Rş/Raş.

Adi Roiban (adiroiban)
Changed in ubuntu-translations:
status: Incomplete → In Progress
Revision history for this message
Ali Savatar (blackfez) wrote :

Names of week should start with small letters (needs to be fixed in cv_RU).

Revision history for this message
Adi Roiban (adiroiban) wrote :

The following fields are still missing:

cv_RU:
LC_NAME: field `name_gen' not defined
LC_NAME: field `name_mr' not defined
LC_NAME: field `name_mrs' not defined
LC_NAME: field `name_miss' not defined
LC_NAME: field `name_ms' not defined
LC_ADDRESS: field `country_post' not defined
LC_ADDRESS: field `country_car' not defined
LC_ADDRESS: field `country_isbn' not defined

Ali told me that name_mr, name_mrs ... etc are not used in Chuvash

Revision history for this message
Ali Savatar (blackfez) wrote :

country_post, country_car and county_isbn are probably the same in all *_RU locales...

Revision history for this message
Ali Savatar (blackfez) wrote :

Any news?

Revision history for this message
Colin Watson (cjwatson) wrote :

This isn't something we'll make progress on in Ubuntu; the locale needs to be sent upstream.

Revision history for this message
Colin Watson (cjwatson) wrote :
Revision history for this message
chavash (anatoly-mironov) wrote :

Thank you, Ali Savatar! Great work. I hope, Chuvash locale is in the 9.10

Revision history for this message
Adi Roiban (adiroiban) wrote :

I have created the required locale file, but we need someone speacking chuvash to test the locale before sending it upstream.

Ali, can you test it?

If you need help please let me know!

Cheers!

Revision history for this message
Ali Savatar (blackfez) wrote :

Thanks, Colin. Is there anything else we can help with to speed up the process? How much time needs to pass before we see our language pack in Ubuntu?

Revision history for this message
Ali Savatar (blackfez) wrote :

Sorry, Adi, I haven't noticed your last comment. Of course I can help. Just what exactly do you want me to do? I tried to use the latest locale and here's what I got:

blackfez@blackfez:~$ localedef -i '/home/blackfez/Desktop/cv_RU' -f ISO-8859-1 cv_RU
LC_ADDRESS: `lang_ab' value does not match `lang_term' value
LC_ADDRESS: `lang_lib' value does not match `lang_term' value
LC_ADDRESS: `country_ab2' value does not match `country_num' value
LC_ADDRESS: `country_ab3' value does not match `country_num' value
no output file produced because warnings were issued

Revision history for this message
Colin Watson (cjwatson) wrote : Re: [Bug 451204] Re: Chuvash locale missing

On Mon, Oct 19, 2009 at 12:46:08PM -0000, Ali Savatar wrote:
> Is there anything else we can help with to speed up the process?

It would be best if somebody who speaks the language worked directly
with upstream to get the locale added.

> How much time needs to pass before we see our language pack in Ubuntu?

I don't know the answer to that, I'm afraid; it depends on how quickly
the new locale is adopted by glibc upstream.

Revision history for this message
Adi Roiban (adiroiban) wrote :

I don't know why do we have these errors since lang_lib is identical with lang_term , and they don't need to match.

We will need some help from an glibc upstream developer

Revision history for this message
In , Adi Roiban (adiroiban) wrote :

Hi,

I'm helping the Chuvash speaking users to implemnt Chuvash locale support in glibc.

The initial bug report was filed in Ubuntu here.

The cv_RU locale file can be found here:
http://launchpadlibrarian.net/33739429/cv_RU

When trying to install the file we get this error, but we don't know how to fix it.

$ localedef -i '/home/blackfez/Desktop/cv_RU' -f ISO-8859-1 cv_RU
LC_ADDRESS: `lang_ab' value does not match `lang_term' value
LC_ADDRESS: `lang_lib' value does not match `lang_term' value
LC_ADDRESS: `country_ab2' value does not match `country_num' value
LC_ADDRESS: `country_ab3' value does not match `country_num' value

Any help is much appreciated!

Kindest regards,
Adi

Revision history for this message
Adi Roiban (adiroiban) wrote :

Ali, please follow the upstream bug report at http://sources.redhat.com/bugzilla/show_bug.cgi?id=10824

Revision history for this message
In , Dmitry V. Levin (ldv) wrote :

That locale file contains several buggy and/or redundant definitions that should
be replaced with
copy "ru_RU"
statements. See also
http://sourceware.org/git/?p=glibc.git;a=blob;f=localedata/locales/tt_RU

Changed in glibc:
status: Unknown → Confirmed
Revision history for this message
In , Adi Roiban (adiroiban) wrote :

Created attachment 4307
cv_RU locale files

I have replace the redundant entries with copy "ru_RU" but we still get those
errors.

Looking at this error message I don't know why lang_ab should match lang_term.
For many locales they are not the same.
LC_ADDRESS: `lang_ab' value does not match `lang_term' value

Revision history for this message
Ali Savatar (blackfez) wrote :

Adi, I think I understood the reason behind those errors:

LC_ADDRESS: `country_ab2' value does not match `country_num' value
LC_ADDRESS: `country_ab3' value does not match `country_num' value

It seems that "country_ab2" and "country_ab3" are some special country codes that don't need to be changed in our case. In Russian locale they equal "RU" and "RUS" respectively. As for these ones:

LC_ADDRESS: `lang_ab' value does not match `lang_term' value
LC_ADDRESS: `lang_lib' value does not match `lang_term' value

I think all those "lang_*" strings can be dropped/commented out since other locales (I've checked crh_UA, ru_RU and tt_RU) work pretty well without them.

I'm attaching the corrected locale file, it seemed to compile without errors:

blackfez@blackfez:~$ localedef -i '/home/blackfez/Desktop/cv_RU' -f ISO-8859-1 cv_RU
cannot create temporary file: Permission denied
blackfez@blackfez:~$ sudo localedef -i '/home/blackfez/Desktop/cv_RU' -f ISO-8859-1 cv_RU
[sudo] password for blackfez:
blackfez@blackfez:~$

Revision history for this message
In , Adi Roiban (adiroiban) wrote :

Created attachment 4311
Working locale file

I have copied LC_ADDRESS from ru_RU and now it is working.

Can you please include it in the next glib release?

Many thanks!

Revision history for this message
Adi Roiban (adiroiban) wrote :

Great!

I have replace them with copy "ru_RU", since they are identical with RU.

I have uploaded the file upstream and ask for inclusion in the next glib release.

Revision history for this message
Ali Savatar (blackfez) wrote :
Revision history for this message
In , Drepper-fsp (drepper-fsp) wrote :

The code below is not sufficient. You have to use reorder_after to assign the
collation symbols their place. Just mentioning it in the comment is not going to
work.

LC_COLLATE
copy "iso14651_t1"

% The Chuvash alphabet has the following letters, ordered as below:
% a a( c e e( h i j k l m n p r s< s s, t u u: v y

collating-symbol <a(>
collating-symbol <e(>
collating-symbol <s<>
collating-symbol <s,>
collating-symbol <u:>

END LC_COLLATE

Aron Xu (happyaron)
tags: added: locale
tags: added: locales
removed: locale
Changed in glibc:
status: Confirmed → Incomplete
Revision history for this message
In , Adi Roiban (adiroiban) wrote :

Created attachment 4348
reorder-after added

Hi,

I have added the reorder-after reference.

Please excuse my errors. I'm still trying to understand the ISO 146522 standard

Cheers

Revision history for this message
In , Adi Roiban (adiroiban) wrote :

Created attachment 4349
diaerisis fixed

This should fix the diaeresis problem

Revision history for this message
In , Adi Roiban (adiroiban) wrote :

HI,

Is there anything I can do to push forward a resolution for this issue?

Aron Xu (happyaron)
tags: added: needs-locale
removed: locales
Adi Roiban (adiroiban)
tags: removed: task
Revision history for this message
In , Drepper-fsp (drepper-fsp) wrote :

I've added the locale now.

Changed in glibc:
status: Incomplete → Fix Released
David Planella (dpm)
Changed in ubuntu-translations:
status: In Progress → Fix Released
Changed in glibc:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.