Software Centre, Synaptic should point to the DDTP

Bug #376464 reported by Pierre Slamich on 2009-05-14
30
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Package Descriptions for Ubuntu
Wishlist
Unassigned
Ubuntu Translations
Medium
Unassigned
unity-lens-applications
Wishlist
Unassigned
software-center (Ubuntu)
Undecided
Unassigned
synaptic (Ubuntu)
Wishlist
Unassigned

Bug Description

There are a lot of untranslated software descriptions in WebCatalog, Software Center and Synaptic (60000+ strings in most languages, https://translations.launchpad.net/ddtp-ubuntu/ ).
Relying solely on translators doesn't scale. Would it be possible to add a mechanism to enable translation suggestion crowdsourcing ?

The basic idea would be a button to "Translate this software description" below each untranslated description that would enable users to easily provide a translation suggestion to the DDTP using Launchpad.

We could point the user to the DDTP translations in each individual software summary shown in Ubuntu App Center or Synaptic. There would be a button called "Translate those descriptions"

http://nightmonkey.ubuntu.hu/#release=raring&language=fr&view=app&repo=REPOSITORY&isok=false&rownumber=100&sortpopcon=dsc&packagename=KEYWORD&page=null

Two variables:
keyword
repository

Mockup:
- Software Centre: https://bugs.launchpad.net/ubuntu-translations/+bug/376464/+attachment/3657387/+files/Logith%C3%A8que-Ubuntu_001.png
- Synaptic: https://bugs.launchpad.net/ubuntu-translations/+bug/376464/+attachment/3657359/+files/synaptic.jpg
- Application Lens: https://bugs.launchpad.net/ubuntu-translations/+bug/376464/+attachment/3650567/+files/mockup.png

description: updated

No task for ddtp-ubuntu

Changed in ddtp-ubuntu:
importance: Undecided → Wishlist
importance: Wishlist → Undecided
status: New → Invalid

Putting back to wishlist

Changed in ddtp-ubuntu:
importance: Undecided → Wishlist
status: Invalid → New
affects: software-center → software-center (Ubuntu)
tags: added: ddtp
tags: added: crowdsourcing
Pierre Slamich (pierre-slamich) wrote :
summary: - Synaptic should point to the DDTP
+ Software Centre, Synaptic should point to the DDTP
Pierre Slamich (pierre-slamich) wrote :

The button appears if the app description is untranslated.

Pierre Slamich (pierre-slamich) wrote :

Here's a synaptic quick mockup. It would only show up for untranslated or partially translated descriptions

Pierre Slamich (pierre-slamich) wrote :

And finally (after Synaptic and the Application Lens), here's a mockup for the Software Centre

no longer affects: software-center
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Matthew Paul Thomas (mpt) wrote :

I like this idea in theory. But I see a couple of big issues to address before it could appear in client software.

First, it's not clear to me how the links would be satisfying for most of the people who were interested. For example, if I go to <http://nightmonkey.ubuntu.hu/> right now it links to one description, deja-dup in French. If I click "Translated" I end up at <https://translations.launchpad.net/ddtp-ubuntu/raring/+pots/ddtp-ubuntu-main/fr/857/+translate>, which says "This template can be translated only by its managers." And that's when I'm already logged in with a Launchpad account! If someone didn't have a Launchpad account, they might be misled into thinking that getting one would make any difference, and end up frustrated. So you need some way of making sure that every "Translate this description" link takes you to a place where you can actually suggest a translation.

Second, we would need to have the DDTP server -- or at least a proxy to it -- on ubuntu.com. I'm sure the ubuntu.hu domain owner is a wonderful person, but if they lose interest or forget to renew the domain, a few months later, millions of Ubuntu users would be running software that links to a squatted domain or worse. We already do this for screenshots.ubuntu.com, which is a caching proxy server just in case screenshots.debian.net goes away.

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Pierre Slamich (pierre-slamich) wrote :

The source code of our tool is public, and the developper (Istvan) is active and responsive, so it should be easy to make a copy/mirror on Ubuntu.com

As for the link, you obviously need to be logged into Launchpad to contribute (otherwise Launchpad tells you to do so) but it will let you propose a suggestion for your language (and even other languages).

The url is able to be modified according to the system locale using the various parameters (such as language=fr, release=raring & packagename=gnome-screenshot,repo=universe,isok=false)

The URL I gave was misleading because I used placeholders. Here's one that's working. I just changed language from fr to es, and i set packagename to kaffeine.

This one will look for Kaffeine in French:
http://nightmonkey.ubuntu.hu/#release=raring&language=fr&view=pack&repo=universe&isok=false&rownumber=100&sortpopcon=dsc&packagename=kaffeine&page=null

This one for Kaffeine in Spanish
http://nightmonkey.ubuntu.hu/#release=raring&language=es&view=pack&repo=universe&isok=false&rownumber=100&sortpopcon=dsc&packagename=kaffeine&page=null

Gabor Kelemen (kelemeng) wrote :

Matthew,

Nightmonkey is there as a stop-gap measure, because LP is not as perfect as we would like it to be. In an ideal world, such UI buttons would lead directly to the Launchpad template. That certainly would need a lot more work to work than wiring in a button with a link and two variables.

Making sure that it's possible to really contribute would be easy - just change the permission of ddtp-ubuntu from restricted to open. This would mean also some extra work to make sure updates are pushed out in a timely manner to make sure nothing "bad"[0] sticks there for a long time.

You are also right that the ubuntu.hu domain is not really reliable at large - for example, even I don't know the owner, it's a miracle that we are still afloat :). It is possible however to run an own copy of it, if Infrastructure is willing to host that terrible spaghetti code (its author said something like this!).

[0] For example, Facebooks translation is entirely crowdsourced and there is no "native QA team" to check the new translations before they go live. A Hungarian entrepreneur thus made his company "advertised" on the login page of Facebook - for a few hours until the "translation" was noticed and reverted. Daily bzr exports, nor "when mvo has time to push them live" are clearly not the desirable update frequency needed for blindly trusting the community.

Gabor,
Restricted sounds like a good compromise; you need a Ubuntu SSO Account, much like Ubuntu One, to login, and then you can suggest. You avoid the risks of rogue translations, and ensure quality while crowdsourcing.

As for Nightmonkey, it avoids doing the logic client-side, which could be demanding and works for me (it was disrupted last year, but only due to a bug in Launchpad Translations which since has been solved)
The code is at https://launchpad.net/ddtp-lp-html/trunk and I've added István to the bug.

Changed in ubuntu-translations:
milestone: none → saucy-user-interface-freeze

For the serverside part: I've filed a RT ticket for hosting Nightmonkey on ubuntu.com and talked with Istvan about refactoring to ensure that Nightmonkey won't pose any issues at all (we haven't had any downtime afaik, but the load will likely be higher).

For the client part, I've found this file in the software centre, which is my best guess on the place the changes should occur:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/saucy/software-center/saucy/view/head:/softwarecenter/ui/gtk3/views/appdetailsview.py

I want to expose two issues which are not directly related to the implementation of this feature but I believe to be important if we are to achieve significant contributions through this newly introduced workflow.

As a long time translation team coordinator I have noticed that it's very important for translators to get fast feedback and good translation experience. If they translate a few strings and "nothing happens" in a more than a week or maximum two weeks most of them will get discouraged and it's far less likely they will continue with translation effort.
In the implementation of this feature I see two main bottlenecks:
* I assume translations will be accepted as suggestions. This means someone will need to review them and confirm them before they are used. Many language teams are not going to check ddtp templates on weekly basis and strings might stay unreviewed for a very long time. Some sort of notification system should be implemented or there should be a clear link who the new translator should try to contact if strings are unreviewd for a longer period of time

* Once the strings are confirmed they are only updated sporadicly in Ubuntu. I suggest weekly or biweekly exports of translations so that translators can quickly notice their work makes a difference and are motivated to contribute more.

- I've filed a bug against the DDTP about it with a sample message we could display to set expectations right : https://bugs.launchpad.net/ddtp-ubuntu/+bug/1188097
Istvan, do you think you could include such a warning in Nightmonkey ?

- About refreshes, I've talked about this with mvo because I also wanted to make sure the French translation are quickly used but it can't be fully automatic for obvious safety reasons.

----

> Finally, would it be possible to set up a weekly automatic push of the
> translations to the actual Ubuntu repositories as many translation teams
> are now moving very fast, and we'd be eager to see users benefit from the
> translations.

This is a bit tricky as a fully automatic solution would require a
unlocked gpg key that can upload to the archive on a server. That is a
bit scary. We should talk to Martin Pitt to see how he is doing it for
the langpack-o-matic stuff and if we could integrate into his
framework. That would probably be the best solution. But I totally
agree with the goal to get the translations in faster!

----

We just received an answer from RT. They want Nightmonkey to be deployable using a Charm (bug filed at https://bugs.launchpad.net/ddtp-lp-html/+bug/1188133 ) and want to do some code review before deployment.

Phillip Sz (phillip-sz) on 2013-08-30
Changed in ubuntu-translations:
status: New → Confirmed
David Planella (dpm) on 2013-10-01
Changed in ubuntu-translations:
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in unity-lens-applications:
importance: Undecided → Wishlist
status: New → Triaged
Matthew Paul Thomas (mpt) wrote :

Pierre, is Nightmonkey still being developed? There's nothing for me to do here until anyone demonstrates that a simple translation crowdsourcing system is viable. Linking from USC to a translation service would be pretty easy, but I wouldn't be happy to see USC linking to anything more complicated than something that takes you directly from an Ubuntu SSO sign-in to a focused field for entering the suggested translation. Nightmonkey might become that simple, but it looks far from there at the moment, and I don't see any activity in the past six months.

Changed in software-center (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
Daniel Fore (danrabbit) on 2015-06-22
no longer affects: appcenter
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
Adolfo Jayme (fitojb) on 2015-06-23
affects: synaptic → synaptic (Ubuntu)
Changed in synaptic (Ubuntu):
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers