gimp (or any other gnome app) should pull in the respective language-pack-gnome-*

Bug #238634 reported by quazgar on 2008-06-09
2
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Wishlist
Unassigned
language-selector (Ubuntu)
Undecided
Unassigned
packagekit (Ubuntu)
Wishlist
Unassigned

Bug Description

In Kubuntu, installing GIMP (and other gnome applications) doesn't pull in the respective language-pack-gnome-* packages. Thus, gnome applications are only available in their native language (English mostly) even when the system language has been explicitly set to another language.

Steps to reproduce:

1) Start your favourite Kubuntu system, which should be set to a non-English language globally.
2) Install GIMP.
3) Start GIMP.

What should happen:
1) language-pack-gnome-foonian (if your language was set to foonian) should be selected as a dependency when installing GIMP.
2) GIMP should be in your set language.

What happens:
1) GIMP runs in English.

Workaround:
1) Manually install language-pack-gnome-foonian.

This happened on Kubuntu Gutsy and was reported (on irc) to still happen on Hardy.

Dereck Wonnacott (dereck) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" [WWW] http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at [WWW] http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Emmet Hikory (persia) wrote :

Description seems complete to me, although I don't have the environment to reproduce.

Changed in language-selector:
status: Incomplete → New
Dereck Wonnacott (dereck) wrote :

This works as desired when in Japanese. but I am in Ubuntu however.

quazgar (quazgar) wrote :

@Dereck: Does it work for you if you install KDE packages which should be available in Japanese?
----

Generally: I'll try to summarize part of the talk in #ubuntu-bugs about this:

It seemed that this kind of problem might be a bit harder to tackle than was thought at first, maybe if the deb dependencies were scriptable somehow? At least that would be the way to do it on systems like gentoo: Something like having one language meta pack per language, and all i18n'ed packages would check which lang-meta-* packages are installed and as a result depend on the respective individual/specific language package. I don't know if this kind of behaviour would be possible with debian packages, nor if it would be desirable from a maintainers' point of view.

Another possibility would be to automatically install all the language-pack-*-LANGUAGE packages at (K)ubuntu install time. This way might, however, increase the install cd size to more than what's acceptable.

Or there are other ways that the real devs could come up with (more than I could).

quazgar (quazgar) wrote :

This bug (and its solution) was confirmed in #<email address hidden> for Xubuntu 8.04 as well.

Arne Goetje (arnegoetje) wrote :

The issue reported here is a very valid one. I have added some code to language-selector to find missing language-packs and other localization related packages, depending on the software being installed.

What still needs to be done is to modify the package manager(s) to call check-language-support (in the language-selector-common package) and install the packages reported by this tool.

The installer uses this method already to find missing packages at install time.

Relevant options to call check-language-support with:
 -l $languagecode : check only for this particular language. If not specified, will check for all languages installed on the system through the respective language-packs.
 -p $list_of_packages : list of packages, separated by comma. These are the packages which are gong to be installed. check-language-support will scan for missing localization packages related to these. If not specified, it will check according to all installed and to-be-installed packages on the system.

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Wishlist
Arne Goetje (arnegoetje) on 2010-03-18
Changed in language-selector (Ubuntu):
status: New → Fix Released
Jonathan Thomas (echidnaman) wrote :

I suppose Ubuntu package managers also need to do this for KDE apps?

affects: kpackagekit (Ubuntu) → packagekit (Ubuntu)
Sergio Zanchetta (primes2h) wrote :

It would be really nice to have it for kde apps in Ubuntu.
It's not so easy for a newbie to understand what it needs to have a newly installed kde application localized in his own language.

Matthias Klumpp (ximion) on 2010-08-30
Changed in packagekit (Ubuntu):
status: New → Invalid
Sebastian Heinlein (glatzor) wrote :

In the end adding a plugin mechanism to the packagekit backend could be a solution. See the corresponding changes in aptdaemon.

Changed in packagekit (Ubuntu):
status: Invalid → Confirmed
Daniel Nicoletti (dantti) wrote :

Right now it would be possible to check for missing language packages before any install/update.
But this would be a MUST, in other words the user would not be able to skip downloading them, which
might upset some users since lang packs are pretty big.
I'll propose a change to PackageKit to allow optional downloads, which could allow the user to skip this,
but if approved it would only be available in Natty.

How can I know what is the best option that users would like?

Matthias Klumpp (ximion) on 2012-03-14
Changed in packagekit (Ubuntu):
importance: Undecided → Wishlist
Matthias Klumpp (ximion) on 2012-06-02
Changed in packagekit (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers