Request to add language-pack-kab for kabyle

Bug #1860779 reported by ButterflyOfFire
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Unassigned
langpack-o-matic
Undecided
Łukasz Zemczak

Bug Description

Hi,
We would like to introduce a request to add language-pack-kab same as Mozilla did firefox-locale-kab.

Hope we can get this soon :)
regards,

ButterflyOfFire

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for reporting.

I think a language needs to meet a minimum requirement of translated strings to create a new language pack. I couldn't find a reference at the moment but I believe it is around 5% of the strings in Ubuntu. Looking at Kabyle on https://translations.launchpad.net/ubuntu/eoan/+translations more translations seems to be needed. (I couldn't check focal for some reason)

In case I'm wrong, I've added an Ubuntu translation task to get some more accurate information.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

Hans Joachim is right, so this request to create Kabyle language packs was submitted prematurely.

So please start translating. You need approximately 15,000 translated strings. Once there, please file a new request.

Closing this for now.

affects: langpack-locales (Ubuntu) → langpack-o-matic
Changed in langpack-o-matic:
status: New → Invalid
Changed in ubuntu-translations:
status: New → Invalid
Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

On 2020-01-25 14:23, Hans Joachim Desserud wrote:
> (I couldn't check focal for some reason)

My mistake - fixed now, so also focal is available.

Revision history for this message
ButterflyOfFire (butterflyoffire) wrote :

Hi team,

Updating this bug : can you check % of kabyle translation now ? :)
Thank you.

Revision history for this message
Gunnar Hjalmarsson (gunnarhj) wrote :

In hirsute it looks like 21000+ strings or approximately 6.5% are translated, so yes, it seems to be time to create Kabyle language packs.

@Łukasz: Will that happen automatically at next base language pack update, or do you need to do anything manually?

Changed in ubuntu-translations:
status: Invalid → Triaged
Changed in langpack-o-matic:
status: Invalid → Confirmed
Changed in langpack-o-matic:
assignee: nobody → Łukasz Zemczak (sil2100)
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

There might be some manual steps required as this will also result in a new source package (which will fail to upload due to it missing in the packageset). I'll spin the first base langpack set and see how it goes.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Ok, seems like somethings working now. I had to tweak l-o-m a bit to get the new language recognized properly. I have uploaded the new packages, approved them and asked for proper team subscription. Once everything settles down, we should be good! I'll also add the new packages to the langpack packageset, as for now I had to upload them manually because of that.

Changed in langpack-o-matic:
status: Confirmed → Fix Committed
Revision history for this message
Łukasz Zemczak (sil2100) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers