SMS notification: time format not translatable

Bug #1372061 reported by David Planella on 2014-09-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
kevin gunn
Ubuntu Translations
Low
Unassigned
ubuntu-settings-components (Ubuntu)
High
Nick Dedekind
ubuntu-ui-toolkit (Ubuntu)
High
Christian Dywan
unity8 (Ubuntu)
High
Nick Dedekind

Bug Description

See the attached screenshot. The time for the notification seems to be hardcoded to "hh:mm - mm, d". This works well for the US, but it's not a format that is used in all other countries. In Spain, for example, the date would rather be "d mm".

The time format needs to be marked for translation.

Not sure from which project the notifications come from, for some reason I seem to remember they were moved to u-s-s, but if it's the wrong project/package, please reassign. Thanks!

Related branches

David Planella (dpm) wrote :
tags: added: touch
description: updated
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

settings has notifications for system updates only, that's probably an issue with telephony-service rather

affects: ubuntu-system-settings (Ubuntu) → telephony-service (Ubuntu)
Bill Filler (bfiller) on 2014-10-05
Changed in telephony-service (Ubuntu):
importance: Undecided → High
assignee: nobody → Tiago Salem Herrmann (tiagosh)
tags: added: rtm14 touch-2014-10-23
Lars Karlitski (larsu) on 2014-10-13
no longer affects: indicator-messages (Ubuntu)
Changed in unity8 (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Nick Dedekind (nick-dedekind) wrote :

This should be using the datetime indicator translation context, perhaps this is wrong?
We're meaning to move the relative time formatters to the sdk to get consistency.

kevin gunn (kgunn72) wrote :

@nick - so should we just move this bug to sdk ?

kevin gunn (kgunn72) on 2014-11-06
tags: added: ota-1
removed: touch-2014-10-23
kevin gunn (kgunn72) on 2014-11-21
Changed in unity8 (Ubuntu):
assignee: Nick Dedekind (nick-dedekind) → Ying-Chun Liu (paulliu)
assignee: Ying-Chun Liu (paulliu) → Nick Dedekind (nick-dedekind)
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in unity8 (Ubuntu RTM):
importance: Undecided → High
status: New → Triaged
Changed in unity8 (Ubuntu):
status: New → Triaged
kevin gunn (kgunn72) on 2014-11-21
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Nick Dedekind (nick-dedekind) wrote :

This is due to the datetime indicator no longer having relative time formatting; so the cross domain usage for translated time formats in unity8 is no longer in sync.

Highlights the problem of inconsistency, and the need to move this to sdk.

Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Michał Sawicz (saviq) on 2014-12-01
Changed in unity8 (Ubuntu RTM):
assignee: Nick Dedekind (nick-dedekind) → nobody
milestone: none → 14.09-ota-1
Bill Filler (bfiller) wrote :

the formatting is done outside of the telephony-service which just passes a timestamp to the messaging-menu, so marking invalid for telephony-service

Changed in telephony-service (Ubuntu):
status: New → Invalid
Nick Dedekind (nick-dedekind) wrote :

Currently in unity8 we rely on indicator-datetime translations for time string formats; but since these are no longer in sync with the one's used in unity8, it's not working.

I'm moving the time formatter into the sdk where the translations will be done.
Everything (messaging & alarm/events) should be passing around "time stamps" rather than "time strings", which can be formatted & translated by the UIs inconsistently.

Michał Sawicz (saviq) on 2014-12-10
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
assignee: nobody → Nick Dedekind (nick-dedekind)
Michał Sawicz (saviq) wrote :

Let's target this for ww03-2015.

Changed in canonical-devices-system-image:
status: Confirmed → New
Changed in unity8 (Ubuntu RTM):
milestone: 14.09-ota-1 → none
Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww03-2015
Michał Sawicz (saviq) on 2015-01-09
Changed in ubuntu-settings-components (Ubuntu):
status: New → In Progress
assignee: nobody → Nick Dedekind (nick-dedekind)
Michał Sawicz (saviq) on 2015-01-13
Changed in ubuntu-settings-components (Ubuntu RTM):
status: New → Triaged
milestone: none → 14.09-ota-2
Changed in unity8 (Ubuntu RTM):
milestone: none → 14.09-ota-2
Changed in ubuntu-settings-components (Ubuntu RTM):
milestone: 14.09-ota-2 → 14.09-release
Changed in unity8 (Ubuntu RTM):
milestone: 14.09-ota-2 → 14.09-release
Changed in ubuntu-settings-components (Ubuntu RTM):
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
status: Confirmed → In Progress
Pat McGowan (pat-mcgowan) wrote :

review the api for inclusion in sdk post rtm

Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Nick Dedekind (nick-dedekind) → Zsombor Egri (zsombi)
Changed in canonical-devices-system-image:
assignee: Canonical Devices Products (canonical-devices-products-team) → Kevin Gunn (kgunn)
milestone: ww07-2015 → ww09-2015
Michał Sawicz (saviq) wrote :

The required API was not accepted into UITK yet, ww09 seems like an impossible target for this.

Changed in unity8 (Ubuntu RTM):
milestone: 14.09-release → 14.09-ota-1
Michał Sawicz (saviq) on 2015-02-13
Changed in unity8 (Ubuntu RTM):
milestone: 14.09-ota-1 → none
Changed in ubuntu-settings-components (Ubuntu RTM):
milestone: 14.09-release → none
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww13-2015
assignee: Kevin Gunn (kgunn) → Zoltan Balogh (bzoltan)
Changed in canonical-devices-system-image:
milestone: ww13-2015 → ww17-2015
Pat McGowan (pat-mcgowan) wrote :

whats going on with this, seems stalled

Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww21-2015
Zsombor Egri (zsombi) on 2015-05-04
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
Zsombor Egri (zsombi) wrote :

The branch proposed for the toolkit does not cover the BP https://blueprints.launchpad.net/ubuntu-ui-toolkit/+spec/time-formatter. Beside that, I agree with Tim and Christian, that there is no need to provide a component dedicated to translate date and time only, especially that we have the internationalisation engine which can be extended with a function or two to support this.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Zsombor Egri (zsombi) → Christian Dywan (kalikiana)
Nick Dedekind (nick-dedekind) wrote :

I used a component because using function won't respond to changes in locale, time-zone, daylight savings, etc without a refresh of the data.
It's a lot more complicated than just a i18n.tr("12:00 PM") kind of thing. Unless you have a better idea (other than ignoring changes).

Pat McGowan (pat-mcgowan) wrote :

Can we get some action on this

Changed in canonical-devices-system-image:
milestone: ww21-2015 → ww26-2015
Changed in canonical-devices-system-image:
milestone: ww26-2015 → ww34-2015
Zsombor Egri (zsombi) wrote :

Nick, you can get updates on function calls when local or any parameter used changes. See i18n.tr() and other functions also get updated when locale changes. You could have thing like i18n.trDate(date, format) which returns an object, which in turn can also have properties/functions so those can get updated whenever date, format or locale changes.

Bill Filler (bfiller) on 2015-08-19
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
assignee: Zoltan Balogh (bzoltan) → kevin gunn (kgunn72)
kevin gunn (kgunn72) on 2015-09-29
no longer affects: telephony-service (Ubuntu)
no longer affects: ubuntu-settings-components (Ubuntu RTM)
no longer affects: ubuntu-ui-toolkit (Ubuntu RTM)
no longer affects: unity8 (Ubuntu RTM)
Changed in ubuntu-settings-components (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Launchpad Janitor (janitor) wrote :
Download full text (6.9 KiB)

This bug was fixed in the package ubuntu-settings-components - 0.6+15.10.20151021-0ubuntu1

---------------
ubuntu-settings-components (0.6+15.10.20151021-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Nick Dedekind ]
  * Fixed problem with message time text alignment. (LP: #1372061,
    #1378821)

ubuntu-settings-components (0.6+15.10.20150915-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Daniel d'Andrada ]
  * Avoid creating a deluge of deprecation warnings

  [ Lukáš Tinkl ]
  * Use the standalone month name for the calendar caption

  [ Nick Dedekind ]
  * Crop icons to aspect ratio inside UbuntuShapes. (LP: #1450229)

ubuntu-settings-components (0.6+15.10.20150903-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Lukáš Tinkl ]
  * Setup message extraction, load the catalog from the plugins (LP:
    #1436912)

ubuntu-settings-components (0.6+15.10.20150716-0ubuntu1) wily; urgency=medium

  [ Michael Zanetti ]
  * Tell the layout what size we want the icons to be

  [ Nick Dedekind ]
  * Don't use preferred values inside Standard item compoonent Loader.
    (LP: #1448716)
  * Multiline support for message replies (lp#1396058) (LP: #1396058)

ubuntu-settings-components (0.6+15.10.20150518-0ubuntu1) wily; urgency=medium

  [ CI Train Bot ]
  * New rebuild forced.

  [ Nick Dedekind ]
  * ServerPropertySynchorniser - Do not update to old server value when
    the control is no longer buffering.

ubuntu-settings-components (0.6+15.04.20150409.1-0ubuntu1) vivid; urgency=medium

  [ Nick Dedekind ]
  * Added ServerActivationSync

  [ CI Train Bot ]
  * New rebuild forced.

ubuntu-settings-components (0.5+15.04.20150123.1-0ubuntu1) vivid; urgency=medium

  [ Sebastien Bacher ]
  * Updated version, so the users of the new property can update their depends

ubuntu-settings-components (0.5-0ubuntu1) UNRELEASED; urgency=medium

  * Added SyncSwitch & SyncCheckBox components

ubuntu-settings-components (0.4+15.04.20141105-0ubuntu1) vivid; urgency=low

  [ Sebastien Bacher ]
  * Get the string translation from telephony-service, that's a
    workaround but ubuntu-settings-components is not currently setup for
    translations (LP: #1389234)

ubuntu-settings-components (0.4+15.04.20141104-0ubuntu1) vivid; urgency=low

  [ Nick Dedekind ]
  * Enable send button on input composition (LP: #1369737)

ubuntu-settings-components (0.4+14.10.20140926-0ubuntu1) utopic; urgency=low

  * New rebuild forced

ubuntu-settings-components (0.4+14.10.20140918-0ubuntu1) utopic; urgency=low

  [ Nick Dedekind ]
  * Added ability to use try*. Added target for test files in qcreator.

ubuntu-settings-components (0.4-0ubuntu1) UNRELEASED; urgency=medium

  [ Nick Dedekind ]

  * Updated components UI for design review

ubuntu-settings-components (0.3+14.10.20140708-0ubuntu1) utopic; urgency=medium

  [ Nick Dedekind ]
  * Added plugin module for Ubuntu.Settings.Menus
  * Added TransferMenu

ubuntu-settings-components (0.2+14.10.20140701.2-0ubuntu2) utopic; urgency=medium

  * debian/control:
    list qtdeclarative5-ubuntu-ui-toolkit-plugin-gles as an alternative
    choice, since...

Read more...

Changed in ubuntu-settings-components (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2015-10-26
Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments