Previews not using DDTP translations for descriptions (like the Software Centre or Synaptic do)

Bug #1171163 reported by Pierre Slamich on 2013-04-21
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Software Center
Status tracked in Trunk
Stable-13-10
Fix Released
Undecided
Unassigned
Stable-5-6
Triaged
Undecided
Unassigned
Trunk
Fix Released
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
unity-lens-applications
Low
Unassigned
software-center (Ubuntu)
High
Unassigned
Raring
High
Unassigned

Bug Description

The Unity Previews lens is not using DDTP translations for package descriptions (like the Software Centre or Synaptic do).
While application titles are translated, translations of the descriptions are not fetched at all (while they have been translated for a while).

Two questions :
- in the lens, where are the titles fetched from ?
  --The pristine DDTP (http://translations.launchpad.net/ddtp-ubuntu/raring/)
  --the tweaked version for Ubuntu called app-install-data (https://translations.launchpad.net/ubuntu/raring/+source/app-install-data-ubuntu/+pots/app-install-data) which doesn't cover all packages, and not their full descriptions.

An example: XScavenger
- Marked as translated in the DDTP both in Quantal and Raring: http://nightmonkey.ubuntu.hu/#release=raring&language=fr&view=pack&repo=universe&isok=all&rownumber=100&sortpopcon=dsc&packagename=xscavenger&page=null
-Shown in English in the Lens
-Shown in French in the Software Centre
-Shown in French in Synaptic

Can it be fixed ?

Related branches

Pierre Slamich (pierre-slamich) wrote :

Here's an untested patch by MVO (was on a train while sending it)

the attached patch against the "dbus-data-provider" fixes the issue. To test you can run:
$ PYTHONPATH=. ./software-center-dbus
you probably have to kill the old software-center-data provider first.

Sebastien Bacher (seb128) wrote :

Confirmed that the patch from mvo fixes the issue ;-)

Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in unity-lens-applications:
status: New → Invalid
importance: Undecided → Low

The attachment "Quick untested patch by mvo" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pierre Slamich (pierre-slamich) wrote :

I was wondering if it was possible to apply the patch and release it in Raring, before Saucy ?

Adolfo Jayme (fitojb) wrote :

@Pierre: all patches that could go through SRU need to be tested and deployed in the development release first...

Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
tags: added: raring saucy
Changed in ubuntu-translations:
milestone: none → saucy-user-interface-freeze
Michael Vogt (mvo) on 2013-05-27
Changed in software-center (Ubuntu Raring):
status: New → Confirmed
importance: Undecided → High
Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
dobey (dobey) on 2013-05-29
Changed in software-center (Ubuntu):
status: Fix Committed → Confirmed
Dave Morley (davmor2) on 2013-08-13
tags: added: u1-notrack
dobey (dobey) on 2013-11-25
Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in software-center (Ubuntu Raring):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers