Apport hook for ubiquity (included) not translated

Bug #1059170 reported by Thibault D on 2012-09-30
This bug report is a duplicate of:  Bug #855337: Apport hooks need localisation. Edit Remove
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
Ubuntu Translations
Undecided
Unassigned
apport (Ubuntu)
Undecided
Unassigned

Bug Description

The information message appeared after doing :
1/ ALT+F2 ubuntu-bug ubiquity
2/ Ubuntu will ask to confirm the authentication
3/ Click on Cancel
4/ The following message appears : "The debug file from your installation would help us a lot but includes the password you used for your user when installing Ubuntu. Do you want to include this log file?"

This string is from an included hook in Apport and should therefore be translated by Apport.

Thibault D (thibdrev) wrote :
Thibault D (thibdrev) wrote :
description: updated
Thibault D (thibdrev) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in apport (Ubuntu):
status: New → Confirmed
summary: - [french] apport > information message not localized
+ information message not localized
tags: added: i18n precise quantal

Message 4 (see bug description) is in /apport/data/package-hooks/source_ubiquity.py but not in translation template.

The other two strings are also package-hooks. See following bug for more details: https://bugs.launchpad.net/ubuntu/+source/apport/+bug/855337

Changed in apport:
status: New → Confirmed
Hendrik Knackstedt (hennekn) wrote :

Unlike bug 855337, this string is coming from apport, so apport is responsible for translating it.

summary: - information message not localized
+ Apport hook for ubiquity (included) not translated
description: updated
Martin Pitt (pitti) wrote :

I don't plan to make package hooks translatable. You need to report bugs in English anyway, so if you don't speak English there is little value in reporting them.

Changed in apport (Ubuntu):
status: Confirmed → Won't Fix
Changed in apport:
status: Confirmed → Won't Fix
status: Won't Fix → Invalid
Hendrik Knackstedt (hennekn) wrote :

It just looks odd if the whole system is translated but these particular messages are in English. However, you do not have to speak English to report bugs. Well, LP is only available in English right now but you could still report a bug in another language if you find somebody to translate it for you (e.g. Ubuntu Translator teams) and you achieve to submit it somehow (you could maybe understand a button label without knowing a lot of English).

This would be easier if LP was localized to make it possible for non-English-speaking users to report bugs but that is a different issue.

In addition, this is a privacy issue even though it is a minor problem because of "sensitive information" contained in log files.

I'll take a look at it when I have some spare time. Maybe you could consider a patch if it gets submitted.

Changed in ubuntu-translations:
status: New → Confirmed

Hendrik Knackstedt [2013-03-25 21:56 -0000]:
> I'll take a look at it when I have some spare time. Maybe you could
> consider a patch if it gets submitted.

Yes, I would, but I still think that actually translating these hooks
will be unnecessary human effort.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers