Not working on GTK 3 undecorated windows

Bug #1263317 reported by mightymouse2045 on 2013-12-21
56
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Ubuntu theme
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Gnome-shell 3.10.2
Fedora 20

There appears to be no window decorations for any gtk3 windows. Nautilus, gnome control panel, gnome tweak tools etc

There are no resize handles, shadows, borders, rounded corners etc

This afftects Gnome-Shell 3.10 to 3.11, on both Fedora 19,&20 and Ubuntu 13.10 up

I've tested the Ambiance and Radiance themes and both these aren't playing nicely.

I hope this is still being maintained becuase this is my favourite gtk theme :P

Related branches

Adolfo Jayme (fitojb) on 2014-01-12
Changed in ubuntu-themes:
status: New → In Progress
Dmitry Shachnev (mitya57) wrote :

Adolfo: I don't think my branch fixes *this* bug. It only moves the close button and fixes the gradient in some apps.

Changed in ubuntu-themes:
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Rafal (rpawluk) wrote :

I have the same problem on gnome-shell 3.10.4 shipped with Ubuntu 14.04 for Ambiance and Radiance. No possibility ro resize, no shadows, etc..
For Adwaita (dafault) all works correctly.

Robert Schroll (rschroll) wrote :

The linked patch fixes all of the problems I've noticed so far. Thanks!

mightymouse2045 (eagleeyes426) wrote :

Nice one - i'll test it out now :)

mightymouse2045 (eagleeyes426) wrote :

patching file Ambiance/gtk-3.0/apps/unity.css
Hunk #1 FAILED at 6.
Hunk #2 FAILED at 19.
2 out of 2 hunks FAILED -- saving rejects to file Ambiance/gtk-3.0/apps/unity.css.rej
patching file Ambiance/gtk-3.0/gtk-main.css
Hunk #1 succeeded at 34 (offset -1 lines).
patching file Ambiance/gtk-3.0/gtk-widgets.css
Hunk #1 succeeded at 379 (offset -2 lines).
Hunk #2 succeeded at 395 (offset -2 lines).
Hunk #3 succeeded at 410 (offset -2 lines).
Hunk #4 succeeded at 425 (offset -2 lines).
Hunk #5 succeeded at 440 (offset -2 lines).
Hunk #6 succeeded at 455 (offset -2 lines).
Hunk #7 succeeded at 469 (offset -2 lines).
Hunk #8 succeeded at 493 (offset -2 lines).
Hunk #9 succeeded at 700 (offset 10 lines).
Hunk #10 succeeded at 716 (offset 3 lines).
Hunk #11 succeeded at 738 (offset 8 lines).
Hunk #12 succeeded at 755 (offset 8 lines).
Hunk #13 succeeded at 763 (offset 8 lines).
Hunk #14 FAILED at 778.
Hunk #15 succeeded at 926 (offset -1 lines).
Hunk #16 succeeded at 989 (offset -3 lines).
Hunk #17 succeeded at 1113 (offset -7 lines).
Hunk #18 succeeded at 1124 (offset -7 lines).
Hunk #19 succeeded at 1179 (offset -7 lines).
Hunk #20 succeeded at 1691 (offset -1 lines).
Hunk #21 succeeded at 1877 with fuzz 2 (offset 2 lines).
Hunk #22 succeeded at 1973 (offset 4 lines).
Hunk #23 succeeded at 1983 (offset 4 lines).
Hunk #24 succeeded at 2009 (offset 4 lines).
Hunk #25 succeeded at 2046 (offset 4 lines).
Hunk #26 succeeded at 2054 (offset 4 lines).
Hunk #27 succeeded at 2075 (offset 4 lines).
Hunk #28 succeeded at 2120 (offset 35 lines).
Hunk #29 succeeded at 2131 (offset 35 lines).
Hunk #30 succeeded at 2143 (offset 35 lines).
Hunk #31 succeeded at 2160 (offset 35 lines).
Hunk #32 succeeded at 2192 (offset 52 lines).
1 out of 32 hunks FAILED -- saving rejects to file Ambiance/gtk-3.0/gtk-widgets.css.rej

With the changes that did work it all still looks the same to me, no borders etc etc

mightymouse2045 (eagleeyes426) wrote :

The package I have installed is:

light gtk3-theme 13.10-0.3.20131014bzr324.fc20

What's the repo again so I can just check out the version in there?

mightymouse2045 (eagleeyes426) wrote :

Ok I updated to the latest revision, and applied the patch, which applied successfully, but there are still major problems with it. It doesn't apply smoothly so the title bars display some striped bar, and the window title is smaller than the window borders.

I also tried the script ambiance to radiance because radiance is the theme I use and it's got more issues than ambiance...

mightymouse2045 (eagleeyes426) wrote :

Here's a screenshot:

http://i.imgur.com/HNStrnF.png

Adolfo Jayme (fitojb) on 2014-07-07
summary: - Not working on GTK 3 windows
+ Not working on GTK 3 undecorated windows
dronus (paul-geisler) wrote :

Applies to gnome-fallback / gnome-flashback sessions as well.

The themes only to be useable on Unity.

dronus (paul-geisler) wrote :

Also, as for Ubuntu 16.04, there are more applications migrated to borderless windows, all of them can't be resized in session types other than Unity.

OwN (own3mall) wrote :
Daniel van Vugt (vanvugt) wrote :

Seems to work fine in 17.10, and probably other recent releases too.

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-themes:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers