[indicators] Align indicators correctly to grid units

Reported by John Lea on 2013-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UX
High
John Lea
Ubuntu theme
High
Matthieu James
Unity 8
High
Nick Dedekind
ubuntu-themes (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

Align indicators correctly to grid units. Most indicators need 3gu, but the bluetooth indicator needs only 2gu and the time requires 4gu.

See attached visual designs which include a grid unit underlay showing the correct spacing.

Related branches

lp:~nick-dedekind/unity8/lp1236267
Merged into lp:unity8 at revision 514
PS Jenkins bot: Approve (continuous-integration) on 2013-11-08
Albert Astals Cid: Approve on 2013-10-31
John Lea (johnlea) wrote :
John Lea (johnlea) wrote :
Changed in ubuntu-ux:
importance: Undecided → High
status: New → Fix Committed
Changed in unity8:
importance: Undecided → High
status: New → Confirmed
Changed in unity8:
assignee: nobody → Nick Dedekind (nick-dedekind)
status: Confirmed → In Progress
Nick Dedekind (nick-dedekind) wrote :

I don't want to hardcode width values into specific indicators. This will become difficult to maintain later on.
For labels: I can round up the widths to the closest gu. If the "10:00" string takes between 3-4gu, then it will be 4gu.
For icons: We need icons of correct aspect to do custom widths. If you want a 3gu icon in the panel (3gu high), then they must be 1:1 aspect including padding. If you want a 2gu icon then it must be between 2:4 and 2:3 padding inclusive, etc.

Note: For svgs, the document size must be the correct aspect.
I've included an example of the bluetooth icon we need to accomplish this.

Changed in ubuntu-themes:
importance: Undecided → High
assignee: nobody → Matthieu James (tiheum)
tags: added: needs-qml-test
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:unity8 at revision 514, scheduled for release in unity8, milestone phone-v1-freeze

Changed in unity8:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2013-11-21
Changed in unity8 (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (6.6 KiB)

This bug was fixed in the package unity8 - 7.84+14.04.20131128.2-0ubuntu1

---------------
unity8 (7.84+14.04.20131128.2-0ubuntu1) trusty; urgency=low

  [ Michal Hruby ]
  * Depend on the separate scopes plugin
  * Move the BottomBar* DBus communicator to the Utils plugin.

  [ Michał Sawicz ]
  * Wait for DashHome to be available in tst_Shell. (LP: #1254898)
  * Use plugindir from unity-shell-api.pc.
  * Expect stop in upstart job and raise in case of surfaceflinger. (LP:
    #1239876)

  [ Albert Astals ]
  * Fix time test in Qt 5.2 Make factors an array instead of a
    object/dict Objects/dicts are unordered by definition, it happened
    that Qt 5.0 gave them in the orrder we wanted, but with Qt 5.2 is
    failing, and we don't even need the "key", so array works as well
    :).
  * Test that the dash hswipe is disabled while the inner stuff is
    moving .
  * Skip restMaximizeVisibleAreaMoveUpAndShowHeader, it's causing too
    many failed runs And we are confident it's failing because of the
    suboptimal scenegraph run in 5.0.x.
  * Make Dash::test_show_scope_on_load more robust If we are testing
    showScopeOnLoaded make sure we force a scope reload after we set it,
    otherwise it may just happen that the scope has already been loaded
    and the expectaction that we'll change the list to it is just wrong.
  * Dash renderer signals: No need to pass the model up and down Whoever
    is listening to the signal has access to the item that emits the
    signal and has the model right there accessible if needs it.
  * LVWPH: Fix header going bad when setContentHeight ends up moving the
    viewport How to reproduce the bug easily without the patch: * In the
    Dash Home, search for london * Scroll to the bottom * Start moving
    to the apps scope very slowly * At around 3/4 of the move you'll see
    the header in the home scope went to a bad position * Go back to the
    Dash Home. (LP: #1237942, #1246351)
  * Remove unused AppInfo and VideoInfo files .
  * Kill unused ApplicationsFilterGrid.qml .
  * Unify ScopeView and GenericScopeView .
  * Fix header getting lost as per bug 1245824. (LP: #1245824)
  * Remove unused Time.js and its test .
  * Do not include the QtQml megaheader Include only qqml.h which is
    what we need in these files.
  * Don't do stuff if our parent context is gone We'll be gone soon too
    (and crash probably) so don't do anything. This looks a bit like a
    workaround, wait for 5.2 better painting/dispatching loop to see if
    this is not needed anymore, we find a better way to do it, or we
    decide this is fine.

  [ Lars Uebernickel ]
  * Allow setting different indicator positions for different profiles.

  [ Mirco Müller ]
  * Added checkbox for toggling between echo-modes of password-
    entryfields in ext. snap-decisions.
  * Fixes bug #1200569. (LP: #1200569)

  [ Andrea Cimitan ]
  * Switch to application scope when a dash swipe is taking place and an
    app is on foreground. (LP: #1231996)
  * Shifts wallpaper rendering for greeter lockscreen to be inline with
    shell. (LP: #1231731)
  * Dinamically load the Carousel/Filtergrid with more than 6 items.
    (LP: #1226288, #1234105)
  * R...

Read more...

Changed in unity8 (Ubuntu):
status: Fix Committed → Fix Released
Michał Sawicz (saviq) on 2013-11-29
Changed in unity8:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers