Use New Radio/Check Assets for Gtk-2.0 Theme Consistency

Bug #1046129 reported by James Schriver on 2012-09-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu theme
Medium
James Schriver
ubuntu-mate-artwork (Ubuntu)
Medium
Martin Wimpress
ubuntu-themes (Ubuntu)
Wishlist
James Schriver

Bug Description

Add new radio and check assets for use with gtk-2.0 Ambiance/Radiance for theme consistency.

Related branches

James Schriver (dashua) wrote :
James Schriver (dashua) wrote :
James Schriver (dashua) on 2012-09-05
summary: - Use New Radio/Check Assets for Gtk-2.0 Consistency
+ Use New Radio/Check Assets for Gtk-2.0 Theme Consistency
Changed in light-themes:
assignee: nobody → James Schriver (dashua)
importance: Undecided → Low
importance: Low → Medium
status: New → In Progress
Adolfo Jayme (fitojb) on 2013-01-31
affects: light-themes (Ubuntu) → ubuntu-themes (Ubuntu)
Adolfo Jayme (fitojb) on 2013-02-25
affects: light-themes → ubuntu-themes
Adolfo Jayme (fitojb) wrote :

James, can you please refresh and re-propose your branch for merging against lp:ubuntu-themes?

Changed in ubuntu-themes:
status: In Progress → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
James Schriver (dashua) wrote :

I'll get to this. I've been in a bug squashing mood lately and finally put my Android flashing addiction to the side.

James Schriver (dashua) wrote :

Ok, re-based. Looks good to me. Please check it out.

Changed in ubuntu-themes:
status: New → Fix Committed
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → James Schriver (dashua)
Mateusz Maćkowski (m4tx) wrote :

New Radio and Check buttons looks fine for me (finally), but there's one more matter. That's only 2 out of the N widgets that needs more consistency in look compared to GTK3. That's why I created the 1207545 bug report, but it was marked as duplicate...

Mateusz Maćkowski (m4tx) wrote :

By the way, these 2 buttons still looks different in these 2 toolkits. Or, to be more exact, theirs highlight states looks different. Although, they look better than before.

Mateusz Maćkowski (m4tx) wrote :

Hmmm... I'm not sure, but I think that the theme now breaks the Gimp's toolbox look. Other Gimp UI elements look fine, but the toolbox looks like with Raleigh theme. I'm not sure if this is because this change (new radio/check buttons) in the theme, so I please someone to confirm it. I attached a screenshot describing the problem.

Adolfo Jayme (fitojb) on 2014-12-09
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
Changed in ubuntu-mate-artwork (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Martin Wimpress (flexiondotorg)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-artwork - 17.04.9

---------------
ubuntu-mate-artwork (17.04.9) zesty; urgency=medium

  * Fix GTK2+ radio and checkbox assets to match GTK3+. (LP: #1046129)
  * Fix GTK2+ Notebooks, Progress bars and Sliders so they match GTK3+.
  * Fix GTK2+ Ambiant-MATE so that Qt4/Qt5 applications are styled correctly.
  * Fix GTK2+ runtime warnings.
  * Fix GTK2+ and GTK3+ Notebook background and font colours.
  * Fix GTK3+ switches, particularly in headerbars.
  * Fix GTK3+ button hover focus.
  * Fix background and colours for MATE Terminal and GNOME Terminal.
  * Fix box-shadow on desktop windows.
  * Fix styling for Brisk Menu and MATE Menu.
  * Fix popover modelbuttons.
  * Fix solid-csd border colors.
  * Fix border images for Ambiant-MATE Dark.
  * Add missing gtkstyle-fallback settings.
  * Add missing GtkSourceView styles for Ambiant-MATE-Dark.
  * Add Ubuntu MATE community contributed wallpaper, Ubuntu MATE Wet.
  * Remove obsolete GTK2+ styling.

 -- Martin Wimpress <email address hidden> Sun, 26 Mar 2017 21:38:38 +0100

Changed in ubuntu-mate-artwork (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers