Font in Terminal is incorrectly massive since recent update

Bug #1514519 reported by Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„ on 2015-11-09
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
kevin gunn
Ubuntu Terminal App
High
Alan Pope ๐Ÿบ๐Ÿง๐Ÿฑ ๐Ÿฆ„
logviewer
New
Undecided
Unassigned
qtubuntu (Ubuntu)
High
Daniel d'Andrada
unity8 (Ubuntu)
High
Daniel d'Andrada

Bug Description

Last know good image: 166
Changes on 167: http://people.canonical.com/~lzemczak/landing-team/ubuntu-touch/rc-proposed/167.commitlog
Landing request for Unity8/Mir: https://requests.ci-train.ubuntu.com/#/ticket/564

After updating my Nexus 4 and Krillin over the weekend I notice the terminal now has really huge text. Even dialling down the font size in the app to 8pt results in huge unusable text.

Before:- http://people.canonical.com/~alan/screenshots/device-2015-11-09-165137.png
After:- http://people.canonical.com/~alan/screenshots/device-2015-11-09-165130.png

With the same font size setting on both.

Related branches

Jean-Baptiste Lallement (jibel) wrote :

Conformed on krillin rc-proposed 167

Changed in canonical-devices-system-image:
milestone: none → ww46-2015
importance: Undecided → High
description: updated
description: updated
tags: added: regression-proposed
Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
kevin gunn (kgunn72) wrote :

from debug we were doing last week, I logged this bug 1513816
we are seeing that the terminal app font is not following the grid units - but it should ?

Michael Zanetti (mzanetti) wrote :

FWIW, this affects the Logviewer app in the store too.

Michael Zanetti (mzanetti) wrote :

Here's the line of code in the logviewer app that is responsible for it:

http://bazaar.launchpad.net/~vtuson/logviewer/trunk/view/head:/app/ui/LogPage.qml#L183

Indeed, it does hardcode the font size to a pixel value. So while I confirm something has changed recently, it seems to reveal improper use of components in apps instead of real breakage in the system.

Michael Zanetti (mzanetti) wrote :

Here's the terminal app:

http://bazaar.launchpad.net/~ubuntu-terminal-dev/ubuntu-terminal-app/reboot/view/head:/src/plugin/qmltermwidget/lib/qtermwidget.cpp#L281

One thing that I've overlooked in the previous comment is that it uses "font.pointSize", not font.pixelSize. Same for the terminal app. That should indeed be correct.

So seems to be an issue in the calculation of font's pointSize after all.Sorry for the wrong assessment in the previous comment.

Changed in canonical-devices-system-image:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Albert Astals Cid (aacid) wrote :

If we're sure the regression is in that landing https://code.launchpad.net/~osomon/qtubuntu/ubuntuscreen-physicalsize/+merge/273965 seems to be one possible candidate for font size changes.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
kevin gunn (kgunn72) on 2015-11-10
Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in qtubuntu (Ubuntu):
importance: Undecided → High
Gerry Boland (gerboland) wrote :

I'd need to dig, but I'd guess the DPI value in the QPA is now being correctly calculated, since we've wired up the physical size, qt can calculate a DPI. But we also live in the X world where DPI is nearly always 96.

So need to figure out the right thing to do...

Changed in unity8 (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Changed in qtubuntu (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Gerry Boland (gerboland) wrote :

http://bazaar.launchpad.net/~mir-team/qtmir/trunk/view/head:/src/platforms/mirserver/screencontroller.cpp#L157 is the relevant line of code. This triggers after compositor start, to match mir DisplayBuffers with Qt Screens. I've designed it under the assumption that each Mir Display will always have a DisplayBuffer on compositor start.

Gerry Boland (gerboland) wrote :

oops wrong bug, please ignore above

Browser is affected too

Changed in qtubuntu (Ubuntu):
status: Confirmed → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
Daniel d'Andrada (dandrader) wrote :

Yes, this is caused by the recent qtubuntu change where we now correctly provide the QScreen physical size.

But the font size is correct. I just measured it with a ruler on my Nexus 4. I set the terminal font size to 10 (via the apps configuration GUI) and the text height is around 3 mm. Which matches with my expectation if the size is being set in points.

One point is ~ 0.35mm. So a 10 points font would have text of height around 3.5 mm.

Before that change, QScreen was defaulting to 100 dpi when calculating its physical size, which is way lower than the 318 of Nexus 4. So yes, I would expect text sizes in points (as opposed to pixels) to get 3 times bigger after that qtubuntu fix.

So the fix for this bug is to have ubuntu-terminal-app to size its VT font in pixels and to factor in grid units when doing to. The whole UI is measured in grid units and ubuntu-terminal-app's VT font should be not exception to that.

But if you do insist in having the VT font size in a physical unit (ie, point size) then please do provide a broader range of values in that slider.

Changed in qtubuntu (Ubuntu):
status: In Progress → Invalid
Changed in unity8 (Ubuntu):
status: In Progress → Invalid
Changed in ubuntu-terminal-app:
status: New → In Progress
assignee: nobody → Alan Pope ๎ƒฟ (popey)
importance: Undecided → High
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-terminal-app:
status: In Progress → Fix Released

Closing C.S.I. task, each application has to be fixed.

Changed in canonical-devices-system-image:
status: In Progress → Invalid
Pat McGowan (pat-mcgowan) wrote :

marking fixed for the terminal which is pre-installed for some images

Changed in canonical-devices-system-image:
status: Invalid → Fix Released

Fix committed into lp:ubuntu-terminal-app at revision 142, scheduled for release in ubuntu-terminal-app, milestone 2014-12-11

Changed in ubuntu-terminal-app:
status: Fix Released → Fix Committed
Changed in ubuntu-terminal-app:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers