take_picture_with_rear_camera fails on Wily

Bug #1469462 reported by Brendan Donegan on 2015-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-system-tests
Medium
Brendan Donegan

Bug Description

Running the ubuntu-system-tests on Wily, the take_picture_with_rear_camera test failed with:

Traceback (most recent call last):
  File "/tmp/adt-run.zVUIrr/build.k16/real-tree/ubuntu_system_tests/tests/test_camera.py", line 96, in test_take_picture_with_rear_camera
    bottom_edge = self.camera_app.open_bottom_edge()
  File "/tmp/adt-run.zVUIrr/build.k16/real-tree/ubuntu_system_tests/helpers/camera.py", line 49, in open_bottom_edge
    bottom_edge.open()
  File "/tmp/adt-run.zVUIrr/deps/usr/lib/python3/dist-packages/autopilot/introspection/dbus.py", line 416, in __getattr__
    (self.__class__.__name__, name))
AttributeError: Class 'Panel' has no attribute 'open'.

In the camera_app package in Wily the inheritance tree looks like:

class CameraCustomProxyObjectBase(dbus.CustomEmulatorBase) <camera-app>
-> class Panel(CameraCustomProxyObjectBase) <camera-app>
-> -> class Panel(Panel) <ubuntu-system-tests>

this is different than in trunk where it's:

class Panel(ubuntuuitoolkit.UbuntuUIToolkitCustomProxyObjectBase) <camera-app>
-> class Panel(Panel) <ubuntu-system-tests>

I assume this won't work since our emulator_base is the UITK class in ubuntu-system-tests. Not sure if changing the emulator_base to CustomEmulatorBase would break anything

Changed in ubuntu-system-tests:
assignee: nobody → Brendan Donegan (brendan-donegan)
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → High
importance: High → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers