Facebook account login not triggered from the facebook web app.

Bug #1596478 reported by Dave Morley on 2016-06-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
Online Accounts setup for Ubuntu Touch
Critical
Alberto Mardegan

Bug Description

STEPS:
1. Do a fresh flash of rc-proposed
2. Tap on the facebook web app launcher

EXPECTED:
Online accounts popup for facebook login

ACTUAL:
Error pops up only option is to swipe close the application.

This is working as expected on stable so is a regression in the current rc-proposed image.

Related branches

Dave Morley (davmor2) on 2016-06-27
summary: - Facebook account login not triggered from the facebook click app.
+ Facebook account login not triggered from the facebook web app.
Dave Morley (davmor2) on 2016-06-27
description: updated
tags: added: lt-blocker regression-proposed
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → David Barth (dbarth)
milestone: none → 12
Alberto Mardegan (mardy) wrote :

I cannot reproduce it. Can you reproduce it everytime?

If so, please run the following command:

    OAU_LOGGING_LEVEL=2 OAU_DAEMON_TIMEOUT=9999 online-accounts-service

then reproduce the bug, and attach the output of the command to this bug.

affects: account-plugins → ubuntu-system-settings-online-accounts
Changed in ubuntu-system-settings-online-accounts:
status: New → Incomplete
Download full text (3.6 KiB)

I get this when trying the above:

phablet@ubuntu-phablet:~$ OAU_LOGGING_LEVEL=2 OAU_DAEMON_TIMEOUT=9999
online-accounts-service

(process:7433): accounts-glib-WARNING **: Loading service
com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
file failed

(process:7433): accounts-glib-WARNING **: Loading service
com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
file failed

(process:7433): accounts-glib-WARNING **: Loading service
com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
file failed

(process:7433): accounts-glib-WARNING **: Loading service
com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
file failed

(process:7433): accounts-glib-WARNING **: Loading service
com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
file failed
service.cpp 42 requestAccess Got request: QMap(("application",
QVariant(QString,
"com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook") ) ( "pid" ,
 QVariant(uint, 7486) ) ( "provider" , QVariant(QString, "facebook") ) (
"windowId" , QVariant(uint, 7486) ) )
utils.cpp 49 apparmorProfileOfPeer App ID:
"com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.4.1"
request-manager.cpp 113 runQueue Head: OnlineAccountsUi::Request(0x1729770)
mir-helper.cpp 151 session_event_callback Prompt Session state updated to 1
Loading module: 'libubuntu_application_api_touch_mirclient.so.3.0.0'
/usr/bin/online-accounts-ui: unrecognized option '--socket'
/usr/bin/online-accounts-ui: unrecognized option '--profile'
ui-server.cpp 103 onDataReady QMap(("code", QVariant(QString, "process") )
( "data" , QVariant(QVariantMap, QMap(("application", QVariant(QString,
"com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook") ) ( "pid" ,
 QVariant(uint, 7486) ) ( "provider" , QVariant(QString, "facebook") ) (
"windowId" , QVariant(uint, 7486) ) ) ) ) ( "id" , QVariant(int, 0) ) (
"interface" , QVariant(QString, "com.ubuntu.OnlineAccountsUi") ) (
"profile" , QVariant(QString,
"com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.4.1") ) )
Given applicationId doesn't match profile
request.cpp 272 fail "com.ubuntu.OnlineAccountsUi.InvalidApplication"
"Invalid client application"
ui-proxy.cpp 186 onDataReady QMap(("code", QVariant(QString, "failed") ) (
"errmsg" , QVariant(QString, "Invalid client application") ) ( "errname" ,
 QVariant(QString, "com.ubuntu.OnlineAccountsUi.InvalidApplication") ) (
"id" , QVariant(int, 0) ) ( "interface" , QVariant(QString,
"com.ubuntu.OnlineAccountsUi") ) )
ui-proxy.cpp 377 ~UiProxy
ui-server.cpp 86 ~UiServerPrivate
mir-helper.cpp 151 session_event_callback Prompt Session state updated to 0
QProcess: Destroyed while process ("/usr/bin/online-accounts-ui") is still
running.

On Mon, Jun 27, 2016 at 3:37 PM, Alberto Mardegan <
<email address hidden>> wrote:

> I cannot reproduce it. Can you reproduce it everytime?
>
> If so, please run the following command:
>
> OAU_LOGGING_LEVEL=2 OAU_DAEMON_TIMEOUT=9999 online-accounts-service
>
> then reproduce the bug, and attach the output of the command to this
> bug.
>
> ** Project changed: account-plugins => ubuntu-sy...

Read more...

David Barth (dbarth) wrote :
Download full text (4.1 KiB)

Note that this is from a fresh ubuntu-device-flash (krillin image 367)
And after having removed all local config and the Facebook account in USSOA

rm -rf ~/.local/share/com.ubuntu.developer.webapps.webapp-facebook; rm -rf
~/.config/com.ubuntu.developer.webapps.webapp-facebook; rm -rf
.cache/com.ubuntu.developer.webapps.webapp-facebook/

On Mon, Jun 27, 2016 at 4:58 PM, David Barth <email address hidden>
wrote:

> I get this when trying the above:
>
> phablet@ubuntu-phablet:~$ OAU_LOGGING_LEVEL=2 OAU_DAEMON_TIMEOUT=9999
> online-accounts-service
>
> (process:7433): accounts-glib-WARNING **: Loading service
> com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
> file failed
>
> (process:7433): accounts-glib-WARNING **: Loading service
> com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
> file failed
>
> (process:7433): accounts-glib-WARNING **: Loading service
> com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
> file failed
>
> (process:7433): accounts-glib-WARNING **: Loading service
> com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
> file failed
>
> (process:7433): accounts-glib-WARNING **: Loading service
> com.ubuntu.developer.webapps.webapp-googlecalendar_webapp-googlecalendar
> file failed
> service.cpp 42 requestAccess Got request: QMap(("application",
> QVariant(QString,
> "com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook") ) ( "pid" ,
> QVariant(uint, 7486) ) ( "provider" , QVariant(QString, "facebook") ) (
> "windowId" , QVariant(uint, 7486) ) )
> utils.cpp 49 apparmorProfileOfPeer App ID:
> "com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.4.1"
> request-manager.cpp 113 runQueue Head: OnlineAccountsUi::Request(0x1729770)
> mir-helper.cpp 151 session_event_callback Prompt Session state updated to 1
> Loading module: 'libubuntu_application_api_touch_mirclient.so.3.0.0'
> /usr/bin/online-accounts-ui: unrecognized option '--socket'
> /usr/bin/online-accounts-ui: unrecognized option '--profile'
> ui-server.cpp 103 onDataReady QMap(("code", QVariant(QString, "process") )
> ( "data" , QVariant(QVariantMap, QMap(("application", QVariant(QString,
> "com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook") ) ( "pid" ,
> QVariant(uint, 7486) ) ( "provider" , QVariant(QString, "facebook") ) (
> "windowId" , QVariant(uint, 7486) ) ) ) ) ( "id" , QVariant(int, 0) ) (
> "interface" , QVariant(QString, "com.ubuntu.OnlineAccountsUi") ) (
> "profile" , QVariant(QString,
> "com.ubuntu.developer.webapps.webapp-facebook_webapp-facebook_1.4.1") ) )
> Given applicationId doesn't match profile
> request.cpp 272 fail "com.ubuntu.OnlineAccountsUi.InvalidApplication"
> "Invalid client application"
> ui-proxy.cpp 186 onDataReady QMap(("code", QVariant(QString, "failed") ) (
> "errmsg" , QVariant(QString, "Invalid client application") ) ( "errname" ,
> QVariant(QString, "com.ubuntu.OnlineAccountsUi.InvalidApplication") ) (
> "id" , QVariant(int, 0) ) ( "interface" , QVariant(QString,
> "com.ubuntu.OnlineAccountsUi") ) )
> ui-proxy.cpp 377 ~UiProxy
> ui-server.cpp 86 ~UiServerPrivate
> mir-helper.cpp 151 session_event_c...

Read more...

David Barth (dbarth) on 2016-06-27
Changed in ubuntu-system-settings-online-accounts:
status: Incomplete → Triaged
Alberto Mardegan (mardy) on 2016-06-28
Changed in ubuntu-system-settings-online-accounts:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Alberto Mardegan (mardy) on 2016-06-29
Changed in ubuntu-system-settings-online-accounts:
status: Triaged → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2016-07-28
Changed in ubuntu-system-settings-online-accounts:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers