UI freezes when trying to log in from youtube scope

Bug #1544063 reported by Albert Astals Cid on 2016-02-10
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
Online Accounts setup for Ubuntu Touch
Critical
Alberto Mardegan
webapps-sprint
Critical
Alberto Mardegan

Bug Description

How to reproduce:
 * Have youtube scope favorited
 * Have a "complex" google account
 * Press the login button on youtube
 * Enter google and user password on the trusted session
 * The UI freezes after that (see attached screenshot)

A "complex" google account is my account :D I guess it is one that has more than one youtube user for the same email address that needs to show a second webpage to ask which of the users you want to use after entering the user and password, if i try with a new clean dummy user i just created the bug does not happen.

This can be fixed (not sure if with side effects) editing /usr/lib/arm-linux-gnueabihf/ubuntu-system-settings/private/Ubuntu/OnlineAccounts/Plugin/WebView.qml and changing onLoadingChanged with onLoadingStateChanged

Related branches

Albert Astals Cid (aacid) wrote :
Alberto Mardegan (mardy) on 2016-02-10
Changed in ubuntu-system-settings-online-accounts:
importance: Undecided → Critical
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

per bug #1542409 onLoadingChanged is deprecated

Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
importance: Undecided → Critical
milestone: none → ww08-2016
status: New → Confirmed
Alberto Mardegan (mardy) on 2016-02-12
Changed in webapps-sprint:
milestone: none → sprint-19
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → Critical
status: New → In Progress
Changed in ubuntu-system-settings-online-accounts:
status: Confirmed → In Progress
assignee: nobody → Alberto Mardegan (mardy)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
David Barth (dbarth) on 2016-03-08
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Committed
Changed in webapps-sprint:
status: In Progress → Fix Committed
Selene ToyKeeper (toykeeper) wrote :

Seems fixed in silo 77 (ticket 1003) today.

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2016-04-26
Changed in ubuntu-system-settings-online-accounts:
status: Fix Committed → Fix Released
Changed in webapps-sprint:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers