Use Qt::AA_ShareOpenGLContexts and drop Qt private headers usage

Bug #1387537 reported by Timo Jyrinki on 2014-10-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Online Accounts setup for Ubuntu Touch
Undecided
Alberto Mardegan
Ubuntu HTML5 UI SDK
High
Alexandre Abreu
webbrowser-app
Fix Released
Medium
Olivier Tilloy
ubuntu-html5-theme (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings-online-accounts (Ubuntu)
Undecided
Unassigned
webbrowser-app (Ubuntu)
Undecided
Olivier Tilloy

Bug Description

Update: Qt 5.4 provides Qt::AA_ShareOpenGLContexts function that should help in dropping the Qt private headers usage in ubuntu-html5-theme, ubuntu-system-settings-online-accounts and webbrowser-app.

More information about Qt 5.4 at: https://wiki.ubuntu.com/Touch/QtTesting

--- original report ---

There's a critical bug that is being fixed with the following MP:

https://code.launchpad.net/~abreu-alexandre/ubuntu-system-settings-online-accounts/use-hw-compositiing-oxide-rtm-1409/+merge/239999

This bug is about removing the need for that, since using private headers causes extra pain for Qt migrations and we should minimize their usage.

Could Oxide provide this somehow else, so that only Oxide would use the private headers (like it already does)?

Update: not blocker for Qt 5.4, but simply something that would help Qt transitions in future by removing 5 packages from the transition list

Related branches

summary: - Should not use private Qt headers
+ online-accounts should not use private Qt headers

+1 this feels like unnecessary technical details, which could be hidden behind an interface or configuration option.

summary: - online-accounts should not use private Qt headers
+ Oxide should provide an interface to avoid webbrowser-app / online-
+ accounts using private Qt headers
David Barth (dbarth) on 2014-12-02
Changed in oxide:
milestone: none → branch-1.5

Adding High priority and qt5.4 tag since the problem seems to be just spreading, latest to ubuntu-html5-theme. All of them are now also broken and need manual patching for Qt 5.4, because all duplicate the same small private headers usage.

Changed in ubuntu-system-settings-online-accounts:
importance: Undecided → High
Changed in webbrowser-app:
importance: Undecided → High
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
importance: Undecided → High
Changed in oxide-qt (Ubuntu):
importance: Undecided → High
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
Changed in ubuntu-html5-theme:
importance: Undecided → High
Changed in ubuntu-html5-theme (Ubuntu):
importance: Undecided → High
tags: added: qt5.4
Timo Jyrinki (timo-jyrinki) wrote :

(webbrowser and html5-theme have the necessary #if clause done so far, u-s-s-online-accounts pending)

Changed in ubuntu-system-settings-online-accounts:
importance: High → Undecided
Changed in ubuntu-html5-theme:
importance: High → Undecided
Changed in webbrowser-app:
importance: High → Undecided
Changed in ubuntu-html5-theme (Ubuntu):
importance: High → Undecided
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
importance: High → Undecided
Changed in webbrowser-app (Ubuntu):
importance: High → Undecided
Changed in ubuntu-html5-theme (Ubuntu):
status: New → Incomplete
Changed in ubuntu-system-settings-online-accounts:
status: New → Incomplete
Changed in ubuntu-html5-theme:
status: New → Incomplete
Changed in webbrowser-app:
status: New → Incomplete
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: New → Incomplete
Changed in webbrowser-app (Ubuntu):
status: New → Incomplete
Timo Jyrinki (timo-jyrinki) wrote :

And one more update to get the bug off other upstreams' radar for now since they can't do anything about the bug until Oxide provides the functionality.

Changed in oxide:
milestone: branch-1.5 → branch-1.6
Olivier Tilloy (osomon) wrote :

Wouldn’t the newly-introduced (in Qt 5.4) Qt::AA_ShareOpenGLContexts attribute help in that case?

description: updated
Chris Coulson (chrisccoulson) wrote :

Having taken a quick glance at the code, it does look like Qt::AA_ShareOpenGLContexts would make this interface in Oxide redundant (Oxide would still need to use a private interface for getting the shared context, but that's ok)

Timo Jyrinki (timo-jyrinki) wrote :

Should we repurpose this bug so that the other components would use Qt::AA_ShareOpenGLContexts and drop the private headers usage?

tags: removed: qt5.4
summary: - Oxide should provide an interface to avoid webbrowser-app / online-
- accounts using private Qt headers
+ Use Qt::AA_ShareOpenGLContexts and drop Qt private headers usage
Changed in oxide:
status: New → Incomplete
Changed in ubuntu-system-settings-online-accounts:
status: Incomplete → Confirmed
Changed in ubuntu-html5-theme:
status: Incomplete → Confirmed
Changed in webbrowser-app:
status: Incomplete → Confirmed
Changed in ubuntu-html5-theme (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Incomplete → Confirmed
description: updated
Changed in webbrowser-app (Ubuntu):
status: Incomplete → Confirmed
description: updated
David Barth (dbarth) on 2015-02-05
Changed in oxide:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Chris Coulson (chrisccoulson) wrote :

Sounds good. Also means that there isn't anything to do in Oxide

Changed in oxide:
status: Incomplete → Invalid
David Barth (dbarth) on 2015-02-05
Changed in oxide:
assignee: Alexandre Abreu (abreu-alexandre) → nobody
Changed in ubuntu-system-settings-online-accounts:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in ubuntu-html5-theme:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in webbrowser-app:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
Changed in oxide:
milestone: branch-1.6 → none
Olivier Tilloy (osomon) on 2015-02-18
Changed in webbrowser-app:
assignee: Alexandre Abreu (abreu-alexandre) → Olivier Tilloy (osomon)
status: Confirmed → In Progress
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Olivier Tilloy (osomon)
Changed in ubuntu-html5-theme:
status: Confirmed → In Progress
Changed in ubuntu-system-settings-online-accounts:
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2015-02-24
Changed in webbrowser-app:
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package webbrowser-app - 0.23+15.04.20150224-0ubuntu1

---------------
webbrowser-app (0.23+15.04.20150224-0ubuntu1) vivid; urgency=medium

  [ Olivier Tilloy ]
  * Fix a flaky autopilot test. (LP: #1423115)
  * Use Qt::AA_ShareOpenGLContexts when building with Qt >= 5.4. (LP:
    #1387537)

  [ Riccardo Padovani ]
  * Fixed design of multiselection in history view (LP: #1412732)
 -- CI Train Bot <email address hidden> Tue, 24 Feb 2015 10:30:59 +0000

Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Olivier Tilloy (osomon) on 2015-02-26
Changed in webbrowser-app:
status: In Progress → Fix Released
David Barth (dbarth) on 2015-03-27
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Released
no longer affects: oxide-qt (Ubuntu)
no longer affects: oxide
Alberto Mardegan (mardy) on 2015-04-27
Changed in ubuntu-system-settings-online-accounts:
assignee: Alexandre Abreu (abreu-alexandre) → Alberto Mardegan (mardy)
status: Fix Released → In Progress
Changed in ubuntu-html5-theme:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-html5-theme - 0.1.2+15.10.20150520-0ubuntu1

---------------
ubuntu-html5-theme (0.1.2+15.10.20150520-0ubuntu1) wily; urgency=medium

  [ Alexandre Abreu ]
  * Fix gallery & component showcase (LP: #1450614)
  * Fix page actions; no need to create actions when none is defined
    (LP: #1455622)
  * Update debian/control to remove qt private package deps; Rely on Qt
    5.4's new API (LP: #1387537)

  [ CI Train Bot ]
  * New rebuild forced.

  [ David Barth ]
  * Add a command line tool to maintain a theme installation in an html5
    project (LP: #1451937)

 -- CI Train Bot <email address hidden> Wed, 20 May 2015 16:51:40 +0000

Changed in ubuntu-html5-theme (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-html5-theme:
status: In Progress → Fix Committed
Changed in ubuntu-html5-theme:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings-online-accounts - 0.6+15.10.20150624-0ubuntu1

---------------
ubuntu-system-settings-online-accounts (0.6+15.10.20150624-0ubuntu1) wily; urgency=medium

  [ Alberto Mardegan ]
  * Fix build with Qt 5.5 (LP: #1387537, #1421009, #1448878, #1447175)
  * Return the error name to the client (LP: #1441873)

  [ CI Train Bot ]
  * New rebuild forced.

 -- CI Train Bot <email address hidden> Wed, 24 Jun 2015 13:36:39 +0000

Changed in ubuntu-system-settings-online-accounts (Ubuntu):
status: Confirmed → Fix Released
Alberto Mardegan (mardy) on 2015-11-05
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers