two applications mixed into one in OA applications screen

Bug #1384314 reported by Kyle Nitzsche on 2014-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Online Accounts setup for Ubuntu Touch
High
Alberto Mardegan
The Savilerow project
High
Unassigned

Bug Description

The photos aggregator scope includes the facebook photos scope. The fb scope requires OA authentication and uses the OnlineAccountClient to display a scope result with the button to Login via online accounts when needed.

Naturally, the fb photos scope has an .application file. Photos needs one too and has one in my dev area.

Problem: When the user is in the photos agg scope and clicks the fb photos child scope's Login button, it works, but when you view the Facebook account in System Settings > Online Accounts on touch, the two applications are merged into one, with layers of text and a single checkbox (for enabling, disabling).

Please see attached png.

Expectation:
System Settings > Accounts > Facebook displays separate entries for every application using the service.

Related branches

Kyle Nitzsche (knitzsche) wrote :
summary: - two applications mixed into one in oa FB on touch
+ two applications mixed into one in OA FB on touch
Chris Wayne (cwayne18) on 2014-12-16
Changed in ubuntu-system-settings-online-accounts:
status: New → Confirmed
Chris Wayne (cwayne18) wrote :

We're seeing this 100% of the time now when adding an online account from an aggregator scope. That is, both the child scope (say fitbit) and the aggregator (today) both have a .application file, and we grant access from the aggregator

Changed in savilerow:
status: New → Confirmed
summary: - two applications mixed into one in OA FB on touch
+ two applications mixed into one in OA applications screen
Changed in savilerow:
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
milestone: none → ww05-2015
Alberto Mardegan (mardy) wrote :

I cannot reproduce it, but I believe that it can happen when we have two different .application files both using the same service.
I've attached a branch which fixes the graphical issue, but this setup seems anyway wrong, and it cannot be handled correctly: even with this branch, if you push the switch on one application, it will affect the other linked application too.

Changed in ubuntu-system-settings-online-accounts:
assignee: nobody → Alberto Mardegan (mardy)
importance: Undecided → High
status: Confirmed → In Progress
David Barth (dbarth) on 2015-01-05
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

< pmcgowan> om26er, silo 0 fixes fine to land

Alberto Mardegan (mardy) on 2015-01-20
Changed in ubuntu-system-settings-online-accounts:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Chris Wayne (cwayne18) on 2015-02-12
Changed in savilerow:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers