Password prompt broken

Bug #1379863 reported by David Barth on 2014-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
Online Accounts setup for Ubuntu Touch
Critical
Alberto Mardegan
ubuntu-system-settings-online-accounts (Ubuntu RTM)
High
Alberto Mardegan

Bug Description

The API to let applications prompt the user for his password is broken. As tested with the Account Tester application (v5) and also while running https://wiki.ubuntu.com/Process/Merges/TestPlan/pay-service which seems to be the main use case.

Related branches

David Barth (dbarth) on 2014-10-10
Changed in ubuntu-system-settings-online-accounts:
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Alberto Mardegan (mardy)
tags: added: ota-1 touch-2014-10-16
Alberto Mardegan (mardy) on 2014-10-10
Changed in ubuntu-system-settings-online-accounts:
status: Triaged → In Progress
David Barth (dbarth) on 2014-10-13
Changed in ubuntu-system-settings-online-accounts:
importance: Critical → High
importance: High → Critical
David Barth (dbarth) on 2014-10-15
tags: added: touch-2014-10-23
removed: touch-2014-10-16
Olli Ries (ories) on 2014-10-22
tags: added: rtm14
Olli Ries (ories) wrote :

can you pls provide more information what impact this has

The issue affects, in particular, the pay-ui. After buying an app in the
store, users cannot buy a 2nd app, because we fail to re-authorize them
with a password prompt.

On Wed, Oct 22, 2014 at 5:19 PM, Olli Ries <email address hidden>
wrote:

> can you pls provide more information what impact this has
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1379863
>
> Title:
> Password prompt broken
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu-system-settings-online-accounts/+bug/1379863/+subscriptions
>

tags: removed: ota-1
David Barth (dbarth) wrote :

Correction: the impact is limited to users who have changed their passwords (like on login.ubuntu.com) or who get their token invalidated by other means (removal of the app access in https://login.staging.ubuntu.com/+applications).

David Barth (dbarth) on 2014-10-30
Changed in ubuntu-system-settings-online-accounts:
status: In Progress → Fix Committed
tags: added: touch-2014-11-06
removed: touch-2014-10-23
Olli Ries (ories) wrote :

this bug needs to be targeted after RTM, via ota

tags: added: ota-1
removed: touch-2014-11-06
David Barth (dbarth) wrote :

Released in vivid, but candidate for an ota update

tags: added: touch-2014-11-13
David Barth (dbarth) on 2014-11-05
no longer affects: ubuntu-rtm
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
Changed in ubuntu-system-settings-online-accounts:
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2014-12-08
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
milestone: none → ww03-2015
status: New → Confirmed
importance: Undecided → High
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
Alberto Mardegan (mardy) on 2015-01-20
Changed in ubuntu-system-settings-online-accounts (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers