Please rename the "reboot" hook to something more generic like "apply"

Bug #1381538 reported by Michael Vogt on 2014-10-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu system image
High
Barry Warsaw

Bug Description

For the ubuntu-core system-image we apply updates in a different way than ubuntu-touch. It does not always imply a reboot so I would like to rename the hook from "reboot" to something more generic like "apply".

Related branches

Barry Warsaw (barry) on 2014-10-15
Changed in ubuntu-system-image:
milestone: none → 3.0
status: New → Triaged
importance: Undecided → Medium
Barry Warsaw (barry) wrote :

How about 'update' ?

Changed in ubuntu-system-image:
status: Triaged → In Progress
importance: Medium → High
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) wrote :

Hah, no, it can't be update for really stupid reasons. The Bag object already has an update() method and the methods and configuration variables for a section share a namespace. Blarg - that was a fun one to debug!

So I guess 'apply' it is.

Barry Warsaw (barry) on 2015-01-28
Changed in ubuntu-system-image:
status: In Progress → Fix Committed
Barry Warsaw (barry) wrote :

See also LP: #1417176

Barry Warsaw (barry) on 2015-05-08
Changed in ubuntu-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers