move archive_master file out of /etc to avoid it being treated as a conffile

Bug #1377184 reported by James Hunt on 2014-10-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu system image
High
Barry Warsaw
system-image (Ubuntu)
High
Barry Warsaw

Bug Description

Currently client.ini specifies:

[gpg]
archive_master: /etc/system-image/archive-master.tar.xz

The problem is that file in /etc are automatically marked as conffiles by debhelper and as such don't get moved into place until the dpkg configure step.

This caused an issue for the initramfs-tools-ubuntu-core package since that Depends on system-image-common (which provides
etc/system-image/archive-master.tar.xz), but when the initramfs-tools-ubuntu-core package was unpacked, this triggered update-initramfs which failed since it needs access to /etc/system-image/archive-master.tar.xz, but that file had not yet been moved into place.

Related branches

Barry Warsaw (barry) on 2014-10-03
Changed in ubuntu-system-image:
milestone: none → 3.0
status: New → Triaged
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
no longer affects: system-image (Ubuntu)
tags: added: client
Barry Warsaw (barry) wrote :

Seems like the proper FHS location would be /usr/share/system-image since this is architecture independent data that won't change (except when a new version is installed). I.e. this isn't variable data.

Changed in ubuntu-system-image:
status: Triaged → In Progress
Barry Warsaw (barry) wrote :

Added Ubuntu bug task since it will be necessary to make some changes to the packaging branch.

Changed in system-image (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
milestone: none → ubuntu-15.04
Barry Warsaw (barry) on 2015-01-27
Changed in ubuntu-system-image:
status: In Progress → Fix Committed
Barry Warsaw (barry) on 2015-04-22
Changed in system-image (Ubuntu):
milestone: ubuntu-15.04 → later
Barry Warsaw (barry) on 2015-05-08
Changed in ubuntu-system-image:
status: Fix Committed → Fix Released
no longer affects: system-image (Ubuntu)
Barry Warsaw (barry) on 2015-05-09
Changed in system-image (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
milestone: none → ubuntu-15.10
Barry Warsaw (barry) on 2015-05-11
Changed in system-image (Ubuntu):
status: In Progress → Fix Committed
Barry Warsaw (barry) on 2015-05-18
Changed in system-image (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers