[UIFe] Qt UI: the "Login" and "Forgotten Password" pages don't have titles and subtitles

Bug #945061 reported by Diego Sarmentero on 2012-03-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Undecided
Unassigned
Trunk
High
Natalia Bidart
ubuntu-sso-client (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

In the "login" and "forgotten password" pages there are no titles nor no subtitles (see screenshots attached). This is bad since the user is presented with screens where something is expected from him/her but is not clear what.

We should add titles and subtitles accordingly to guide the user what to do on each page.

The strings should be:

LOGIN_TITLE = _('Sign In to %(app_name)s')
LOGIN_SUBTITLE = _('To connect this computer to %(app_name)s enter your details below.')

FORGOTTEN_PASSWORD_TITLE = _('Reset password')
FORGOTTEN_PASSWORD_SUBTITLE = _('To reset your %(app_name)s password, enter your registered email address below. We will send instructions to reset your password to that address.')

Please note that the only new strings are LOGIN_TITLE and FORGOTTEN_PASSWORD_SUBTITLE, the rest of the strings are already in the project's translations.

I'm happy to provide screenshots with the new strings added if needed.

Emails sent to Docs and Translators lists:
https://lists.ubuntu.com/archives/ubuntu-doc/2012-March/016379.html
https://lists.ubuntu.com/archives/ubuntu-translators/2012-March/005184.html

Related branches

summary: - Login and ForgottenPassword page doesn't have titles
+ Login and ForgottenPassword page doesn't have titles and subtitles
description: updated
Changed in ubuntu-sso-client:
assignee: nobody → Natalia Bidart (nataliabidart)
importance: Undecided → High
status: New → Triaged
summary: - Login and ForgottenPassword page doesn't have titles and subtitles
+ [UIFe] Qt UI: the "Login" and "Forgotten Password" pages don't have
+ titles and subtitles
description: updated
description: updated
Changed in ubuntu-sso-client (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-2
tags: added: u1-fe
description: updated
David Planella (dpm) wrote :

Translations team notified: +1 if it's to add essential info that the user needs.

As usual, if the freeze is approved, I'd appreciate it if it could be uploaded quickly, so that the translatable strings are exposed to translators as soon as possible.

Natalia Bidart (nataliabidart) wrote :

Hi there!

Docs and translators teams have been notified (see link to email archive in the bug description). If approved, the plan is to land this today and release to Ubuntu tomorrow so the strings are available ASAP.

Thanks!

Scott Kitterman (kitterman) wrote :

Approved. Thank you for pre-volunteering to do the screen shots if needed.

Changed in ubuntu-sso-client (Ubuntu Precise):
status: New → Triaged
Natalia Bidart (nataliabidart) wrote :

Hello David!

Yes, we're rushing this to land it today so we release it to Ubuntu tomorrow.
I'm happy to provide any screenshot needed.

Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 2.99.90-0ubuntu1

---------------
ubuntu-sso-client (2.99.90-0ubuntu1) precise; urgency=low

  * New upstream release:
    [ Diego Sarmentero <email address hidden> ]
      - Hide the errors label on refresh captcha (LP: #947202).
      - Changed the name of the function assigned to the lambda that is called
        on passwordChanged signal from reset_password_page (LP: #945080).
      - Made on_user_validated also emit stopProcessing so callers can hide
        any processing overlay they are showing (LP: #945094).
      - Fixed: Qt UI: there is not loading overvaly while validating an
        email address (LP: #944767).
      - Fixed: Qt UI: clicking on the "Set Up Account" button takes me
        instantly to the verification page, even if there are form errors
        (LP: #934502).
      - Fix: [UIFe] Improve the display of errors in the Qt UI (LP: #938604).
      - Fixed: The header in the pages is above the overlay (LP: #934523).
      - Fixed: [UIFE] The padding of the wizard pages in the Qt UI is not
        correct (LP: #934519).
    [ Manuel de la Pena <email address hidden> ]
      - Ensure that the strings used in sso do not have "ubuntu one" in them
        (LP: #933729).
      - Ensure that the strings used are the ones provided by design
        (LP: #937905).
      - Added the dialog that will be used to show that a certificate has issues
        (LP: #933729).
    [ Natalia B. Bidart <email address hidden> ]
      - Add proper titles and subtitles for the Login and Forgot password
        pages (LP: #945061).
      - Made UI modules to setup the gui logging logger (LP: #947469).
      - Fallback to the GTK+ UI when the specified ui_executable does
        not exist (LP: #939821).
      - Move the 'choose sign in page' to client code (U1 control panel
        in this case) (LP: #933576).
      - Do not mask ImportError by importing inside a function (LP: #939173).
      - No more strings coming up from the Designer ui files (LP: #938626).
    [ Roberto Alsina <email address hidden> ]
      - Made the network detection code return ONLINE if NM is not available
        (but still UNKNOWN if it's available and fails) (LP: #939703).
  * debian/control:
    - Updated Standards-Version to 3.9.93.
  * debian/watch:
    - Updated to fetch latest milestone.
  * Removed patches which were included upstream.
 -- Natalia Bidart (nessita) <email address hidden> Tue, 06 Mar 2012 15:57:56 -0300

Changed in ubuntu-sso-client (Ubuntu Precise):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers