[UIFe] Use the string literals that have been stated by design

Bug #937905 reported by Manuel de la Peña
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-3-0
Fix Released
Undecided
Unassigned
Trunk
Fix Released
Medium
Manuel de la Peña
ubuntu-sso-client (Ubuntu)
Fix Released
Undecided
Unassigned
Precise
Fix Released
Undecided
Unassigned

Bug Description

After talking with the design team we have noticed that the strings used in the proxy creds dialog have to be changed so that the dialog follows the standard gnome styling and clarifies what is happening to the user.

The new strings should be:

[frame title] Proxy Settings
[frame header] Please provide login details.
[connecting label] Connecting to:
[error message] Incorrect login details. Please try again.
[user label] Proxy username:
[password label] Proxy password:
[help button] Get Help With Proxies
[cancel button] Cancel
[save button] Save And Connect

Emails sent to Docs and Translators lists:

https://lists.ubuntu.com/archives/ubuntu-doc/2012-February/016352.html
https://lists.ubuntu.com/archives/ubuntu-translators/2012-February/005161.html

Related branches

Revision history for this message
Natalia Bidart (nataliabidart) wrote :

Manuel,

Since this is a public bug, please do not link private documents that can't be seen outside canonical employees. Can you please add sreenshots of the new screens instead?

Also, string changes can not be done without an UIFe at this point, so please add the details to this bug report so we can start the process of asking for a UI freeze exception, and please ping Joshua Hoover about this.

Thanks a lot!

summary: - Use the string literals that have been stated by design
+ [UIFe] Use the string literals that have been stated by design
description: updated
tags: added: u1-proxy-uife
tags: added: u1-fe
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

Thanks for contacting doc/translator teams already. Approved.

Changed in ubuntu-sso-client (Ubuntu Precise):
status: New → Confirmed
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 2.99.90-0ubuntu1

---------------
ubuntu-sso-client (2.99.90-0ubuntu1) precise; urgency=low

  * New upstream release:
    [ Diego Sarmentero <email address hidden> ]
      - Hide the errors label on refresh captcha (LP: #947202).
      - Changed the name of the function assigned to the lambda that is called
        on passwordChanged signal from reset_password_page (LP: #945080).
      - Made on_user_validated also emit stopProcessing so callers can hide
        any processing overlay they are showing (LP: #945094).
      - Fixed: Qt UI: there is not loading overvaly while validating an
        email address (LP: #944767).
      - Fixed: Qt UI: clicking on the "Set Up Account" button takes me
        instantly to the verification page, even if there are form errors
        (LP: #934502).
      - Fix: [UIFe] Improve the display of errors in the Qt UI (LP: #938604).
      - Fixed: The header in the pages is above the overlay (LP: #934523).
      - Fixed: [UIFE] The padding of the wizard pages in the Qt UI is not
        correct (LP: #934519).
    [ Manuel de la Pena <email address hidden> ]
      - Ensure that the strings used in sso do not have "ubuntu one" in them
        (LP: #933729).
      - Ensure that the strings used are the ones provided by design
        (LP: #937905).
      - Added the dialog that will be used to show that a certificate has issues
        (LP: #933729).
    [ Natalia B. Bidart <email address hidden> ]
      - Add proper titles and subtitles for the Login and Forgot password
        pages (LP: #945061).
      - Made UI modules to setup the gui logging logger (LP: #947469).
      - Fallback to the GTK+ UI when the specified ui_executable does
        not exist (LP: #939821).
      - Move the 'choose sign in page' to client code (U1 control panel
        in this case) (LP: #933576).
      - Do not mask ImportError by importing inside a function (LP: #939173).
      - No more strings coming up from the Designer ui files (LP: #938626).
    [ Roberto Alsina <email address hidden> ]
      - Made the network detection code return ONLINE if NM is not available
        (but still UNKNOWN if it's available and fails) (LP: #939703).
  * debian/control:
    - Updated Standards-Version to 3.9.93.
  * debian/watch:
    - Updated to fetch latest milestone.
  * Removed patches which were included upstream.
 -- Natalia Bidart (nessita) <email address hidden> Tue, 06 Mar 2012 15:57:56 -0300

Changed in ubuntu-sso-client (Ubuntu Precise):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers