Windows XP: can't delete current device

Bug #845806 reported by Natalia Bidart on 2011-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
High
Manuel de la Peña

Bug Description

See attached screenshot, looks like python-keyring is not being able to delete the key.

Natalia Bidart (nataliabidart) wrote :
description: updated
tags: added: u1-zomg-windows
Changed in ubuntu-sso-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Roberto Alsina (ralsina)
Roberto Alsina (ralsina) wrote :

This is a missing method in the python-keyring backend used on XP.

Manuel is working on a fix upstream, so assigning to him.

Changed in ubuntu-sso-client:
assignee: Roberto Alsina (ralsina) → Manuel de la Peña (mandel)
Manuel de la Peña (mandel) wrote :

The implemented method is from a patch to pykeyring I did. The fail was due to a lack of rights when trying to delete the creeds. I have updated the patch to take that into account.

Changed in ubuntu-sso-client:
status: Triaged → Fix Committed
Natalia Bidart (nataliabidart) wrote :

Confirmed this is working on XP now.

Changed in ubuntu-sso-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers