Do not start two instances of this process

Bug #803672 reported by Alejandro J. Cura on 2011-06-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
High
Natalia Bidart
Ubuntu Single Sign On Client
High
Alejandro J. Cura
ubuntuone-client (Ubuntu)
Undecided
Unassigned

Bug Description

On windows we should check if there's a running instance of this process, and not start in that case.

Related branches

Changed in ubuntu-sso-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alejandro J. Cura (alecu)
Changed in ubuntuone-client:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Alejandro J. Cura (alecu)
Changed in ubuntuone-client (Ubuntu):
status: New → Invalid

Me pueden sacar de esta lista gracias
------Mensaje original------
De: Launchpad Bug Tracker
Remitente: <email address hidden>
Para: <email address hidden>
Responder a: Bug 803672
Asunto: [Bug 803672] Re: Do not start two instances of this process
Enviado: 22 de jul de 2011 17:31

** Branch linked: lp:~alecu/ubuntu-sso-client/user-id-tcp-port

--
You received this bug notification because you are subscribed to Ubuntu
One Client.
https://bugs.launchpad.net/bugs/803672

Title:
  Do not start two instances of this process

Status in Ubuntu Single Sign On Client:
  Triaged
Status in Ubuntu One Client:
  Triaged
Status in “ubuntuone-client” package in Ubuntu:
  Invalid

Bug description:
  On windows we should check if there's a running instance of this
  process, and not start in that case.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-sso-client/+bug/803672/+subscriptions

Sent from my BlackBerry® wireless device

Changed in ubuntu-sso-client:
status: Triaged → Fix Committed
Changed in ubuntuone-client:
status: Triaged → Fix Committed
Roberto Alsina (ralsina) wrote :

If you start syncdaemon once in a terminal, and then in another, the second instance, instead of dying, does this (many times, from different places, always the same exception):

Logged from file states.py, line 378
Traceback (most recent call last):
  File "C:\Python27\lib\logging\handlers.py", line 77, in emit
    if self.shouldRollover(record):
  File "C:\Users\ROBERTO\canonical\ubuntuone-client\ubuntuone\logger.py", line 101, in shouldRollover
    self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file
Logged from file states.py, line 448
Traceback (most recent call last):
  File "C:\Python27\lib\logging\handlers.py", line 77, in emit
    if self.shouldRollover(record):
  File "C:\Users\ROBERTO\canonical\ubuntuone-client\ubuntuone\logger.py", line 101, in shouldRollover
    self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file
Logged from file main.py, line 271
Traceback (most recent call last):
  File "C:\Python27\lib\logging\handlers.py", line 77, in emit
    if self.shouldRollover(record):
  File "C:\Users\ROBERTO\canonical\ubuntuone-client\ubuntuone\logger.py", line 101, in shouldRollover
    self.stream.seek(0, 2) #due to non-posix-compliant Windows feature
ValueError: I/O operation on closed file

Changed in ubuntuone-client:
status: Fix Committed → Confirmed
dobey (dobey) on 2011-08-25
Changed in ubuntu-sso-client:
milestone: none → 1.3.3
dobey (dobey) on 2011-08-25
Changed in ubuntu-sso-client:
status: Fix Committed → Fix Released
Changed in ubuntuone-client:
status: Confirmed → Triaged
tags: added: u1-windows
Changed in ubuntuone-client:
status: Triaged → In Progress
Changed in ubuntuone-client:
assignee: Alejandro J. Cura (alecu) → Natalia Bidart (nataliabidart)
Changed in ubuntuone-client:
status: In Progress → Fix Committed
Changed in ubuntuone-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers