[SRU] Missing user's name field

Bug #709494 reported by Alejandro J. Cura on 2011-01-28
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
Status tracked in Trunk
Stable-1-0
High
Natalia Bidart
Trunk
High
Natalia Bidart
ubuntu-sso-client (Ubuntu)
High
Natalia Bidart
Maverick
High
Natalia Bidart
Natty
High
Natalia Bidart

Bug Description

The user's name is used when sharing folders, so it must be a required field.
This field was removed to make the registration dialog shorter, and because the sso-server did not provide the option to store it, so we need to un-hide the text entry.

TESTCASE (for a maverick system):

* run the sso daemon using:

DEBUG=True PYTHONPATH=. ./bin/ubuntu-sso-login

* run d-feet. Look for the com.ubuntu.soo bus name, select the /credentials object path and the com.ubuntu.sso.ApplicationCredentials interface. Then, execute the "login_or_register_to_get_credentials" method, using as parameters the following:

'SRU Testing App', '', '', 0

* you'll be presented with a dialog to create a new SSO account. Be sure to use a non-registered, valid, email to register. You should confirm that:

 - the name is mandatory (ie can't be blank)
 - once the registration process succeeds (including entering the confirmation token in the last screen), go to https://login.ubuntu.com/ and check that your "Full name" matches the one you entered in the registration dialog.

Related branches

Changed in ubuntu-sso-client:
importance: Undecided → High
assignee: nobody → Naty Bidart (nataliabidart)
Natalia Bidart (nataliabidart) wrote :

Depends on bug #709496.

Changed in ubuntu-sso-client:
status: New → Triaged
Changed in ubuntu-sso-client (Ubuntu):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → High
Changed in ubuntu-sso-client:
status: Triaged → In Progress
tags: added: u1-natty
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 1.1.12-0ubuntu1

---------------
ubuntu-sso-client (1.1.12-0ubuntu1) natty; urgency=low

  * New upstream release:

    [ Natalia B. Bidart <email address hidden> ]
      - Tests for a particular package are now inside that package.
      - Register now uses the 'displayname' field to pass it on to SSO as
        display name (LP: #709494).
    [ Manuel de la Pena <email address hidden> ]
      - Fix main issues.
      - First step of implementing the code in main on windows.
      - Fixed setup.py issues so that we can build .debs (LP: #735383).
      - Added the network status implementation for windows (LP: #727680).
      - Added an implementation of the keyring on windows (LP: #684967).
      - Added script to run tests on windows using u1trial (LP: #684988).
      - Added bat to run tests on windows (LP: #684988).
 -- Natalia Bidart (nessita) <email address hidden> Tue, 22 Mar 2011 23:31:22 -0300

Changed in ubuntu-sso-client (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntu-sso-client (Ubuntu Maverick):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
importance: Undecided → High
description: updated
Natalia Bidart (nataliabidart) wrote :

As per a comment shared by Rodney, I would hold the release for maverick until we define what to do about the change made in the register_user method.

Likewise, we need to file a UI freeze exception since the registration dialog is now displaying a text entry to fill in with the user full name. This entry was already present in the UI but was hidden since the SSO server was not providing any way of settting the display name for a newly created account.

Natalia Bidart (nataliabidart) wrote :

 Feature freeze exception filed in bug #742678.

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Triaged → In Progress
Changed in ubuntu-sso-client (Ubuntu Natty):
milestone: none → ubuntu-11.04
Changed in ubuntu-sso-client (Ubuntu Maverick):
milestone: none → maverick-updates
summary: - Missing user's name field
+ [SRU] Missing user's name field

SRUs are not for implementing a redesign.

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: In Progress → New
Natalia Bidart (nataliabidart) wrote :

Hi Scott,

I've discussed this with pitti and seb128, and they told me this is an SRU. Is not a redesign, is the un-hiding of a text entry that we couldn't use until 2 weeks ago since the SSO remote server will not take that information (the display name).

Let me know if you need any other info.

Thanks, Natalia.

OK. I used the word redesign since that's in the description in the bug.

Natalia Bidart (nataliabidart) wrote :

Right, I just edited the description to be more accurate. Thanks!

description: updated
btreegorilla (btreegorilla) wrote :
Download full text (6.4 KiB)

No prompt for user name...subsequent login shows 'Full Name' to be empty as expected

Linux ubuntu 2.6.35-28-generic #49-Ubuntu SMP Tue Mar 1 14:39:03 UTC 2011 x86_64 GNU/Linux

Calling register_user with email '<email address hidden>', password <hidden>, captcha_id dbus.String(u'03AHJ_VutmGGejuuKEpkawmTHGFT2Y_CbC7fmqJtYOAKZ5W4wo08-FY85KEU57s7irCaxusPdSL2Tha-CkSgt3db0a6Yj_pUvdtKeIanA5xTMxWYZzqJFMPzt5jPGdDApNyE2uj2EvD6Id1xqAP4DlvqtZ-oGffQKOzQ') and captcha_solution 'novel tworeme'.
register_user: email: dbus.String(<email address hidden>') password: <hidden>, captcha_id: dbus.String(u'03AHJ_VutmGGejuuKEpkawmTHGFT2Y_CbC7fmqJtYOAKZ5W4wo08-FY85KEU57s7irCaxusPdSL2Tha-CkSgt3db0a6Yj_pUvdtKeIanA5xTMxWYZzqJFMPzt5jPGdDApNyE2uj2EvD6Id1xqAP4DlvqtZ-oGffQKOzQ'), captcha_solution: dbus.String(u'novel tworeme')
register_user: email: dbus.String(<email address hidden>') result: {u'status': u'ok', u'message': u'Email verification required.'}
SSOLogin: emitting UserRegistered with app_name "SRU App Testing" and result dbus.String(<email address hidden>')
on_user_registered: args (<ubuntu_sso.gui.UbuntuSSOClientGUI object at 0x31bbe90>, dbus.String(u'SRU App Testing'), dbus.String(<email address hidden>')), kwargs {}.
on_user_registered: args (<ubuntu_sso.gui.UbuntuSSOClientGUI object at 0x366cdd0>, dbus.String(u'SRU App Testing'), dbus.String(<email address hidden>')), kwargs {}.
Calling validate_email with email '<email address hidden>', password <hidden>, app_name dbus.String(u'SRU App Testing') and email_token 'StHbqq'.
validate_email: email: dbus.String(<email address hidden>') password: <hidden>, email_token: dbus.String(u'StHbqq'), token_name: 'SRU App Testing @ ubuntu'.
login: email: dbus.String(<email address hidden>') password: <hidden>, token_name: 'SRU App Testing @ ubuntu'
login: authentication successful! consumer_key: u'bBJWyAN', token_name: 'SRU App Testing @ ubuntu'
validate_email: email: dbus.String(<email address hidden>') result: {u'errors': {u'email_token': [u'Bad email token!']}}
Exception while running DBus blocking code in a thread:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/main.py", line 319, in _in_thread
    result_cb(app_name, f())
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/main.py", line 455, in f
    email_token, token_name)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/main.py", line 255, in validate_email
    raise EmailTokenError(errorsdict)
EmailTokenError: {u'email_token': u'Bad email token!'}
SSOLogin: emitting EmailValidationError with app_name "SRU App Testing" and error {'errtype': 'EmailTokenError', u'email_token': u'Bad email token!'}
on_email_validation_error: args (<ubuntu_sso.gui.UbuntuSSOClientGUI object at 0x31bbe90>, dbus.String(u'SRU App Testing'), dbus.Dictionary({dbus.String(u'errtype'): dbus.String(u'EmailTokenError'), dbus.String(u'email_token'): dbus.String(u'Bad email token!')}, signature=dbus.Signature('ss'))), kwargs {}.
on_email_validation_error: args (<ubuntu_sso.gui.UbuntuSSOClientGUI object at 0x366cdd0>, dbus.String(u'SRU App Testing'), dbus.Dictionary({dbus.String(u'errtype'): dbus.String(u'EmailTokenError'), dbus.String(u'email_token'): dbus.String(u'...

Read more...

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: New → Confirmed
Natalia Bidart (nataliabidart) wrote :

Hello btreegorilla,

Can you please explain what were you trying to point out with your last comment?

Thanks!

btreegorilla (btreegorilla) wrote :

Found this in a "new" state for maverick and was simply trying to progress it to "confirmed". I stepped through the test case and found that it was not prompting for the user name as described...which based on everything I had read was not surprising since it was not a supported on the remote server. So ultimately just trying to indicate that the issue was still present in maverick....was I incorrect in doing so?

Natalia Bidart (nataliabidart) wrote :

Hello btreegorilla,

No, you were not incorrect, thank you for helping out! I was confused: I wasn't sure if you were confirming that in maverick the name field was not present with or without this fix.

Thanks, Natalia.

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Confirmed → New
tags: added: u1-maverick-sru
tags: removed: u1-natty
Martin Pitt (pitti) wrote :

This was a bit hard to understand at first, but discussed with Natalia: The only string change here is the addition of the user's full name, which isn't translated/translatable. There are no other strings involved. It only applies for the registration dialog, it will not e. g. change the name of shared folders. It won't affect existing SSO accounts at all, just registration of a new one, so already existing users won't even see the change, and for new users it will be less confusing.

So approved for SRU.

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: New → Confirmed
Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Confirmed → Fix Committed

Accepted ubuntu-sso-client into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Natalia Bidart (nataliabidart) wrote :

Confirmed is working smoothly on a freshly installed maverick VM enabling -proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-sso-client - 1.0.9-0ubuntu1

---------------
ubuntu-sso-client (1.0.9-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release:

    [ Natalia B. Bidart <email address hidden> ]
      - Register now uses the 'displayname' field to pass it on to SSO as
      display name (LP: #709494).
 -- Natalia Bidart (nessita) <email address hidden> Tue, 29 Mar 2011 16:26:42 -0300

Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers