Sign-on dialog won't open a second time, give traceback

Bug #624127 reported by Matthew Paul Thomas on 2010-08-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Single Sign On Client
High
Natalia Bidart
software-center (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned
ubuntu-sso-client (Ubuntu)
Medium
Natalia Bidart
Maverick
Medium
Natalia Bidart

Bug Description

Ubuntu Software Center 2.1.11, ubuntu-sso-client 0.99.2-0ubuntu1, Ubuntu Maverick

0. Clear your Ubuntu Single Sign-On credentials from your user account if necessary.
1. software-center --enable-buy
2. Choose "File" > "Reinstall Previous Purchases..."
3. In the dialog that appears, click "Cancel".
4. Choose "File" > "Reinstall Previous Purchases..." again.

What should happen: The dialog appears again.

What actually happens: It doesn't. This appears on the terminal:
------------
ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
TypeError: _on_credentials_error() takes exactly 4 arguments (2 given)
------------

The problem persists even after relaunching Ubuntu Software Center.

Related branches

description: updated
Changed in ubuntu-sso-client:
status: New → Invalid
Michael Vogt (mvo) on 2010-08-25
Changed in software-center (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
Michael Vogt (mvo) wrote :

Ths software center part of this is solved by updateing to the new api and adding a versionized dependency.

However I can reproduce the issues that mpt has. When I run the attached test code a couple of times (two times seems to be enough most of the time) and click cancel in the dialog I get no dialog anymore but instead:

error: lala Problem opening the Ubuntu SSO user interface. Traceback (most recent call last):

  File "/usr/lib/pymodules/python2.6/ubuntu_sso/main.py", line 508, in _show_login_or_register_ui
    help_text, win_id, login_only)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 311, in __init__
    self._setup_signals()
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 347, in _setup_signals
    dbus_interface=self.iface_name)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 360, in inner
    assert actual is None
AssertionError

Michael Vogt (mvo) wrote :

Ths software center part of this is solved by updateing to the new api and adding a versionized dependency.

However I can reproduce the issues that mpt has. When I run the attached test code a couple of times (two times seems to be enough most of the time) and click cancel in the dialog I get no dialog anymore but instead:

error: lala Problem opening the Ubuntu SSO user interface. Traceback (most recent call last):

  File "/usr/lib/pymodules/python2.6/ubuntu_sso/main.py", line 508, in _show_login_or_register_ui
    help_text, win_id, login_only)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 311, in __init__
    self._setup_signals()
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 347, in _setup_signals
    dbus_interface=self.iface_name)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 361, in inner
    f(method, signal_name, dbus_interface)
  File "/usr/lib/pymodules/python2.6/ubuntu_sso/gui.py", line 360, in inner
    assert actual is None
AssertionError

Changed in ubuntu-sso-client:
status: Invalid → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 2.1.12

---------------
software-center (2.1.12) maverick; urgency=low

  [ Kiwinote ]
  * softwarecenter/app.py:
    - pass required argument to fix crash (LP: #618212)
    - fix crash in setting supported filter (LP: #618243)
  * softwarecenter/db/application.py:
    - fail nicely on not available for architecture (mit-scheme)
  * softwarecenter/view/appdetailsview_gtk.py:
    - use package info lines rather than package info tables
      (for devildante to use in the addons branch)
    - add elipsis to buy button for mpt (LP: #622708)
  * softwarecenter/view/appview.py:
    - don't show duplicate app/pkg (in channelviews)
    - count pkgs when displaying pkgs and apps
  * softwarecenter/view/availablepane.py:
    - two way 'show/hide technical packages' action bar
      (the number of technical pkgs to show is not very accurate)
  * softwarecenter/view/channelpane.py:
    - two way 'show/hide technical packages' action bar
      (this is accurate, LP: #594833)
  * softwarecenter/view/widgets/actionbar.py:
    - disable text getting bold on hover

  [ Milo Casagrande ]
  * softwarecenter/db/application.py:
    - make 'source available' warning more suitable for translation.

  [ Gary Lasker ]
  * softwarecenter/backend/channel.py:
    - Rename the "App Expo" node to "Independent" per the USC spec

  [ Michael Vogt ]
  * implement the "Find it at" part of the specification to make it
    easier for the user to discover the newly installed software
  * softwarecenter/backend/login_sso.py:
    - use Sign into "Ubuntu Software Center Store" as sso login name
  * debian/control:
    - tighten dependency on ubuntu-sso-client (LP: #624127)

  [ Mohamed Amine IL Idrissi ]
  * (all): Implemented add-on handling.
 -- Michael Vogt <email address hidden> Wed, 25 Aug 2010 23:06:27 +0200

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Michael Vogt (mvo) on 2010-08-25
summary: - Sign-on dialog won't open a second time
+ Sign-on dialog won't open a second time, give traceback
Michael Vogt (mvo) on 2010-08-26
Changed in ubuntu-sso-client (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-10.10
tags: added: desktop+ u1-maverick
Changed in ubuntu-sso-client:
status: New → In Progress
importance: Undecided → High
Changed in ubuntu-sso-client (Ubuntu):
status: New → Triaged
assignee: nobody → Naty Bidart (nataliabidart)
Changed in ubuntu-sso-client:
assignee: nobody → Naty Bidart (nataliabidart)
dobey (dobey) on 2010-08-31
Changed in ubuntu-sso-client:
status: In Progress → Fix Committed
Changed in ubuntu-sso-client (Ubuntu):
importance: High → Medium
Changed in software-center (Ubuntu Maverick):
milestone: ubuntu-10.10-beta → ubuntu-10.10
Changed in ubuntu-sso-client (Ubuntu Maverick):
status: Triaged → Fix Released
Changed in ubuntu-sso-client:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers