Scope consuming a lot of resources

Bug #1158278 reported by Alan Pope 🍺🐧🐱 🦄
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Scopes
Undecided
Unassigned
Unity
Fix Released
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

alan 15063 99.4 0.1 486480 15600 ? Sl 10:07 167:44 /usr/bin/python3 /usr/share/unity-scopes/scope-runner-dbus.py /usr/share/unity-scopes/texdoc/unity_texdoc_daemon.py

See top, below, note that python3 has been consuming a lot of CPU time all day for me.

top - 12:56:37 up 5:14, 6 users, load average: 3.40, 2.11, 1.72
Tasks: 308 total, 2 running, 305 sleeping, 0 stopped, 1 zombie
%Cpu(s): 48.8 us, 10.6 sy, 0.0 ni, 40.6 id, 0.0 wa, 0.0 hi, 0.0 si, 0.0 st
KiB Mem: 8057840 total, 7728256 used, 329584 free, 134376 buffers
KiB Swap: 8267772 total, 29732 used, 8238040 free, 2265660 cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 4083 alan 20 0 1478m 546m 57m R 100.3 6.9 10:44.92 chromium-browse
15063 alan 20 0 475m 15m 6800 S 99.3 0.2 168:34.53 python3
 3006 alan 20 0 1500m 131m 31m S 8.3 1.7 22:41.32 compiz
 3657 alan 20 0 1008m 244m 54m S 8.3 3.1 25:40.75 chromium-browse
 4367 alan 20 0 1244m 195m 30m S 7.0 2.5 8:32.46 chromium-browse
 1632 root 20 0 437m 130m 113m S 5.3 1.7 17:51.48 Xorg
 4255 alan 20 0 844m 99m 30m S 1.7 1.3 9:57.00 chromium-browse
 3040 alan 20 0 499m 13m 9424 S 1.0 0.2 3:07.76 indicator-multi
 3238 alan 20 0 624m 37m 13m S 1.0 0.5 4:24.55 unity-panel-ser
 3240 alan 20 0 491m 10m 3588 S 0.7 0.1 2:10.68 hud-service
15780 root 20 0 0 0 0 S 0.7 0.0 0:08.40 kworker/2:0
28552 alan 20 0 20680 1732 1152 R 0.7 0.0 0:00.02 top
  744 messageb 20 0 25544 2448 924 S 0.3 0.0 0:01.71 dbus-daemon
 2942 alan 20 0 28508 4472 768 S 0.3 0.1 0:34.16 dbus-daemon
 3257 alan 20 0 464m 6400 4928 S 0.3 0.1 0:41.04 indicator-appli
 3375 alan 20 0 689m 22m 13m S 0.3 0.3 1:45.75 gnome-terminal
 4202 alan 20 0 962m 113m 24m S 0.3 1.4 0:20.95 chromium-browse

tags: added: 100scopes
Revision history for this message
Thomas Strehl (strehl-t) wrote :
Changed in unity:
importance: Undecided → High
Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

I'm less concerned that it's long running, more that it pegged my cpu at 100% for ~hours.

Revision history for this message
David Callé (davidc3) wrote :

Regarding this specific scope, it's probably because it's not able to reach its data source (texdoc), I'm investigating how it could bring your system to this point. This kind of direct dependency issues are going to be fixed by allowing Unity to query a scope only if its data source is reachable.

Didier Roche (didrocks)
Changed in unity:
importance: High → Medium
importance: Medium → High
Revision history for this message
David Callé (davidc3) wrote :

I haven't been able to reproduce the high cpu usage with the Texdoc scope.
Nevertheless changes have been made to prevent scopes from starting when their local data source is missing.

Revision history for this message
David Callé (davidc3) wrote :

Alan, do you still have this issue?

Revision history for this message
Alan Pope 🍺🐧🐱 🦄 (popey) wrote :

I haven't seen it since, no.

Changed in ubuntu-scopes:
status: New → Fix Released
Changed in unity:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers