Tapping the top edge shows the indicators panel when in fullscreen mode

Bug #1439318 reported by Dave Morley on 2015-04-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
unity8 (Ubuntu)
High
Daniel d'Andrada
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

STEPS:
1. Run a fullscreen application (eg "machines vs machines", Gallery when displaying a photo, camera-app)
2. Tap very close to the top edge (where the indicators bar would be if you were not in fullscreen)

EXPECTED:
The application gets the tap.

ACTUAL:
The indicators panel slides down, getting fully shown/open.

COMMENTS:
When in fullscreen, you can reveal the indicators panel by performing a top-edge swipe. The bug is that even a simple tap near the top edge is enough to reveal it.

Related branches

Dave Morley (davmor2) wrote :
Dave Morley (davmor2) on 2015-04-01
tags: added: qa-manual-testing
Michał Sawicz (saviq) on 2015-04-01
Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Michael Zanetti (mzanetti)

Confirmed on rtm on krillin.

Daniel d'Andrada (dandrader) wrote :

When the active/focused application is fullscreen you should be able to get the indicators panel by swiping from the top edge.
But as this video shows, it seems that even a tap (ie, a mini-swipe as no finger is absolutely still) was enough to trigger it.

Changed in unity8 (Ubuntu):
assignee: Michael Zanetti (mzanetti) → Daniel d'Andrada (dandrader)
status: Triaged → In Progress
Daniel d'Andrada (dandrader) wrote :

Hmmm.... or more likely it's the MouseArea we now have to show the indicators on desktops.

summary: - Indicator can take over a whole screen app.
+ A tap is enough to show the indicators tapping the top edge shows the
+ indicators panel when in fullscreen mode
summary: - A tap is enough to show the indicators tapping the top edge shows the
- indicators panel when in fullscreen mode
+ Tapping the top edge shows the indicators panel when in fullscreen mode
description: updated
Michael Zanetti (mzanetti) wrote :

Can't reproduce this on RTM. Popey, you absolutely sure you can?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150409.1-0ubuntu1

---------------
unity8 (8.02+15.04.20150409.1-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Focus the shutdown dialog (LP: #1417991)
  * Make url-dispatching scope activation when the dash is not on the
    main scopes (LP: #1364306)
  * We use autopilot3 now

  [ CI Train Bot ]
  * New rebuild forced.
  * Resync trunk. added: po/or.po

  [ Daniel d'Andrada ]
  * Make tst_PreviewListView and tst_GenericScopeView work in out-of-
    source builds
  * MouseArea that shows the indicators panel should cover the
    indicators bar only (LP: #1439318)
  * Surface gets active focus also with mouse clicks

  [ Josh Arenson ]
  * Add a mode option to unity8 for selecting greeter mode in the future
  * Remove PkgConfig include from Launcher plugin to fix cross-compile
    (LP: #1437702)

  [ Leo Arias ]
  * Fixed the check for string in the lock screen test. (LP: #1434518)

  [ Michael Terry ]
  * Make sure the edge tutorial is destroyed when we receive a call
    during the wizard. (LP: #1436349)
  * Skip parts of the edge tutorial that require a touch device (like
    spread and bottom edge). (LP: #1434712)

  [ Michael Zanetti ]
  * Don't hide stages just because they're empty (LP: #1439615)
  * [Launcher] fix bug where an item would disappear even though the app
    is running (LP: #1438172)

  [ Nick Dedekind ]
  * Fixed autopilot test failures related to udev input failure for
    power button.
  * Made improvements for laggy indicator backends (lp#1390136). (LP:
    #1390136)

  [ Pete Woods ]
  * GPS only goes active when the Dash is in the foreground (LP:
    #1434379)

  [ handsome_feng<email address hidden> ]
  * Modified the wrong time format in ScreenGrabber (LP: #1436006)
 -- CI Train Bot <email address hidden> Thu, 09 Apr 2015 14:01:11 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers