[scopes] Launching a scope once installed is broken

Bug #1410337 reported by Jouni Helminen on 2015-01-13
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Ubuntu UX
High
Paty Davila
unity-scopes-shell (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Andrea Cimitan
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Current situation:

1) Search for a scope in app store (for example "Cinema").
2) Install it
3) After installation, you have two buttons: Uninstall and Search.
4) Tap Search.

Instead of being taken to the scope, you get taken to a nested installation screen. If installing it for 2nd time from there, Search button doesn't do anything after 2nd install.

Fix:

"Search" button should take you directly to the scope you just installed.

Also "Search" doesn't sound like a clear word for opening the scope, maybe consider "Open" instead?

Related branches

Michał Sawicz (saviq) on 2015-01-13
Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Andrea Cimitan (cimi)
Andrea Cimitan (cimi) wrote :

what should happen when tapping open/search? any animation?
what should happen when tapping back from the new opened scope? going back to store or dash?

Changed in unity8 (Ubuntu):
status: Triaged → Incomplete
Changed in ubuntu-ux:
status: New → Triaged
assignee: nobody → James Mulholland (jamesjosephmulholland)
importance: Undecided → High
dobey (dobey) wrote :

This is a regression. I don't know why there is an ubuntu-ux task for this exactly. The behavior used to be correct for this flow.

1) From the store scope's preview of an installed scope, tapping "Search" should open the scope with the search URL that is attached to the button (this does actually happen, but for some reason the uninstalled preview is requested on top of the scope as if it's a preview for a result there, tapping the "<" back arrow will actually take you to the newly installed scope from here).

2) Tapping back from the search in the new scope should return to the installed preview page of the click store scope (the place where the search was opened from).

Michał Sawicz (saviq) wrote :

Are you sure case 1) worked before? We should try and bisect when it broke, then.

Point 2) never worked for sure, we never had more than one non-favourited scope open at the same time, which would be required to have the store scope and another scope on top of that.

dobey (dobey) wrote :

I was pretty sure 1) worked at some point. but I don't know when it might have broken. Maybe I'm just misremembering that, or am remembering correctly and just got lucky to have it work. Maybe 2) never worked either.

But from a user perspective, the description is how I would expect the experience to be, and it feels obvious to me.

Andrea Cimitan (cimi) on 2015-02-04
Changed in unity8 (Ubuntu):
status: Incomplete → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scopes-shell - 0.5.4+15.04.20150213-0ubuntu1

---------------
unity-scopes-shell (0.5.4+15.04.20150213-0ubuntu1) vivid; urgency=medium

  [ Pawel Stolowski ]
  * Keep temporary scopes list in the Scopes object instances and make
    Scopes the partent of temp scopes instances. Temp scopes can be
    closed (and freed) using closeScope() method of the original scope,
    or by calling closeScope() method of Scopes instance. (LP: #1410337,
    #1410191)
 -- CI Train Bot <email address hidden> Fri, 13 Feb 2015 16:47:39 +0000

Changed in unity-scopes-shell (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.02+15.04.20150216.1-0ubuntu1

---------------
unity8 (8.02+15.04.20150216.1-0ubuntu1) vivid; urgency=medium

  [ Andrea Cimitan ]
  * Fix temp scopes opening temp scopes, correctly close previously
    opened temp scope with its preview (LP: #1410337)
  * Set sourcesize for scopes images in manage dash

  [ CI Train Bot ]
  * Resync trunk

  [ Albert Astals Cid ]
  * Test for bug #1316660 (LP: #1316660)
  * Hardcode tranlsation for internal.location field (LP: #1393438)
  * Make sure the height it's the height it will have

  [ Michael Zanetti ]
  * Cleanup cmake warning about missing Qt5Sql module
 -- CI Train Bot <email address hidden> Mon, 16 Feb 2015 13:14:26 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-ux:
assignee: James Mulholland (jamesjosephmulholland) → Paty Davila (dizzypaty)
summary: - Launching a scope once installed is broken
+ [scopes] Launching a scope once installed is broken
Paty Davila (dizzypaty) on 2015-08-03
Changed in ubuntu-ux:
status: Triaged → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers