greeter not reacting to swipes

Bug #1391149 reported by Oliver Grawert on 2014-11-10
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
unity8 (Ubuntu)
High
Daniel d'Andrada
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

i had this a few times over the weekend with images 150-153, suddenly the greeter does not react to right/left swipes on the wallpaper to reveal the PIN unlock dialog ... swiping in the launcher from the left makes the greeter go away and reveals the PIN unlock dialog then.

Michael Zanetti (mzanetti) wrote :

Some more notes after an IRC conversation with ogra:

* The launcher can still be flicked up/down, so not a touch vs mouse issue.
* hiding the greeter using the launcher gets a fully working phone
* tapping the greeter does NOT tease the launcher

Oliver Grawert (ogra) wrote :

i am wondering if that is the same as bug #1391076 , just in a less intrusive manifestation

Daniel d'Andrada (dandrader) wrote :

Looks like it could be related to the TouchGate in Greeter.qml.
Enabling TouchRegistry and TouchGate logging, as well as adding some debug prints to the DraggingArea in Greeter.qml, should be enough to clarify what's happening.
Provided there's a way to reproduce the bug, that is.

kevin gunn (kgunn72) wrote :

going ahead and marking as dup of bug 1391076

Michał Sawicz (saviq) wrote :

Nope, not a dupe. See the description, the phone works rather fine, but the welcome screen stops receiving events. So you can't double-tap to change the infographics, or swipe the greeter away, other than from the left edge, etc.

Changed in unity8 (Ubuntu):
status: New → Triaged
importance: Undecided → High
kevin gunn (kgunn72) wrote :

got it, i was conflating the unity frozen ui bug 1391076 & the double tap bug 1388359 as solving this.

Ricardo Salveti (rsalveti) wrote :

Just reproduced this with RTM (krillin) 166. No steps yet to reproduce it, got after using the phone for almost 2 days without a reboot.

Ricardo Salveti (rsalveti) wrote :

And the phone seems to be completely fine, just can't unlock using the right->left swipe.

Michael Zanetti (mzanetti) wrote :

Here's how to repro:

* With one finger tap and hold the greeter
* with a second finger swipe it away
* lock the phone again
=> greeter broken

Another way:

* tap and hold the greeter
* with another finger pull in the launcher, press the orange BFB
* lock phone again
=> greeter broken

Ricardo Salveti (rsalveti) wrote :

Just reproduced this with RTM 241/krillin:

current build number: 241
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2015-02-20 00:41:40
version version: 241
version ubuntu: 20150219
version device: 20150216-fe747ac
version custom: 20150216-561-29-186

Tiago Salem Herrmann (tiagosh) wrote :

Same here. I can reproduce using the steps provided on comment #9 and I could use the same steps to make it go back to the normal behavior.

Pat McGowan (pat-mcgowan) wrote :

see these bugs for similar symptoms
bug #1295623
bug #1373641

Michał Sawicz (saviq) on 2015-02-24
Changed in unity8 (Ubuntu):
assignee: nobody → Daniel d'Andrada (dandrader)
Daniel d'Andrada (dandrader) wrote :

I can reproduce it with ubuntu-touch/ubuntu-rtm/14.09-proposed using (roughly) the steps from comment #9 but not with vivid-proposed.

Maybe that's due to different versions of Qt as I cannot spot any relevant difference in that part of unity8 code (greeter and launcher).

Since we're about to move Vivid to stable, I guess it's not worth the effort of finding and backporting whatever fixed it?

On Tue, Feb 24, 2015 at 10:42 AM, Daniel d'Andrada
<email address hidden> wrote:
> I can reproduce it with ubuntu-touch/ubuntu-rtm/14.09-proposed using
> (roughly) the steps from comment #9 but not with vivid-proposed.
>
> Maybe that's due to different versions of Qt as I cannot spot any
> relevant difference in that part of unity8 code (greeter and launcher).
>
> Since we're about to move Vivid to stable, I guess it's not worth the
> effort of finding and backporting whatever fixed it?

"about" here is still unclear, we might still have 1-2 months of RTM.

Pat should be able to answer if high enough for a backport/fix.

Michael Terry (mterry) wrote :

Based on comment #13, I'll close the vivid task, but leave the ubuntu rtm task open.

Changed in unity8 (Ubuntu):
status: Triaged → Fix Released

It is fixed in vivid. Closing C.S.I. task

Changed in canonical-devices-system-image:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers