Apps that import Ubuntu.Components 1.2 or older use the 1.3 palette

Bug #1549830 reported by Tim Peeters on 2016-02-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
Critical
Zsombor Egri

Bug Description

For example:

import QtQuick 2.4
import Ubuntu.Components 1.2

MainView {
    width: units.gu(48)
    height: units.gu(60)

    Page {
        title: "Hello, I am blue." // should be darkGrey
        Label {
            anchors.centerIn: parent
            text: "bla"
            color: Theme.palette.normal.negative // this color does not exist in 1.2 palette
        }
    }
}

The old header label uses the selected.backgroundText color from the palette. This is darkGrey in the old (1.2) palette and blue in the new (1.3) palette. Also, I can refer to Theme.palette.normal.negative, which is a color that was not defined in the 1.2 palette.

Several apps that use the old header and import Ubuntu.Components 1.2 or older have blue text in the header because of this bug. For example: clock app.

Related branches

Tim Peeters (tpeeters) on 2016-02-25
description: updated
Zsombor Egri (zsombi) wrote :

Thanks Tim for digging it out!

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → Critical
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: none → ww08-2016
Zsombor Egri (zsombi) on 2016-02-25
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: New → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: New → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
assignee: nobody → Zsombor Egri (zsombi)
Changed in canonical-devices-system-image:
importance: Undecided → Critical
assignee: nobody → Zoltan Balogh (bzoltan)
Zoltan Balogh (bzoltan) on 2016-02-29
no longer affects: ubuntu-ui-toolkit (Ubuntu)
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
importance: Undecided → Critical
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Łukasz Zemczak (sil2100) wrote :
Download full text (8.5 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1872+15.04.20160308-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1872+15.04.20160308-0ubuntu1) vivid; urgency=medium

  [ Timo Jyrinki ]
  * Fix gles unit test skipping.
  * Add s390x to the unit test skipping architectures
  * UITK test plan - wily -> xenial. Fixes LP: #1544490

  [ Christian Dywan ]
  * Print errors when QuickUtils fails to create a component.
  * unit tests shouldn't use deprecated Dialog.callera
  * Correctly count only test case results. The result= value is used in suites
    and results.
  * Skip tst_pagehead_visible flakes on non-arm. Fixes LP: #1534651
  * Skip flaky tst_mousefilterTest::doubleClicked. Fixes LP: #1542215
  * Suppress click signal if releasing outside of ListItem. Fixes LP: #1541148.
  * Use gdb in runtest.sh to produce backtraces.
  * Arrow keys change value of a Slider. Fixes LP: #1523824.
  * Only use Maliit when enabled explicitly in the environment

  [ Oliver Tilloy ]
  * Do not try to assign to non-existent property "activeFocusOnPress".
    Fixes LP: #1532953
  * Bubble up ESC key press event if there is no popover to close.
    Fixes LP: #1546627

  [ Loïc Molinari ]
  * Added private items and nodes for the new component styles.
    Fixes LP: #1523836
  * Made use of new private Frame item for the focusing.
  * Fixed performance monitor crash because of a NULL timer pointer dereference.
    Fixes LP: #1546986
  * Fixed performance monitor dangling pointer crash. Fixes LP: #1546984
  * [ProportionalShape] Ensured width/height ratio is correct with default values.
    Fixes LP: #1546546
  * Added a workaround to prevent a crash while changing the QPA scale factor.

  [ Florian Boucault ]
  * Always on performance monitor that logs frames that too long to render.
  * MainView: proceed to selecting the theme automatically at startup too.
    Fixes LP: #1535819
  * MainView: when no gradient color is needed for the background, rely on
    QQuickWindow's GL clear color. Lessens overdraw considerably for most
    apps. Fixes LP: #1439133.
  * Panel: MathUtils used without import prefix was leading to undefined
    reference.
  * Label: use native rendering on low dpi screens (GRID_UNIT_PX <= 10) for
    sharper looking text.
  * Gallery: added palette browser to Colors page.

  [ Tim Peeters ]
  * Support scrolling in ListViews with horizontal orientation to the
    qquicklistview CPO.
  * Add background to AppHeader and remove contents clipping from MainView.
    Fixes LP: #1531016, LP: #1531457.
  * Hide AppHeader when using AdaptivePageLayout. Fixes bug 1531871.
    Fixes LP: #1531871.
  * Implement horizontal flicking in the flickable autopilot CPO.
  * Re-order to list of pages in the gallery to be alphabetical.
  * Fix the autopilot failures introduced with the horizontal scrolling in
    the Flickable CPO.
  * Update documentation for MainView, Page, AdaptivePageLayout to use the new
    PageHeader in all examples. Deprecate old properties. Fixes LP: #1540574
  * Add 'animate' property to new internal AppHeaderBase, and do not show a
    header anim...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Zoltan Balogh (bzoltan) on 2016-03-09
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers