tst_pagehead_visible flaky test

Bug #1534651 reported by Timo Jyrinki on 2016-01-15
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Medium
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

https://jenkins.ubuntu.com/ubuntu-sdk/job/ubuntu-ui-toolkit-ci-amd64/46/consoleFull

Note filing this bug just to not forget about it, but the two tests failing there seem flaky as they did not fail for armhf or another MP with similar no-op changes.

--
tst_pagehead_visible.qml: FAIL! : components::HeaderLockedVisible::test_scroll_when_unlocked_updates_visible() Scrolling down does not hide header.
tst_pagehead_visible.qml: Actual (): true
tst_pagehead_visible.qml: Expected (): false
tst_pagehead_visible.qml: Loc: [/tmp/buildd/ubuntu-ui-toolkit-1.3.1795+16.04.20160106/tests/unit_x11/tst_components/tst_pagehead_visible.qml(180)]
tst_pagehead_visible.qml: FAIL! : components::HeaderLockedVisible::test_set_visible_to_hide_and_show() Cannot hide unlocked header by setting visible to false.
tst_pagehead_visible.qml: Actual (): true
tst_pagehead_visible.qml: Expected (): false
tst_pagehead_visible.qml: Loc: [/tmp/buildd/ubuntu-ui-toolkit-1.3.1795+16.04.20160106/tests/unit_x11/tst_components/tst_pagehead_visible.qml(180)]
--

Related branches

Timo Jyrinki (timo-jyrinki) wrote :

Another case: https://jenkins.ubuntu.com/ubuntu-sdk/job/ubuntu-ui-toolkit-ci-amd64/126/console - next run was ok.

tst_pagehead_visible.qml: 'FAIL!' : 'components::HeaderLockedVisible::test_scroll_when_unlocked_updates_visible()' Scrolling down does not hide header.
tst_pagehead_visible.qml: 'FAIL!' : 'components::HeaderLockedVisible::test_set_visible_to_hide_and_show()' Cannot hide unlocked header by setting visible to false.
tst_pagehead_visible.qml: FAIL! : components::HeaderLockedVisible::test_scroll_when_unlocked_updates_visible() Scrolling down does not hide header.
tst_pagehead_visible.qml: FAIL! : components::HeaderLockedVisible::test_set_visible_to_hide_and_show() Cannot hide unlocked header by setting visible to false.

Timo Jyrinki (timo-jyrinki) wrote :

(the earlier logs have disappeared due to Jenkins auto-clean, I now increased the amount of logs to be kept from 100 to 500 which should last 2-3 months)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

https://code.launchpad.net/~tpeeters/ubuntu-ui-toolkit/untest/+merge/284896 started ignoring this test but on i386 only, while it affects amd64 too.

tags: added: flaky
Zoltan Balogh (bzoltan) on 2016-03-09
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Changed in canonical-devices-system-image:
milestone: none → ww08-2016
status: New → Fix Committed
assignee: nobody → Zoltan Balogh (bzoltan)
Changed in canonical-devices-system-image:
importance: Undecided → Medium
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers