When an application starts there is temporarily a white gap at the top

Bug #1524901 reported by Andrew Hayzen on 2015-12-10
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
High
Tim Peeters

Bug Description

When an application starts there is temporarily a white gap at the top, note I think this has started happening on the rc-proposed channel since around when OTA8 was released.

This is seen with apps using v1.3 of the uitk
The symptom varies depending on the app, some jump up (contacts) some jump down (messaging) as they initially display.

What happened:
1) Launch an application such as Music, dekko, messaging app
2) As it is launched watch the very top
3) Notice that for a few frames there is a white box that pushes all of the content down (most visible on music due to black app colour)

What was expected to happen:
At step 3 for there to be no white box at the top of the app on startup

$ system-image-cli -i
current build number: 184
device name: mako
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-12-10 15:02:28
version version: 184
version ubuntu: 20151210.1
version device: 20150911
version custom: mako-1.1

Related branches

Andrew Hayzen (ahayzen) on 2015-12-10
description: updated

This is especially noticable on the bq e4.5 which is somewhat slower than other devices.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
description: updated
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
milestone: none → ww08-2016
status: New → Confirmed
description: updated
dinamic (dinamic6661) wrote :

same here, arale/rc-proposed

Tim Peeters (tpeeters) on 2016-01-27
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
Tim Peeters (tpeeters) on 2016-01-28
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Tim Peeters (tpeeters) wrote :

I flashed the rc-proposed image on mako and I have problems reproducing this bug.

- In music-app it seems like the whole background is flashing white before showing the proper page, not just the top
- Messaging-app looks fine. No white box.
- Dekko crashes on startup after I added an account.
- Contacts-app some times hangs, and some times crashes.

Tim Peeters (tpeeters) wrote :

There is a very similar bug https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1518002 but with different apps listed that is fixed in the branch attached to that bug.

Tim Peeters (tpeeters) wrote :

I got Dekko to work properly (removed the account properly and then re-added it in Dekko), and it starts good now without showing a white gap.

Tim Peeters (tpeeters) wrote :

^My reports above were on mako with the latest rc-proposed image (r352).

On krillin with image r387 I can reproduce this bug: https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1518002 with music-app. Messaging-app, contacts-app and Dekko are good (I cannot reproduce the bug).

Now flashing image 394 to see if there is a difference.

Tim Peeters (tpeeters) wrote :

With the latest rc-proposed on krillin (r394) I get the same results as with r384:. Messaging-app, contacts-app and Dekko are good, music-app does seem affected.

Dan Chapman ๎ƒฟ (dpniel) wrote :

I haven't seen this behaviour so far in Dekko, with the default white background it's probably difficult to see anyway. Just to test I changed the apps background colour to dark but still didn't see this white gap.

Tested on krillin & mako

Tim Peeters (tpeeters) wrote :

Please provide a small test program to reproduce the bug

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Incomplete
Dan Chapman ๎ƒฟ (dpniel) wrote :

I've now started seeing similar in Dekko, which i've narrowed down to happening while pushing the first page onto the page stack on launch. PageStack.push() is blocking for ~400ms in Dekko and there is the gap above the page header until push() is complete.

This maybe an issue in Dekko that the initial page is too heavy and slow to create, so I can definitely make some optimizations there. But maybe there is some optimizations still to be made in PageStack.push() as well?

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Incomplete → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Zoltan Balogh (bzoltan) on 2016-03-09
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers