MathUtils.clamp, min value should not be bigger than the max value

Bug #1520557 reported by Christian Dywan on 2015-11-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
Critical
Benjamin Zeller

Bug Description

I'm seeing tons of these in the UITK gallery after https://code.launchpad.net/~zeller-benjamin/ubuntu-ui-toolkit/mathutils_to_cpp/+merge/277704 landed.

1) Out of the box no 1.3 code or example should produce these warnings.
2) Deprecation flags should be respected.

Related branches

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Benjamin Zeller (zeller-benjamin)
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
Zoltan Balogh (bzoltan) on 2015-12-05
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Łukasz Zemczak (sil2100) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1742+15.04.20151209-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1742+15.04.20151209-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickView when the application quits. Fixing segfault caused by the
    dangling objects in GestireDetector.
  * BottomEdgeHint API changes, deprecating state property, introducing locked
    property to drive visuals lock and click handling.
  * Fixing CheckBox and Switch getting checked property altered after clicked()
    signal is emitted. Fixes LP: #1510919.
  * Add ListItem.swipeEnabled property to block swiping when overlay MouseArea
    is used to drag content. Fixes swiping when leading/trailing actions list
    is empty. Fixes LP: #1500409, LP: #1500416.
  * Follow the new design in BottomEdgeHint.
  * Provide import version information for StyledItem and remove theme.version
    obsolete property.
  * Use QQuickItemChangeListener to listen parent changes, skipping the meta
    object model. Convert UCThemingExtension into a Q_INTERFACE so object_cast<>
    can work with it saving the need to memorise on an item whether it is an
    extended item or not.
  * Set mouseAttached to false to revert regression in UITK gallery.
  * Remove BottomEdgeHint from UITK gallery's MainPage.qml which occludes with
    the bottom-up dragging of the ListView.

  [ Benjamin Zeller ]
  * Avoid unnecessary updates for i18n strings.
  * "MathUtils.clamp, min value should not be bigger than the max value".
    Fixes LP: #1520557.
  * Move MathUtils to Cpp.

  [ Loïc Molinari ]
  * UbuntuShape - Fixed deprecation logging issues.
  * This fix prevents logging a deprecation warning for "image", "color" and
    "gradientColor" properties when the import version is less than 1.3. The
    logging of properties used internally (through the old image wrapper) have
    been removed too since the user might not even have used them.
    Fixes LP: #1519414.

  [ Christian Dywan ]
  * Enable gallery target in qmake.
  * Don't set activeFocusOnPress on TextField but on child only.
    Fixes LP: #1486274, LP: #1513897.
  * Make runtest.sh work out of the box again.
  * Explicitly handle keyboard anchoring in dialog foreground.
    Fixes LP: #1376763.
  * Remove GestureDetector in favor of SwipeArea in BottomEdgeHint. Also make
    possible to assign Action to the ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww02-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers