Header is shown at startup and slides out even though it is set to be invisible and locked

Bug #1518002 reported by Andrew Hayzen on 2015-11-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
High
Tim Peeters

Bug Description

Some applications have no header on the starting page, but may have headers on the sub pages (for settings), eg Calculator, Clock and Weather. However it has been observed that if you set the header to invisible and locked with the code below, the header is infact shown at startup and then slides away (as shown in this video [0]).

head {
  locked: true
  visible: false
}

What happened:
1) Create an application that uses the code above to have no header on the starting page
2) Deploy and launch the application
3) Notice that the header is initially shown but then slides away

What was expected to happen:
At step 3) for the header not to be shown at startup.

0 - https://www.youtube.com/watch?v=OMqJbc6H6IY

$ system-image-cli -i
current build number: 160
device name: mako
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-11-12 07:59:01
version version: 160
version ubuntu: 20151112.1
version device: 20150911
version custom: mako-1.1

$ apt-cache policy qtdeclarative5-ubuntu-ui-toolkit-plugin
qtdeclarative5-ubuntu-ui-toolkit-plugin:
  Installed: 1.3.1705+15.04.20151118-0ubuntu1
  Candidate: 1.3.1705+15.04.20151118-0ubuntu1
  Version table:
 *** 1.3.1705+15.04.20151118-0ubuntu1 0
       1001 http://ppa.launchpad.net/ci-train-ppa-service/stable-phone-overlay/ubuntu/ vivid/main armhf Packages
        100 /var/lib/dpkg/status
     1.2.1458+15.04.20150422-0ubuntu1 0
        500 http://ports.ubuntu.com/ubuntu-ports/ vivid/main armhf Packages

Related branches

Further videos showing this in clock and weather, along with the click packages can be found at http://people.canonical.com/~alan/uitk1.3bug/

Tim Peeters (tpeeters) wrote :

With the current header configuration using Page.head there is this issue, and other issues related to the configuration of more customized header. We introduced a new Page.header property (in UITK staging, soon to land in trunk) that can be set to any Item to have your own header, and if you set it to an instance of the new PageHeader component, it will look the same as the current header. It will require changing some code (not much) related to the header, but after doing that you will have a lot more flexibility in what you can do with the header, including properly hiding/disabling it.

The current API will keep working in UITK 1.3, as long as you don't set the Page.header property, the old header will appear for your page. But I will recommend apps to switch to the new header once we have it landed in an image. The documentation for the header will be included in UITK docs at the same time the new features land.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
importance: Undecided → High
status: New → Confirmed
Tim Peeters (tpeeters) on 2015-11-19
tags: added: header
Andrew Hayzen (ahayzen) wrote :

I've attached an example application that shows the issue with the header 'sliding out'.

It should be noted that it requires the PageStack, if I just put the Page inside the MainView it appears to be fine, I assume this due to an empty header being shown, then as the page is pushed on it slides out to hide the header. It ideally needs to skip the animation when first starting, so there isn't a sliding in/out animation.

Tim Peeters (tpeeters) on 2016-01-28
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Tim Peeters (tpeeters) wrote :

This duplicate bug https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1524901 reports the issue also with Music, dekko, messaging-app.

Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
milestone: none → ww08-2016
status: New → In Progress
Tim Peeters (tpeeters) wrote :

<ahayzen> t1mp, i don't think bug 1524901 and bug 1518002 are duplicates, One is stating that if you have the header locked in the visible=false state then it animates on startup. The other states that some apps that have a header get an extra gap at startup. Although they may be linked in terms of how they'll be fixed

Zoltan Balogh (bzoltan) on 2016-03-09
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers