[listitemlayout] setting RichText format with html image tag leads to crash (segfault)

Bug #1514173 reported by Andrea Bernabei on 2015-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
Critical
Andrea Bernabei

Bug Description

ListItemLayout defines a default main slot, which is currently the internal class UCThreeLabelsSlot.

ListItemLayout currently doesn't set the QML context of the UCThsreeLabelsSlot, and UCThreeLabelsSlot doesn't set the QML context of its internal UCLabels.

This leads to a segfault when Qt tries to access the QML context of any of the predefined labels in ListItemLayout.

The following test case triggers the crash:
ListItemLayout {
    id: layoutTestQmlContext
    title.text: "<html><body><p dir='ltr'>TEST <img align=absmiddle height=\"10\" width=\"10\" src=\"file:///test.png\" /> </p></body></html>"
    title.textFormat: Text.RichText
}

Related branches

Andrea Bernabei (faenil) on 2015-11-08
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Andrea Bernabei (faenil)
status: New → In Progress
Zsombor Egri (zsombi) on 2015-11-11
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
tags: added: regression-proposed
Timo Jyrinki (timo-jyrinki) wrote :

Tentatively for OTA-8 if possible.

Changed in canonical-devices-system-image:
milestone: none → ww46-2015
assignee: nobody → Zoltan Balogh (bzoltan)
Timo Jyrinki (timo-jyrinki) wrote :

Ok, more likely to OTA-9.

Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
tags: removed: regression-proposed
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → Critical
Andrea Bernabei (faenil) on 2015-11-20
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2015-12-05
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Łukasz Zemczak (sil2100) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1742+15.04.20151209-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1742+15.04.20151209-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickView when the application quits. Fixing segfault caused by the
    dangling objects in GestireDetector.
  * BottomEdgeHint API changes, deprecating state property, introducing locked
    property to drive visuals lock and click handling.
  * Fixing CheckBox and Switch getting checked property altered after clicked()
    signal is emitted. Fixes LP: #1510919.
  * Add ListItem.swipeEnabled property to block swiping when overlay MouseArea
    is used to drag content. Fixes swiping when leading/trailing actions list
    is empty. Fixes LP: #1500409, LP: #1500416.
  * Follow the new design in BottomEdgeHint.
  * Provide import version information for StyledItem and remove theme.version
    obsolete property.
  * Use QQuickItemChangeListener to listen parent changes, skipping the meta
    object model. Convert UCThemingExtension into a Q_INTERFACE so object_cast<>
    can work with it saving the need to memorise on an item whether it is an
    extended item or not.
  * Set mouseAttached to false to revert regression in UITK gallery.
  * Remove BottomEdgeHint from UITK gallery's MainPage.qml which occludes with
    the bottom-up dragging of the ListView.

  [ Benjamin Zeller ]
  * Avoid unnecessary updates for i18n strings.
  * "MathUtils.clamp, min value should not be bigger than the max value".
    Fixes LP: #1520557.
  * Move MathUtils to Cpp.

  [ Loïc Molinari ]
  * UbuntuShape - Fixed deprecation logging issues.
  * This fix prevents logging a deprecation warning for "image", "color" and
    "gradientColor" properties when the import version is less than 1.3. The
    logging of properties used internally (through the old image wrapper) have
    been removed too since the user might not even have used them.
    Fixes LP: #1519414.

  [ Christian Dywan ]
  * Enable gallery target in qmake.
  * Don't set activeFocusOnPress on TextField but on child only.
    Fixes LP: #1486274, LP: #1513897.
  * Make runtest.sh work out of the box again.
  * Explicitly handle keyboard anchoring in dialog foreground.
    Fixes LP: #1376763.
  * Remove GestureDetector in favor of SwipeArea in BottomEdgeHint. Also make
    possible to assign Action to the ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers