UITK unixsignalhandler_p.cpp: error: functional cast to array

Bug #1484004 reported by Timo Jyrinki on 2015-08-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu RTM)
High
Timo Jyrinki

Bug Description

A new error with UITK when compiled against Qt 5.5 (the problem was not there in July)

---
In file included from /usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:74:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qnamespace.h:37,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qobjectdefs.h:41,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qobject.h:40,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/QObject:1,
                 from plugin/unixsignalhandler_p.h:20,
                 from plugin/unixsignalhandler_p.cpp:18:
/usr/include/x86_64-linux-gnu/qt5/QtCore/qpair.h: In instantiation of 'constexpr QPair<T1, T2>::QPair() [with T1 = int [2]; T2 = QSocketNotifier*]':
plugin/unixsignalhandler_p.cpp:50:17: required from here
/usr/include/x86_64-linux-gnu/qt5/QtCore/qpair.h:49:9: error: functional cast to array type 'int [2]'
         Q_DECL_NOEXCEPT_EXPR(noexcept(T1()) && noexcept(T2()))
         ^
/usr/include/x86_64-linux-gnu/qt5/QtCore/qpair.h: In instantiation of 'constexpr QPair<T1, T2>::QPair() [with T1 = int [2]; T2 = QSocketNotifier*]':
plugin/unixsignalhandler_p.cpp:50:17: required from here
/usr/include/x86_64-linux-gnu/qt5/QtCore/qpair.h:49:9: error: functional cast to array type 'int [2]'
make[4]: *** [.obj/unixsignalhandler_p.o] Error 1
---

Build log: https://launchpadlibrarian.net/214254104/buildlog_ubuntu-wily-amd64.ubuntu-ui-toolkit_1.3.1584%2B15.10.20150730-0ubuntu2~wily1~test1~qt550~1_BUILDING.txt.gz

Information about Qt 5.5 at https://wiki.ubuntu.com/Touch/QtTesting

Related branches

Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
Timo Jyrinki (timo-jyrinki) wrote :

< zsombi> Mirv: it cries because of constexpr... but there's no constexpr there... C++11 issue?
< zsombi> Mirv: I guess we need to rewrite the Handler type, so it doesn't use int[2] but some Qt
< zsombi> Mirv: like QVector<int>

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
status: Confirmed → In Progress
Albert Astals Cid (aacid) wrote :

I've reported this as a bug upstream seems it seems like a QPair regression to me https://bugreports.qt.io/browse/QTBUG-48780

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Zoltan Balogh (bzoltan) on 2015-12-05
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Łukasz Zemczak (sil2100) wrote :
Download full text (6.8 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1742+15.04.20151209-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1742+15.04.20151209-0ubuntu1) vivid; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickView when the application quits. Fixing segfault caused by the
    dangling objects in GestireDetector.
  * BottomEdgeHint API changes, deprecating state property, introducing locked
    property to drive visuals lock and click handling.
  * Fixing CheckBox and Switch getting checked property altered after clicked()
    signal is emitted. Fixes LP: #1510919.
  * Add ListItem.swipeEnabled property to block swiping when overlay MouseArea
    is used to drag content. Fixes swiping when leading/trailing actions list
    is empty. Fixes LP: #1500409, LP: #1500416.
  * Follow the new design in BottomEdgeHint.
  * Provide import version information for StyledItem and remove theme.version
    obsolete property.
  * Use QQuickItemChangeListener to listen parent changes, skipping the meta
    object model. Convert UCThemingExtension into a Q_INTERFACE so object_cast<>
    can work with it saving the need to memorise on an item whether it is an
    extended item or not.
  * Set mouseAttached to false to revert regression in UITK gallery.
  * Remove BottomEdgeHint from UITK gallery's MainPage.qml which occludes with
    the bottom-up dragging of the ListView.

  [ Benjamin Zeller ]
  * Avoid unnecessary updates for i18n strings.
  * "MathUtils.clamp, min value should not be bigger than the max value".
    Fixes LP: #1520557.
  * Move MathUtils to Cpp.

  [ Loïc Molinari ]
  * UbuntuShape - Fixed deprecation logging issues.
  * This fix prevents logging a deprecation warning for "image", "color" and
    "gradientColor" properties when the import version is less than 1.3. The
    logging of properties used internally (through the old image wrapper) have
    been removed too since the user might not even have used them.
    Fixes LP: #1519414.

  [ Christian Dywan ]
  * Enable gallery target in qmake.
  * Don't set activeFocusOnPress on TextField but on child only.
    Fixes LP: #1486274, LP: #1513897.
  * Make runtest.sh work out of the box again.
  * Explicitly handle keyboard anchoring in dialog foreground.
    Fixes LP: #1376763.
  * Remove GestureDetector in favor of SwipeArea in BottomEdgeHint. Also make
    possible to assign Action to the ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww02-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers