music-app blocks system suspend even when not playing any song

Bug #1423787 reported by Ricardo Salveti on 2015-02-20
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
qtmir (Ubuntu)
High
Gerry Boland
qtmir (Ubuntu RTM)
High
Gerry Boland
unity8 (Ubuntu RTM)
Undecided
Unassigned

Bug Description

current build number: 241
device name: krillin
channel: ubuntu-touch/ubuntu-rtm/14.09-proposed
last update: 2015-02-20 00:41:40
version version: 241
version ubuntu: 20150219
version device: 20150216-fe747ac
version custom: 20150216-561-29-186

I know we currently have an exception in the lifecycle for music-app, and it seems that there is a quite critical bug with it at the current image.

Opening up music-app is already enough for unity8 to hold a system state request from powerd, blocking suspend until you close the app (having it in the background doesn't really help here).

Ideally the system state request (wakelock) should just be enabled and active when the music-app is also active, playing songs.

This bug can drastically affect the battery life for the user of the phone.

You can check this by running 'powerd-cli list' after opening music-app.
phablet@ubuntu-phablet:~$ powerd-cli list
powerd-cli: Running as user is not fully supported.
System State Requests:
  Name: active, Owner: :1.77, State: 1

Related branches

affects: unity8 (Ubuntu) → unity8 (Ubuntu RTM)
tags: added: battery
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
Gerry Boland (gerboland) on 2015-02-20
Changed in qtmir (Ubuntu RTM):
assignee: nobody → Gerry Boland (gerboland)
importance: Undecided → High
status: New → In Progress
Changed in unity8 (Ubuntu RTM):
status: New → Invalid
Changed in canonical-devices-system-image:
milestone: none → ww13-ota
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtmir (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2015-03-05
Changed in qtmir (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Gerry Boland (gerboland)
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.4+15.04.20150306.1~rtm-0ubuntu1

---------------
qtmir (0.4.4+15.04.20150306.1~rtm-0ubuntu1) 14.09; urgency=medium

  [ Gerry Boland ]
  * Refactor wakelock handling. Lifecycle exempt apps now release
    wakelock when shell tries to suspend them (LP: #1423787)
 -- CI Train Bot <email address hidden> Fri, 06 Mar 2015 14:20:33 +0000

Changed in qtmir (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2015-03-09
Changed in qtmir (Ubuntu):
assignee: Gerry Boland (gerboland) → Michał Sawicz (saviq)
Michał Sawicz (saviq) on 2015-03-16
Changed in qtmir (Ubuntu):
assignee: Michał Sawicz (saviq) → Gerry Boland (gerboland)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.4+15.04.20150318-0ubuntu1

---------------
qtmir (0.4.4+15.04.20150318-0ubuntu1) vivid; urgency=medium

  [ Daniel d'Andrada ]
  * Port to the new MirEvent API and add support for pointer events.
    (LP: #1417650, #1392716)

  [ Gerry Boland ]
  * Refactor wakelock handling. Lifecycle exempt apps now release
    wakelock when shell tries to suspend them (LP: #1423787)

  [ Robert Carr ]
  * Port to the new MirEvent API and add support for pointer events.
    (LP: #1417650, #1392716)
 -- CI Train Bot <email address hidden> Wed, 18 Mar 2015 10:12:22 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers