unity8 crashed with SIGABRT in g_assertion_message() when launching calculator from quicklist

Bug #1408819 reported by Michał Sawicz on 2015-01-08
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
qtmir (Ubuntu RTM)
Critical
Michał Sawicz

Bug Description

Steps:
* add calculator app to launcher
* long-press on the calculator item in the launcher
* tap the top action "Calculator"
* repeat if necessary

Expected:
* calculator is launched or focused

Current:
* unity8 aborts due to some utf8 encoding issue

ProblemType: Crash
DistroRelease: Ubuntu RTM 14.09
Package: unity8 8.02+15.04.20150107~rtm-0ubuntu1
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.14.7-0ubuntu8
Architecture: armhf
CurrentDesktop: Unity
Date: Thu Jan 8 23:18:50 2015
ExecutablePath: /usr/bin/unity8
ExecutableTimestamp: 1420625961
InstallationDate: Installed on 2014-12-18 (21 days ago)
InstallationMedia: Ubuntu Utopic Unicorn (development branch) - armhf (20141218-163635)
ProcCmdline: unity8
ProcCwd: /home/phablet
Signal: 6
SourcePackage: unity8
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip plugdev sudo tty video

Related branches

Michał Sawicz (saviq) wrote :
affects: unity8 (Ubuntu) → unity8 (Ubuntu RTM)
Michał Sawicz (saviq) wrote :

This seems to be an rtm-only issue, btw.

Michael Zanetti (mzanetti) wrote :

I've debugged this a bit now. It crashes when calling

QDesktopServices::openUrl("appid://com.ubuntu.calculator/calculator/current-user-version");

which seems ok to me. So it seems the bug is further down the stack...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: url-dispatcher → url-dispatcher (Ubuntu)
Changed in url-dispatcher (Ubuntu):
status: New → Confirmed
Changed in url-dispatcher (Ubuntu):
importance: Undecided → Medium
tags: removed: need-armhf-retrace
Michał Sawicz (saviq) on 2015-01-09
information type: Private → Public
Michał Sawicz (saviq) on 2015-01-09
affects: unity8 (Ubuntu RTM) → qtmir (Ubuntu RTM)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Michał Sawicz (saviq) on 2015-01-09
affects: url-dispatcher (Ubuntu) → qtubuntu (Ubuntu)
Changed in qtubuntu (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) wrote :

I've added some debugging to Services::callDispatcher

> qDebug() << qUrl << url;

When everything's fine, the debug output is as expected:

> QUrl( "application:///dialer-app.desktop" ) application:///dialer-app.desktop

But when stuff breaks:

> QUrl( "appid://com.ubuntu.calculator/calculator/current-user-version" ) p��
> QUrl( "appid://com.ubuntu.calculator/calculator/current-user-version" ) a

So it looks like us using "qUrl.toEncoded().constData();" isn't safe.

Michał Sawicz (saviq) on 2015-01-09
Changed in qtmir (Ubuntu RTM):
assignee: Michael Zanetti (mzanetti) → Michał Sawicz (saviq)
Changed in qtubuntu (Ubuntu):
assignee: nobody → Michał Sawicz (saviq)
status: New → Triaged
Changed in qtmir (Ubuntu RTM):
status: Triaged → In Progress
Changed in qtubuntu (Ubuntu):
status: Triaged → In Progress
no longer affects: qtubuntu (Ubuntu)
no longer affects: qtubuntu
Michał Sawicz (saviq) on 2015-01-13
Changed in qtmir (Ubuntu RTM):
milestone: none → 14.09-ota-2
no longer affects: qtmir (Ubuntu)
Michał Sawicz (saviq) on 2015-01-14
no longer affects: qtmir (Ubuntu)
Michał Sawicz (saviq) on 2015-01-14
Changed in qtmir (Ubuntu RTM):
status: In Progress → Fix Released
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.4+15.04.20150120~rtm-0ubuntu1

---------------
qtmir (0.4.4+15.04.20150120~rtm-0ubuntu1) 14.09; urgency=low

  [ CI Train Bot ]
  * Resync trunk
  * Resync trunk
  * Resync trunk
  * Resync trunk

  [ Michał Sawicz ]
  * Declare the QByteArray in callDispatcher so it doesn't get deleted
    before it's copied. (LP: #1408819)
 -- Ubuntu daily release <email address hidden> Tue, 20 Jan 2015 11:22:12 +0000

Changed in qtmir (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers