Sound-indicator (from MPRIS) shows no metadata for m4a audio

Bug #1368290 reported by Andrew Hayzen on 2014-09-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
media-hub (Ubuntu)
High
Unassigned
media-hub (Ubuntu RTM)
High
Unassigned

Bug Description

$ system-image-cli -i
current build number: 237
device name: mako
channel: ubuntu-touch/devel-proposed
alias: ubuntu-touch/utopic-proposed
last update: 2014-09-11 15:10:01
version version: 237
version ubuntu: 20140911.1
version device: 20140903.1
version custom: mako-0.3a

1) Start the music-app
2) Start playing some m4a audio and note that the metadata is shown in the app
3) Open the sound indicator to see the media controls and notice that no metadata is shown

Jim Hodapp (jhodapp) on 2014-09-11
Changed in media-hub:
assignee: nobody → Thomas Voß (thomas-voss)
importance: Undecided → High
Jim Hodapp (jhodapp) on 2014-09-25
Changed in media-hub:
status: New → Triaged
Jim Hodapp (jhodapp) on 2015-11-20
Changed in media-hub (Ubuntu RTM):
status: New → Invalid
no longer affects: media-hub
Jim Hodapp (jhodapp) wrote :

Confirmed that no metadata seems to be getting extracted by playbin for m4a files. Still need to figure out why this is since the m4a codec type works for playback.

Changed in media-hub (Ubuntu RTM):
status: Invalid → Triaged
importance: Undecided → High
Changed in media-hub (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
status: New → Triaged
importance: Undecided → High
Jim Hodapp (jhodapp) on 2016-09-21
Changed in canonical-devices-system-image:
status: Triaged → Fix Released
Changed in media-hub (Ubuntu):
status: Triaged → Fix Released
Changed in media-hub (Ubuntu RTM):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers