headphone button does not play/pause music.

Bug #1309731 reported by Chris Gagnon on 2014-04-18
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Canonical System Image
John McAleely
Ubuntu Music App
media-hub (Ubuntu)
Jim Hodapp
media-hub (Ubuntu RTM)

Bug Description

headphone button does not play/pause music

1. plug in headphones with a call/hangup button in headphone jack
2. import music in to music folder
3. open music app and play song
3. press headphone button a few times

expected results:
music is played or paused when pressing the headphone button

actual results
nothing happens.

Additional info, this should also answer/hangup a phone call.

no longer affects: touch-preview-images
Jim Hodapp (jhodapp) wrote :

I'll have to get a headphone pair that has this kind of button. I do have the Apple earbuds that have volume buttons...I'll have to see if this works.

Simon K (octav14n) wrote :

This seems to be a duplicate of https://bugs.launchpad.net/music-app/+bug/1231909 .
If you agree, please mark one of the bugs as a duplicate of the other one.

Selene ToyKeeper (toykeeper) wrote :

Still broken in Utopic image 140.

Jim Hodapp (jhodapp) on 2014-07-31
Changed in pulseaudio:
assignee: nobody → Ricardo Salveti (rsalveti)
Changed in media-hub:
status: New → Invalid
Changed in music-app:
status: New → Invalid
Ricardo Salveti (rsalveti) wrote :

I don't see how this fix would end up being part of pulseaudio, as it shouldn't be controlling the play/pause by itself (the external client should be responsible for that instead).

I'm still not completely sure how android is managing such headset switch (probably via input devices), but I believe this should be part of media-hub instead.

Ricardo Salveti (rsalveti) wrote :
affects: media-hub → media-hub (Ubuntu)
Changed in media-hub (Ubuntu):
status: Invalid → Confirmed
no longer affects: pulseaudio
Changed in media-hub (Ubuntu RTM):
status: New → Confirmed
Changed in media-hub (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
milestone: none → backlog
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
James Lewis (james-fsck) wrote :

This appears to apply to bluetooth headphones also....

Jim Hodapp (jhodapp) wrote :

@James: support for BT headsets will be coming with the Bluez5 landing that is currently being worked on. So stay tuned.

Sturm Flut (sturmflut) wrote :

My wired headset generates key input events on krillin and mako, and Unity already has partial support for them. The problem seems to be that the hardware/driver does not emit the same key codes on all devices.

Sennheiser CX2.00G earbuds connected to krillin OTA-8:
Play/Pause/Hook button emits Qt::Key_MediaPlay
Volume up button emits Qt::Key_MediaPrevious
Volume down button emits Qt::Key_MediaNext

Sennheiser CX2.00G earbugs connected to mako ubuntu-touch/rc-proposed/ubuntu-pd r85:
Play/Pause/Hook button emits Qt::Key_LaunchMedia
Volume up button emits nothing
Volume down button emits nothing

As far as I can see AOSP ships a key mapping file for every device to compensate for this.

James Lewis (james-fsck) wrote :

Bluetooth play/pause confirmed NOT working in OTA12.

James Lewis (james-fsck) wrote :

Confirmed in OTA-13

Also, this impacts bluetooth car audio systems, so this issue may now be safety related.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers