Locked toolbar closes after timeout and cannot be opened afterwards

Bug #1248759 reported by Leo Arias on 2013-11-06
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu Calendar App
Undecided
Unassigned
Ubuntu Clock App
High
Unassigned
Ubuntu File Manager App
High
Unassigned
Ubuntu Shorts App
High
Unassigned
Ubuntu UI Toolkit
Fix Released
Critical
Tim Peeters
ubuntu-ui-toolkit (Ubuntu)
Undecided
Tim Peeters

Bug Description

Steps to reprodue:

Open the rss app
Open the toolbar
Click the Add reads button
Click the Add feads option
Wait for the toolbar to disappear
At this point, it's not possible to make it appear.

I'm testing in and up-to-date trusty, using trunk.

The toolbar in the main page works fine, I can hide and reveal it.

Related branches

Do you really think that it is our local (application-wide) problem rather
than in SDK? :)
They changed toolbar's default behavior (hiding it after 5 seconds as far
as I know),
so all questions to them.
I can only give an advice - reason of this bug is much deeper, than anyone
can think.
Such behavior can't be reproduced in simple app with few pages, only when
there is a stack
of pages. Check code of our app for more info.

2013/11/7 Leo Arias <email address hidden>

> Public bug reported:
>
> Steps to reprodue:
>
> Open the rss app
> Open the toolbar
> Click the Add reads button
> Click the Add feads option
> Wait for the toolbar to disappear
> At this point, it's not possible to make it appear.
>
> I'm testing in and up-to-date trusty, using trunk.
>
> The toolbar in the main page works fine, I can hide and reveal it.
>
> ** Affects: ubuntu-rssreader-app
> Importance: High
> Status: New
>
>
> ** Tags: elopio qa-touch
>
> --
> You received this bug notification because you are a member of Ubuntu
> RSS Feed Reader Developers, which is subscribed to Ubuntu RSS Feed
> Reader App.
> Matching subscriptions: Ubuntu RSS Reader Bugmail
> https://bugs.launchpad.net/bugs/1248759
>
> Title:
> Once the toolbar in the Add feeds page is hidden, I can't make it
> appear anymore
>
> Status in RSS Feed Reader application for Ubuntu devices:
> New
>
> Bug description:
> Steps to reprodue:
>
> Open the rss app
> Open the toolbar
> Click the Add reads button
> Click the Add feads option
> Wait for the toolbar to disappear
> At this point, it's not possible to make it appear.
>
> I'm testing in and up-to-date trusty, using trunk.
>
> The toolbar in the main page works fine, I can hide and reveal it.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-rssreader-app/+bug/1248759/+subscriptions
>

Marking as confirmed, reproduced by veebers.
I'll ask the SDK team about this.

Changed in ubuntu-rssreader-app:
status: New → Confirmed
Joey Chan (qqworini) wrote :

Maybe the "locked" property of toolbar cause this bug, I did a workaround for previous version , but now came out again.

Comment the "locked" property should work, I will have a try later.

Tim Peeters (tpeeters) wrote :

do you have a small qml program to reproduce this bug?

Joey Chan (qqworini) wrote :

I can't reproduce in my environment: Kubuntu 12.04 with SDK ppa

Also can't reproduce in my nexus 4 with saucy r100

Seems it's only happen in latest SDK version

Ken VanDine (ken-vandine) wrote :

I've noticed this in clock-app in the add alarm page and calendar-app in the new appointment page. Both lock the toolbar open to show the save button.

Tim Peeters (tpeeters) on 2013-11-07
Changed in ubuntu-ui-toolkit:
assignee: nobody → Tim Peeters (tpeeters)
importance: Undecided → Critical
Changed in ubuntu-clock-app:
status: New → Confirmed
importance: Undecided → High
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Changed in ubuntu-clock-app:
milestone: none → 1.2
Tim Peeters (tpeeters) on 2013-11-08
summary: - Once the toolbar in the Add feeds page is hidden, I can't make it appear
- anymore
+ Locked toolbar closes after timeout and cannot be opened afterwards
tags: added: toolbar
Tim Peeters (tpeeters) wrote :

I'm trying to reproduce this issue, but the following code does not reproduce it:

import QtQuick 2.0
import Ubuntu.Components 0.1

MainView {
    width: units.gu(50)
    height: units.gu(80)
    id: mainView

    Page {
        id: page
        title: "test page"
        Label {
            anchors.centerIn: parent
            text: "testing the toolbar"
        }
        tools: ToolbarItems {
            id: toolbarItems
            ToolbarButton {
                text: "action1"
            }
            locked: true
            opened: true
        }
    }
// Component.onCompleted: mainView.__propagated.toolbar.open()
}

When the toolbar is locked, it does not auto-hide.

Tim Peeters (tpeeters) wrote :

aha! If I use this code:

import QtQuick 2.0
import Ubuntu.Components 0.1

MainView {
    width: units.gu(50)
    height: units.gu(80)
    id: mainView

    Tabs {
        Tab {
            title: "test"

            page: Page {
                id: page
                title: "test page"
                Label {
                    anchors.centerIn: parent
                    text: "testing the toolbar"
                }
                tools: ToolbarItems {
                    id: toolbarItems
                    ToolbarButton {
                        text: "action1"
                    }
                    locked: true
                    opened: true
                }
            }
        }

        Tab {
            title: "empty"
            page: Page { }
        }
    }
}

and then switch tabs, and switch back, I can reproduce.

Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Changed in ubuntu-filemanager-app:
status: New → Confirmed
importance: Undecided → High
Tim Peeters (tpeeters) on 2013-11-08
Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Tim Peeters (tpeeters) on 2013-11-28
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Changed in ubuntu-clock-app:
status: Confirmed → Fix Committed
David Planella (dpm) wrote :

What's the status of this bug for the core apps? Did the UITK bugfix resolve the issue? Is there still a workaround required?

Changed in ubuntu-calendar-app:
status: New → Incomplete
Changed in ubuntu-filemanager-app:
status: Confirmed → Incomplete
Changed in ubuntu-rssreader-app:
status: Confirmed → Incomplete
Changed in ubuntu-clock-app:
status: Fix Committed → Fix Released
David Planella (dpm) on 2014-10-08
Changed in ubuntu-rssreader-app:
status: Incomplete → Fix Released
Changed in ubuntu-calendar-app:
status: Incomplete → Fix Released
Changed in ubuntu-filemanager-app:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers