test_rssreader.TestMainWindow.test_add_remove_feed_and_topic failure on devices

Bug #1210571 reported by Paul Larson on 2013-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Shorts App
High
Nicholas Skaggs
touch-preview-images
Fix Released
Undecided
Nicholas Skaggs

Bug Description

Image: 20130809

The test_rssreader.TestMainWindow.test_add_remove_feed_and_topic test for ubuntu-rssreader-app is failing in the daily automated test runs.

Traceback (most recent call last):
  File "/usr/bin/autopilot", line 351, in <module>
    main()
  File "/usr/bin/autopilot", line 342, in main
    run_tests(args)
  File "/usr/bin/autopilot", line 119, in run_tests
    success = runner.run(test_suite).wasSuccessful()
  File "/usr/bin/autopilot", line 211, in run
    return test.run(result)
  File "/usr/lib/python2.7/unittest/suite.py", line 108, in run
    test(result)
  File "/usr/lib/python2.7/unittest/case.py", line 395, in __call__
    return self.run(*args, **kwds)
  File "/usr/lib/python2.7/dist-packages/testscenarios/testcase.py", line 62, in run
    test.run(result)
  File "/usr/lib/python2.7/dist-packages/testscenarios/testcase.py", line 65, in run
    return super(WithScenarios, self).run(result)
  File "/usr/lib/python2.7/dist-packages/testtools/testcase.py", line 526, in run
    return self.__RunTest(self, self.exception_handlers).run(result)
  File "/usr/lib/python2.7/dist-packages/testtools/runtest.py", line 74, in run
    return self._run_one(actual_result)
  File "/usr/lib/python2.7/dist-packages/testtools/runtest.py", line 88, in _run_one
    return self._run_prepared_result(ExtendedToOriginalDecorator(result))
  File "/usr/lib/python2.7/dist-packages/testtools/runtest.py", line 107, in _run_prepared_result
    handler(self.case, self.result, e)
  File "/usr/lib/python2.7/dist-packages/testtools/testcase.py", line 499, in _report_failure
    result.addFailure(self, details=self.getDetails())
  File "/usr/lib/python2.7/dist-packages/testtools/testresult/real.py", line 1150, in addFailure
    err = self._details_to_exc_info(details)
  File "/usr/lib/python2.7/dist-packages/testtools/testresult/real.py", line 1212, in _details_to_exc_info
    _StringException(_details_to_str(details, special='traceback')),
  File "/usr/lib/python2.7/dist-packages/testtools/testresult/real.py", line 1751, in _details_to_str
    text = content.as_text().strip()
  File "/usr/lib/python2.7/dist-packages/testtools/content.py", line 84, in as_text
    return _u('').join(self.iter_text())
  File "/usr/lib/python2.7/dist-packages/testtools/content.py", line 109, in _iter_text
    for bytes in self.iter_bytes():
  File "/usr/lib/python2.7/dist-packages/testtools/content.py", line 88, in iter_bytes
    return self._get_bytes()
  File "/usr/lib/python2.7/dist-packages/testtools/content.py", line 212, in <lambda>
    return Content(UTF8_TEXT, lambda: [text.encode('utf8')])
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 5518: ordinal not in range(128)

Maybe we should use a different rss feed?

More detail can be found at http://reports.qa.ubuntu.com/smokeng/saucy/image/3439/ubuntu-rssreader-app-autopilot/250858/

Related branches

Changed in touch-preview-images:
assignee: nobody → Nicholas Skaggs (nskaggs)
Changed in ubuntu-rssreader-app:
assignee: nobody → Nicholas Skaggs (nskaggs)
status: New → Fix Released
Changed in touch-preview-images:
status: New → Fix Released
Nicholas Skaggs (nskaggs) wrote :

So, now it appears the keyboard being stuck open prevents the page from loading.

Changed in ubuntu-rssreader-app:
status: Fix Released → In Progress
Nicholas Skaggs (nskaggs) wrote :

I'm seeing it get stuck after entering the rss feed and not able to hit next because the keyboard is still onscreen. If anyone has ideas on fixing them, I'm all ears.

Changed in ubuntu-rssreader-app:
assignee: Nicholas Skaggs (nskaggs) → nobody
assignee: nobody → Omer Akram (om26er)
Paul Larson (pwlars) on 2013-08-15
Changed in touch-preview-images:
status: Fix Released → In Progress
Omer Akram (om26er) wrote :

Its something we can't fix in our tests, the app should fix the behavior, i.e. when the OSK appears, the toolbar should appear above the OSK, just like in the phone-app.

something like this is what needs to be done: http://bazaar.launchpad.net/~phablet-team/address-book-app/trunk/revision/12

Changed in ubuntu-rssreader-app:
status: In Progress → New
Changed in touch-preview-images:
status: In Progress → New
Changed in ubuntu-rssreader-app:
assignee: Omer Akram (om26er) → nobody
Changed in ubuntu-rssreader-app:
status: New → Confirmed
importance: Undecided → High
David Planella (dpm) on 2013-08-29
Changed in ubuntu-rssreader-app:
status: Confirmed → Triaged
assignee: nobody → Nicholas Skaggs (nskaggs)

Fix committed into lp:ubuntu-rssreader-app at revision 64, scheduled for release in ubuntu-rssreader-app, milestone alpha-1

Changed in ubuntu-rssreader-app:
status: Triaged → Fix Committed
Nicholas Skaggs (nskaggs) wrote :

The tests are still failing, changing status to reflect

Changed in ubuntu-rssreader-app:
status: Fix Committed → Fix Released
Changed in touch-preview-images:
status: New → Fix Released
Changed in ubuntu-rssreader-app:
status: Fix Released → In Progress
Changed in ubuntu-rssreader-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers