Weather links in today scope lead to 404 weather.com pages

Bug #1629243 reported by Andrea Bernabei on 2016-09-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Today Scope
Undecided
Unassigned
Ubuntu Rest Scopes
High
Kyle Nitzsche

Bug Description

Krillin, rc-proposed/bq-aquaris.en, r440

How to reproduce:
1) open today scope
2) tap on Today's card (not the category) to open the preview page of today's weather info
3) tap on "10 day forecast" (green button)

Expected result:
The browser launches, and the 10day forecast page for the current location is shown

Actual result:
The browser launches and shows "Oh no! The page you are looking for does not exist. Go back, friend, go back!" 404 page from weather.com

Additional notes:
this works properly if you do the same from the Weather Channel scope

Related branches

Andrea Bernabei (faenil) on 2016-09-30
description: updated
Andrea Bernabei (faenil) wrote :

This worked properly after forcing a refresh of Today's scope data.

Not sure what data the card was showing...it sounds like it wasn't showing actual data, and maybe it didn't know the current location so the web request was malformed?

Andrea Bernabei (faenil) wrote :

Here's unity8-dash.log, from the start to the point where the wrong URL was used.

royden (ryts) wrote :

Following the described steps on arale, rc-proposed I arrived at weather.com page showing 'news'items but no location weather.

I seldom use weather on the today scope, for info and I cannot reproduce this by switching off device.

Kyle Nitzsche (knitzsche) wrote :

Hi and thanks for reporting the bug!

This is not a Today scope bug. The Today scope just displays results from child scopes, like the Weather Channel scope, and this includes the Preview page.

The Weather Channel scope is one of a few scopes that are not installed locally - they live on a server. The these scopes are part of the Ubuntu Rest Scopes project.

The Ubuntu Rest Scopes project already has a bug for this, which does not seem to have received attention.

https://bugs.launchpad.net/ubuntu-rest-scopes/+bug/1588997

I will make this a duplicate of that.

Changed in today-scope:
status: New → Invalid
Changed in ubuntu-rest-scopes:
status: New → Confirmed
Changed in ubuntu-rest-scopes:
importance: Undecided → High
assignee: nobody → Kyle Nitzsche (knitzsche)
Changed in today-scope:
status: Invalid → Opinion
Changed in ubuntu-rest-scopes:
status: Confirmed → In Progress
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments