Some scopes are not ready for changes in search semantics

Bug #1541025 reported by Paweł Stołowski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Fix Released
High
Alejandro J. Cura
Ubuntu Rest Scopes
New
Undecided
Unassigned
unity-scope-click (Ubuntu)
Fix Released
High
Paweł Stołowski

Bug Description

Some scopes are still not updated to correctly handle the change in search semantics (to be released with support for filters), that is to allow searching inside departments and displaying departments if search string is not empty (rather than doing search "globally", and only allow departments to be browsed).

This bug is to track any remaining scopes that needs updating.

Long explanation:

The change is in the semantics of the search in the UI. In the
old designs search was designed to be "global", i.e. if you
start typing, departments menu disappears and the search is
"broad". Departments were meant to be used and displayed only
for browsing, i.e. when search query is empty and departments
navigation is used. This search semantics is partially
reflected in the search logic of some scopes.

In the new approach unity shell plugin will no longer reset
current department to "root" nor hide departments menu when
you start typing a query, meaning you can search inside
departments. Some scopes may not expect this and have a simple
search logic along these lines (pseudo-code for better
clarity):

if (search_query_not_empty) {
         do_global_search(query_string); // current department surely must be root , so don't bother passing it around to search! Also, don't bother creating departments menu since UI will not display it when searching
         } else { // empty search string
             display_departments_menu(); // ok, empty search, so create departments menu
             display_results_for_department(current_department);
         }

Related branches

Changed in unity-scope-click (Ubuntu):
importance: Undecided → High
assignee: nobody → Pawel Stolowski (stolowski)
status: New → Confirmed
status: Confirmed → In Progress
description: updated
description: updated
description: updated
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
milestone: none → ww08-2016
status: New → Triaged
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-click - 0.1.1+16.04.20160321-0ubuntu1

---------------
unity-scope-click (0.1.1+16.04.20160321-0ubuntu1) xenial; urgency=medium

  [ Pawel Stolowski ]
  * Always push departments (departments should be available also in
    search mode) and allow searching inside departments. (LP: #1541025)

 -- Michael Zanetti <email address hidden> Mon, 21 Mar 2016 10:00:50 +0000

Changed in unity-scope-click (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers