Release Notes for Ubuntu

No way to save current session

Reported by Dave North on 2011-04-27
390
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
gnome-session (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Binary package hint: gnome-session

There is no way I can find to set up a session the way you'd like to have Unity start up and then save that setup. This also affects the Classic session.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-session 2.32.1-0ubuntu19
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Wed Apr 27 09:27:01 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en
 PATH=(custom, user)
 LANG=C
 LC_MESSAGES=en_US.UTF-8
 SHELL=/bin/csh
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Dave North (north) wrote :
jonaz__ (jonaz-86) wrote :

This is a real showstopper... im going back to ubuntu classic (gnome) until i can save session in unity!
I dont want to open 7 terminals and 2 browsers and alot of other apps every time i launch my computer and i dont want it running 27/7 because of the power bills.

rschlitz (rschlitz) wrote :

Can you save the session in classic now? In Ubuntu 10.10, the session could be saved System->Preferences->Startup Applications->Options; not now.

Dave North (north) wrote :

No, I can't! I was primarily interested in Unity, but it's very interesting to see the pref gone from Gnome 2 also. I hadn't previously tried starting classic -- at least on my setup, it does a pretty good job of matching things up. Which means unfortunately they both fail in the same way.

metti (mathias-schneuwlys) wrote :

This missing feature is also to me a show stopper!

I'm using Ubuntu in my lab on several test PCs and each PC uses about 20 terminal well ordered to have an overview over the system. To open and place each terminal after a restart is absolutely a NO GO to me!!!

I switched immediately back to Ubuntu Classic but also here the feature is missing or I've not yet found it...

I would be very pleased to add this feature again to Ubuntu!

Russ W. Knize (rknize) wrote :

This seems to have been broken by accident or on purpose. Very frustrating. You can enable it with gconf-editor ("Configuration Editor") under /app/gnome-session/options/auto_save_session, but it does not work for Unity or GNOME ("Ubuntu Classic").

Russ W. Knize (rknize) wrote :

Looks like it was removed deliberately:

http://ubuntuforums.org/showthread.php?t=1672787

The original rationale is that it was broken and they didn't have time to fix it. However the subsequent discussion shows that they do not intend to. The reasoning is highly flawed. I keep my machines on 24/7. I have 10 or more workspaces and dozens of terminals, editors, and you-name-it. It is how I manage doing many things in parallel since my brain cannot. I use this feature when I am forced to reboot due to a security update or some other major issue. Losing all of that context is detrimental to me. I've been struggling to figure out how to work with Unity, but after discovering this I fear I am going to have to say goodbye to Ubuntu. I've been using it since Breezy (and Debian much longer than that), but it is going in a direction that is not for power users and clearly not for me.

Dave North (north) wrote :

I think you've got it about right, though I interpret the discussion as "if someone finds a way to do it maybe we will put it in." On the other hand, it looks like it's a good thing somebody submitted a bug, since it appears the various folks in that discussion think it would be too much trouble or something to file it. Or really, that the general trend is to pretend this isn't a bug. I expect, following the logic of the discussion, that suspend and hibernate will soon be removed too.

However, I also agree that it looks unlikely it will be fixed. Note that (a) though the kernel etc in Squeeze is quite old, everything I've tried works there. It might be useful to consider that as an option. Just tryna be helpful!

Thomas Knudsen (knudsen-thomas) wrote :

I fully agree: this really is a showstopper. This is horrible!

jbaron (john-baron) wrote :

Ouch. I know the developers were running fast to get Natty out in time, but this is a mighty big hole for a lot of us.

I liked Unity when I first saw it -- for about 5 seconds. Then I couldn't figure out how to do anything, since it's all changed and the menus are gone. But I persisted and a few hours later I like it again. This lack of session memory is the first thing I've found missing / broken that I don't know how to work around without a lot of pain.

rschlitz (rschlitz) wrote :

Not to be too flip, but Kubuntu 11.04 (KDE) "looking like" ubuntu classic (gnome) has no problem saving the session. There may be other problems but that certainly is not one.

This needs to be fixed for all the reasons listed above...

Ian Booth (wallyworld) wrote :

I'm a KDE user and having just tried Unity for the first time am also affected by this issue. I really miss this feature. The forum thread mentioned in an earlier comment implies there are technical issues. Since KDE seems to manage to implement it successfully, could we look at how it is implemented there and do something similar?

I have updated to 11.04 few days ago and was quite surprised to lose my session. Even when I switched to "Ubuntu Classic" I would still lose my session. So I googled and found this discussion.

To be frank I find developers' reasoning to be flawed and to a certain extent disturbing. Session saving might not have worked for some applications but it did work for many others and since it was present in Ubuntu for few years (I think) many people were relying on it. Disabling it seems like display of disregard towards users, but I can understand that sometimes decisions like that have to be made. What I don't understand is why was this removed even as an option? You know for people who decide to enable it. You basically removed it as a choice which seems totally unreasonable.

Proposition to use suspend/hibernate for session saving sounds like a cruel joke, for two reasons. Firstly, those features themselves are unreliable and slow. (Talk about broken features that have side effects.) Secondly, Ubuntu doesn't support rebootless kernel update, so suspend/hibernate hardly help in situations when you need to update your kernel, but even if it did they you still need to shutdown your computer once in a while.

I have switched to Xfce for now and session saving works there just fine.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
summary: - No way to save current session
+ No way to save current session in Unity
Changed in gnome-session (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged

Pedro, this bug is in no way specific to Unity. It appears in Ubuntu-classic just the same.
Changing bug title accordingly.
Regards, Rüdiger.

summary: - No way to save current session in Unity
+ No way to save current session
Dave North (north) wrote :

Not sure I follow the sense of this change. First, the problem is specific to only Unity and its fallback mode. KDE, XFCE, etc are not affected.

Second, it was my understanding that Ubuntu-classic is a subset of Unity (the fallback 2d mode). Is that incorrect?

On the other hand, recent moves (wishlist backburner, change title) imply this is a wontfix...?

Thomas Amland (amland) wrote :

I think he just want to make sure that everyone understands that this bug appears in both the session "Ubuntu", "Ubuntu Classic" and "Unity 2D".

That's true, thank you Thomas. And my apologies, Pedro, if I misunderstood your intent.
The problem occurs in "Ubuntu Classic", which is, as Thomas pointed out, not "Unity 2D", but the traditional Gnome session as it was in Maverick.
Regards, Rüdiger

Pedro Villavicencio (pedro) wrote :

Ok I'll update the description as well then, because it clearly said 'Unity' thus the confusion, thanks all.

Changed in gnome-session (Ubuntu):
importance: Wishlist → Low
description: updated
Johannes Reif (johannes-reif) wrote :

Is there any progress on this?
Without saving sessions Ubuntu is worthless to me...

According to this, there's still hope for oneiric: https://blueprints.launchpad.net/ubuntu/+spec/desktop-o-session-management
Don't hold your breath for natty.

Russ W. Knize (rknize) wrote :

One of these days I want to try to revert Didier's patches on gnome-session to see if I can fix this. I've switched to Linux Mint, but they've inherited this same bug in their latest version based on natty (11).

I'm a bit confused with those session management work items. Isn't GNOME "Classic" being removed for oneiric? What is the point in fixing it?

Uhurusurfa (chrisbroderick) wrote :

Saved sessions save(d) time. Hope it gets re-instated and a patch made available for gnome shortly otherwise like others I will be looking to use a different distro.

Even if saved sessions didn't work in all cases their removal should have been mentioned in the release notes at least.

Changed in gnome-session (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Didier Roche (didrocks) wrote :

@Dimitris: unfortunatly not, I tried to reenable it for oneiric, but the same issues came again, with session mixing and no way ui at all in GNOME3 in the gnome-control-center to enable/disable session saving properly.
GNOME is thinking to disable it as well btw as the feature is broken.

@Dennis: this has been mentionned on the ubuntu desktop mailing list.

As stating there: https://lists.ubuntu.com/archives/ubuntu-desktop/2011-January/002734.html everyone wanting to help fixing that feature are welcome to contribute. Otherwise, nothing will happen.

Changed in gnome-session (Ubuntu):
assignee: Didier Roche (didrocks) → nobody

Session saving is a must have feature! I really missing it after switching from KDE to Gnome/Unity, KDE was and still is really good in session management and it would be great to see such session management in Gnome

frunc leiwss (salonder) wrote :

About the ubuntu version 11.04 logout: the gnome-session.
We can do this: killall gnome-session.As we know that we can type "sudo gnome-session-save --logout" then the os will logout!

Martin Pitt (pitti) wrote :

There is a pending upload for this:

+gnome-session (3.2.1-0ubuntu7) precise; urgency=low
+
+ * debian/patches/51_remove_session_saving_from_gui.patch:
+ - add GNOME_SESSION_SAVE environment variable for people wanting to
+ use the save session still, knowing that it can break your system
+ if used unwisely (LP: #771896)
+
+ -- Didier Roche <email address hidden> Thu, 12 Apr 2012 10:30:56 +0200

But really, this makes it so undiscoverable, and gnome-session's concept of session saving is so fundamentally broken that this just looks like a hack which nobody will know about, that I doubt that it makes much sense to add this. I don't have a strong opinion, though, so if you want to push this, I won't veto.

Kate Stewart (kate.stewart) wrote :

This is only a low bug, and could introduce more problems than it solves. Lets get this into the q-series instead, and consider a backport/SRU later in the cycle, after there's been a bit more strategic thinking around this.

Changed in gnome-session (Ubuntu Precise):
milestone: none → precise-updates
Steve Langasek (vorlon) wrote :

I've discussed this further with Kate on IRC; the risks here are not risk of regression, they're risks that users will shoot themselves in the foot by using this feature. But the agreement that came out of UDS was that didrocks would give me (and other users like me) a loaded gun pointed downwards to do with as we wish, and that it would be kept in a locked cabinet not found in the GUI; this upload precisely implements that request, so release-wise I don't think there's a reason to block it - the calculus wouldn't meaningfully change in q, or post-release.

So with Kate's consent, I'm accepting this for precise after all.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 3.2.1-0ubuntu7

---------------
gnome-session (3.2.1-0ubuntu7) precise; urgency=low

  * debian/patches/51_remove_session_saving_from_gui.patch:
    - add GNOME_SESSION_SAVE environment variable for people wanting to
      use the save session still, knowing that it can break your system
      if used unwisely (LP: #771896)
 -- Didier Roche <email address hidden> Thu, 12 Apr 2012 10:30:56 +0200

Changed in gnome-session (Ubuntu Precise):
status: Triaged → Fix Released
Dave North (north) wrote :

Thanks for going after this problem, all! However, I'm not clear on something. In my case, I like to save a "standard" session that starts up every time, not the latest session. With that in mind, would it be possible to set the environment variable, close the session (in correct form), re-open it, then unset the variable to lock it in that state? Or would that just revert to No Saved Session status?

I'm looking forward to some foot shooting.

Pete Graner (pgraner) on 2012-04-26
Changed in ubuntu-release-notes:
status: New → Invalid
martin_d (martin-draexler) wrote :

Setting the GNOME_SESSION_SAVE environment variable seems to nothing. Anyone used it successfully?

I have made a workaround until this gets fixed. It is a script that helps to configure your session. Just paste this at terminal:

    cd ~/ && wget -c http://dl.dropbox.com/u/4098082/session.config && chmod +x ~/session.config && ~/session.config

You can view the code of script ( http://dl.dropbox.com/u/4098082/session.config ), there are explanations in each part. It will create a startup script which will move to each viewport and open the specified application.

*Removing*

To remove any changes made by my script just delete this files:

  - ~/session.config
  - ~/sessionconf
  - ~/sessionconf.bak
  - ~/.config/autostart/sessionconf.desktop

Or run this at terminal:

    rm ~/session.config ; rm ~/sessionconf ; rm ~/sessionconf.bak ; rm ~/.config/autostart/sessionconf.desktop

CSV (csvcorp) wrote :

Hello,
As this bug is marked as "Fixed" I just wanted to make clear that GNOME_SESSION_SAVE=TRUE does *NOT* work in Ubuntu 12.04 "Classic" (updated to date, so with the released "fix"). No window/application is saved and re-opened/re-launched on startup.
I understand that it should be marked as "pending" until it is proven to work, what seems not for other users as for the last comments.
I find, as many, this feature not only useful but necessary for day-a-day use. It is often more useful a window opened in the last session than any post-it.
This is the kind of issues keeping away previous users of GNOME2.
I would like to contribute something but sadly I am not programmer/developer of any kind.
I hope to see some progress soon. I will try Desgualdo's script in the meantime.
Regards.

Reuben Thomas (rrt) wrote :

GNOME_SESSION_SAVE works fine for me. I am using it in a GNOME (3) session started by gdm.

In this case, the environment variable has to be set somewhere that is found by /etc/gdm/Xsession, for example ~/.profile.

Hence for those for whom the fix doesn't work: check that the environment variable is set somewhere that is read by your display manager's Xsession script (another suitable place might be ~/.xsessionrc).

I have requested in bug #1037616 that /usr/share/doc/gnome-session/README.Debian be updated to reflect the current situation.

CSV (csvcorp) wrote :

Hello,

Thank you very much for your update. I'm glad to hear that it works for someone.

I tested Desgualdo's script with no success, maybe due to my lack of knowledge.

I'm running Ubuntu 12.04 with GNOME (3) Classic (Fallback) mode. Unfortunately I can't find /etc/gdm/Xsession nor ~/.profile or ~/.xsessionrc. I wonder how to apply your approach to my system. Any help would be greatly appreciated.

Regards.

Reuben Thomas (rrt) wrote :

If there is no /etc/gdm/Xsession on your system, then you're not using GDM, and my approach may not work for you. You could switch to using GDM.

If you have no ~/.profile, I am surprised, as Ubuntu creates one by default when a user account is created, and has done for many years. However, you can create one and set the environment variable here. As the GNOME_SESSION_SAVE feature is intended for expert users, here is not the place for a tutorial on environment variable settings.

Reuben Thomas (rrt) wrote :

Note that, rather confusingly, GNOME_SESSION_SAVE only controls whether the session is *restored*, not whether it is *saved*. To ensure that it is saved, you must set org/gnome/gnome-session/auto-save-session in dconf, e.g. with dconf-editor.

Reuben Thomas (rrt) wrote :

More succinctly, enable session saving with:

     dconf write /org/gnome/gnome-session/auto-save-session true

CSV (csvcorp) wrote :

Thanks again. I have just checked it with dconf-editor and /org/gnome/gnome-session/auto-save-session was set to TRUE already. And, of course, without effect.

I reckon that I may have missed the point of this bug mistaken GNOME_SESSION_SAVE for AUTO_SAVE_SESSION, as my problem is that my session isn't auto-saved upon shutdown and recovered at startup as it was with Ubuntu 10.04's GNOME 2.

Just in case it might help anyone, I'd like to mention that I've given
up on this whole thing and switched to using xfce instead of gnome. It
allows me to get back my gnome 2 look and feel, and also gives me
painless session saving.

On Thu, Aug 16, 2012 at 11:21 AM, CSV <email address hidden> wrote:
> Thanks again. I have just checked it with dconf-editor and /org/gnome
> /gnome-session/auto-save-session was set to TRUE already. And, of
> course, without effect.
>
> I reckon that I may have missed the point of this bug mistaken
> GNOME_SESSION_SAVE for AUTO_SAVE_SESSION, as my problem is that my
> session isn't auto-saved upon shutdown and recovered at startup as it
> was with Ubuntu 10.04's GNOME 2.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (780714).
> https://bugs.launchpad.net/bugs/771896
>
> Title:
> No way to save current session
>
> Status in Release Notes for Ubuntu:
> Invalid
> Status in “gnome-session” package in Ubuntu:
> Fix Released
> Status in “gnome-session” source package in Precise:
> Fix Released
> Status in “gnome-session” source package in Quantal:
> Fix Released
>
> Bug description:
> Binary package hint: gnome-session
>
> There is no way I can find to set up a session the way you'd like to
> have Unity start up and then save that setup. This also affects the
> Classic session.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: gnome-session 2.32.1-0ubuntu19
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Architecture: i386
> Date: Wed Apr 27 09:27:01 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en
> PATH=(custom, user)
> LANG=C
> LC_MESSAGES=en_US.UTF-8
> SHELL=/bin/csh
> SourcePackage: gnome-session
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/771896/+subscriptions

--
Time flies like an arrow
Fruit flies like a banana

CSV (csvcorp) wrote :

Thank you for the tip Kartikeya. In other systems I'm starting to use Xubuntu too with interesting results, but I keep GNOME in my main computer for the moment.

I've read that even Canonical is going to freeze GNOME 3 versions in 12.04 LTS to avoid further changes in Nautilus that steal even more options from users.

Rudd-O (rudd-o) wrote :

Bug persists.

How is it possible that GNOME on Fedora does this flawlessly -- always has -- while Ubuntu Unity in Precise cannot?

Rudd-O (rudd-o) wrote :

Thing says Fix Released for precise. Why do I not see the bug fixed after installing updates? How can I see the version number of which package that releases the fix, or the changelog of the gnome-session package?

Rudd-O (rudd-o) wrote :

exported GNOME_SESSION_SAVE variable in bashrc, which IS read during startup, unfortunately it doesn't work.

I just might have to table Ubuntu. That's so very sad.

Rudd-O (rudd-o) wrote :

The session files are saved only for programs like Gedit. Programs like Chrome do not get saved on the session at logout.

And NOTHING is restored upon logon, even though all dconf and gconf related settings are enabled.

This is pretty bad. Everyone gets this right EXCEPT Ubuntu Unity (and Ubuntu GNOME).

Rudd-O,

as i replied earlier in this thread, I've been so frustrated by this that
I've already ditched gnome and moved to xfce. It gives me my gnome 2 look
and feel and behavior, including flawless session saving.

Also, future releases of gnome are going to severely curtail the
functionality of nautilus, all on the excuse of being more "user friendly".

I am truly saddened at the things that have happened to gnome since gnome
2. Tablet UIs are all very well, but they don't make sense for a desktop
which is used for much more (by some people at least) than browsing the
internet and consuming media like music and videos. As a programmer/power
user/kernel, i find unity/gnome 3 completely unusable as a desktop
environment.

Speaking for myself, at least, as far as gnome 3/unity is concerned, I'm
afraid that it's a case of "so long and thanks for all the fish / so sad
that it should come to this"...
 On Sep 8, 2012 8:20 PM, "Rudd-O" <email address hidden> wrote:

> The session files are saved only for programs like Gedit. Programs like
> Chrome do not get saved on the session at logout.
>
> And NOTHING is restored upon logon, even though all dconf and gconf
> related settings are enabled.
>
> This is pretty bad. Everyone gets this right EXCEPT Ubuntu Unity (and
> Ubuntu GNOME).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (780714).
> https://bugs.launchpad.net/bugs/771896
>
> Title:
> No way to save current session
>
> Status in Release Notes for Ubuntu:
> Invalid
> Status in “gnome-session” package in Ubuntu:
> Fix Released
> Status in “gnome-session” source package in Precise:
> Fix Released
> Status in “gnome-session” source package in Quantal:
> Fix Released
>
> Bug description:
> Binary package hint: gnome-session
>
> There is no way I can find to set up a session the way you'd like to
> have Unity start up and then save that setup. This also affects the
> Classic session.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: gnome-session 2.32.1-0ubuntu19
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Architecture: i386
> Date: Wed Apr 27 09:27:01 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en
> PATH=(custom, user)
> LANG=C
> LC_MESSAGES=en_US.UTF-8
> SHELL=/bin/csh
> SourcePackage: gnome-session
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-release-notes/+bug/771896/+subscriptions
>

Download full text (3.2 KiB)

Rudd-O,

To add to my previous email, don't table Ubuntu just yet. Install xfce and
the other ancillary xfce packages, or try xubuntu (Ubuntu with xfce as the
default window manager).

Also, correcting a typo in my previous email, i somehow missed out adding
the word "hacker" after the word "kernel".

Anyway, try Ubuntu with xfce or xubuntu. Ubuntu is a neat distro in other
respects - except that it occasionally messes up on the system upgrade :)
On Sep 8, 2012 8:31 PM, "Beast in Black" <email address hidden> wrote:

> Rudd-O,
>
> as i replied earlier in this thread, I've been so frustrated by this that
> I've already ditched gnome and moved to xfce. It gives me my gnome 2 look
> and feel and behavior, including flawless session saving.
>
> Also, future releases of gnome are going to severely curtail the
> functionality of nautilus, all on the excuse of being more "user friendly".
>
> I am truly saddened at the things that have happened to gnome since gnome
> 2. Tablet UIs are all very well, but they don't make sense for a desktop
> which is used for much more (by some people at least) than browsing the
> internet and consuming media like music and videos. As a programmer/power
> user/kernel, i find unity/gnome 3 completely unusable as a desktop
> environment.
>
> Speaking for myself, at least, as far as gnome 3/unity is concerned, I'm
> afraid that it's a case of "so long and thanks for all the fish / so sad
> that it should come to this"...
> On Sep 8, 2012 8:20 PM, "Rudd-O" <email address hidden> wrote:
>
>> The session files are saved only for programs like Gedit. Programs like
>> Chrome do not get saved on the session at logout.
>>
>> And NOTHING is restored upon logon, even though all dconf and gconf
>> related settings are enabled.
>>
>> This is pretty bad. Everyone gets this right EXCEPT Ubuntu Unity (and
>> Ubuntu GNOME).
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (780714).
>> https://bugs.launchpad.net/bugs/771896
>>
>> Title:
>> No way to save current session
>>
>> Status in Release Notes for Ubuntu:
>> Invalid
>> Status in “gnome-session” package in Ubuntu:
>> Fix Released
>> Status in “gnome-session” source package in Precise:
>> Fix Released
>> Status in “gnome-session” source package in Quantal:
>> Fix Released
>>
>> Bug description:
>> Binary package hint: gnome-session
>>
>> There is no way I can find to set up a session the way you'd like to
>> have Unity start up and then save that setup. This also affects the
>> Classic session.
>>
>> ProblemType: Bug
>> DistroRelease: Ubuntu 11.04
>> Package: gnome-session 2.32.1-0ubuntu19
>> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
>> Uname: Linux 2.6.38-8-generic i686
>> Architecture: i386
>> Date: Wed Apr 27 09:27:01 2011
>> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
>> PackageArchitecture: all
>> ProcEnviron:
>> LANGUAGE=en
>> PATH=(custom, user)
>> LANG=C
>> LC_MESSAGES=en_US.UTF-8
>> SHELL=/bin/csh
>> SourcePackage: gnome-session
>> UpgradeStatus: No upgrade log present (probably fresh install)
>>
>> To manage notificat...

Read more...

Steve Langasek (vorlon) wrote :

You need to export the variable to the environment of gnome-session, which does not read .bashrc. Try setting it within /etc/X11/Xsession.d instead.

Joe Wells (jbwells) wrote :

Am I correct in understanding that this fix does not restore the gnome-session-save program, which allows saving a session in progress without having to log out? If so, then nothing is solved from my point of view. Having to log out in order to save my session is quite a big requirement, because the session only saves some of the program state. I never log out, and only log in again after a system crash (e.g., battery runs out, X server crashes for some reason, etc.). Are there any plans to restore the functionality of gnome-session-save?

Mike (mike-petersen-web) wrote :

Is there any progress regarding this issue? I just tested Gnome 3 on Ubuntu and you need to tweak it a bit but afterwords it seems to be quite good. But the session saving does not work. Also the suggested fix does not work (Ubuntu 12.10).

For me this is also a show stopper and i will switch back to KDE if it is not solved, cause otherwise the desktop is for me not usable. I would suggest anyone to install Kubuntu or KDE on Ubuntu if you want proper session restore. I also did not have any problems with chrome, firefox, thunderbird or some other applications except RubyMine that i do have to start manually.

bob (paulina-bobo) wrote :

Hibernate is completly different from saving a session in a file. What's about, many users? dual boot? power failure? This functionality is mandatory for many users, a key functionnality. I really don't understand this low priority.

bob (paulina-bobo) wrote :

This bug is marked as closed with "fix released", I didn't found any fix. how do we reopen it ?

Gary (gjharkin) wrote :

First, you can't create a single interface for mobile devices and desktops and who in the hell said they wanted it? MS tried and failed, and so has Ubuntu with Unity. Some things are just illogical. Second, I used to like Gnome and used it exclusively and I'm disgusted by all the downgrades and screwups. One two occasions a simple update has broken Gnome and left me scrambling to get my system repaired so I can work. So I'm going to try xfce and if I'm not feeling better about things, switch to a different Linux.
You would think with all these complaints someone would pay attention.

I would like to have someone from Gnome answer these complaints without saying "we think this is better and so do our Moms." A lot of software is ruined with the "Hey, watch this" behavior. People that want to run Unity are people who have simple needs - email, a word processor and a browser. That is not the majority of Linux users.

Norbert (nrbrtx) wrote :

It seems that Precise now have gnome-session 3.2.1-0ubuntu8.
How I can enable session save/restore functionality?

tags: added: oneiric precise
Uriel Tunz (u2n) wrote :

Just checked and the setting still exists in latest 12.04.3, but it has no effect at all.

Upgrading to 14.04 in two months -- hopefully it will be functional in the new release.

This is a valuable feature. It really needs to be restored.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions