Release Notes for Ubuntu

Video loses sync on omap4

Reported by Tobin Davis on 2011-03-30
38
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Canonical ARM Developers
linux-ti-omap4 (Ubuntu)
High
Paolo Pisati
Oneiric
High
Paolo Pisati

Bug Description

After a few minutes, the signal from the system to the monitor is dropped, blanking the screen. To revivie the screen, the user needs to press <ctrl><alt>-F1 to switch to console and <ctrl><alt>-F7 to get back to X. This happens even when the system is actively used (twice while filling out this bug report).

The information in dmesg is as follows:

[ 5660.017425] omapdss DISPC error: GFX_FIFO_UNDERFLOW, disabling GFX
[ 5660.151000] omapdss DISPC error: SYNC_LOST_DIGIT, disabling TV
[ 5660.248718] omapdss DISPC error: timeout waiting for EVSYNC

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image-2.6.38-1207-omap4 2.6.38-1207.10
ProcVersionSignature: User Name 2.6.38-1207.10-omap4 2.6.38
Uname: Linux 2.6.38-1207-omap4 armv7l
Architecture: armel
Date: Wed Mar 30 16:51:38 2011
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-ti-omap4
UpgradeStatus: No upgrade log present (probably fresh install)

Tobin Davis (gruemaster) wrote :
tags: added: iso-testing
Tobin Davis (gruemaster) on 2011-03-31
Changed in linux-ti-omap4 (Ubuntu):
importance: Undecided → High
Tobin Davis (gruemaster) on 2011-04-01
Changed in linux-ti-omap4 (Ubuntu):
milestone: none → ubuntu-11.04-beta-2
Tobin Davis (gruemaster) wrote :

Here is a new twist on the video issue I have been seeing. This is with the kubuntu-mobile image on ompa4. The screen is supposed to show the oem-config window for adding a new user.

Changed in linux-ti-omap4 (Ubuntu):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Oliver Grawert (ogra) wrote :

i also see the GFX_FIFO_UNDERFLOW error above after about 2h working on the panda. unlike tobin i can not get the screen back via console switching. i have to actually ssh into the board and restart gdm and *then* can get it back through switching to a tty and back.

Changed in linux-ti-omap4 (Ubuntu):
status: New → Confirmed
Oliver Grawert (ogra) wrote :

kernel bug and we will likely not have another kernel upload before natty releases, moving milestone to -updates

Changed in linux-ti-omap4 (Ubuntu):
milestone: ubuntu-11.04 → natty-updates
Ricardo Salveti (rsalveti) wrote :

This bug is quite annoying. I got one underflow during the installer and 3 more after the first boot, just a few minutes after I opened up the unity-2d session, trying to install the omap4 extras.

Used the netbook image from 20110426.4, that uses the kernel 2.6.38-1208-omap4.

warmcat (andy-warmcat) wrote :

Seems to be two different issues, one is the original bug report and this other random thing.

On my tree, with my config, I don't see this at all. Blanking occurs but I can every time bring it back by waving the mouse a couple of seconds without these errors.

Is the kernel you're seeing this with maybe having CPU_FREQ enabled? I'm running with it disabled.

On Tue, Apr 26, 2011 at 2:38 PM, warmcat <email address hidden> wrote:
> Seems to be two different issues, one is the original bug report and
> this other random  thing.

It's actually the same thing. The problematic part here is the
GFX_FIFO_UNDERFLOW, that disables the GFX and then you need to blank
it again if you want to have your screen back.

> On my tree, with my config, I don't see this at all.  Blanking occurs
> but I can every time bring it back by waving the mouse a couple of
> seconds without these errors.

That's fine, it also works the same way with our kernel. The underflow
issue happened when I was using the board, not when it was idle.

> Is the kernel you're seeing this with maybe having CPU_FREQ enabled?
> I'm running with it disabled.

It's also disabled for Natty.

Bryan Wu (cooloney) wrote :

Actually, I failed to reproduce this issue on my board with kernel 1208.12. Could you guys test again with latest kernel?

-Bryan

Oliver Grawert (ogra) on 2011-04-27
Changed in ubuntu-release-notes:
assignee: nobody → Canonical ARM Developers (canonical-arm-dev)
Changed in linux-ti-omap4 (Ubuntu):
assignee: nobody → Canonical Kernel Team (canonical-kernel-team)

I'm slightly confused by the Oneiric nomination but the natty-updates milestone...

Regardless, setting this to Incomplete for now per Bryan's comment #8.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
milestone: natty-updates → none
status: Confirmed → Incomplete
Tobin Davis (gruemaster) wrote :

Still seeing "omapdss DISPC error: timeout waiting for EVSYNC" on linux-image-3.0.0-1203-omap4. See syslog-20110830.txt attached.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: Incomplete → Confirmed
Brad Figg (brad-figg) on 2011-09-02
tags: added: rls-mgr-o-tracking

Hi Paolo,

Care to take a look at this for us? Thanks.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
assignee: Canonical Kernel Team (canonical-kernel-team) → Paolo Pisati (p-pisati)
Changed in linux-ti-omap4 (Ubuntu Oneiric):
milestone: none → oneiric-updates
Tobin Davis (gruemaster) wrote :

I'm not seeing this in the latest oneiric kernel. It may have been fixed with the latest TI pull. Will keep my eyes open and close this if I don't see it at all.

Tobin Davis (gruemaster) wrote :

On all my systems, I only am seeing this on my headless (no monitor) systems, and only once during boot. Some of these systems have been on for days. Previously, this error would repeat constantly every few seconds.

I think it is safe to close for Oneiric.

Closing per comment #13 from Tobin. Thanks.

Changed in linux-ti-omap4 (Ubuntu Oneiric):
status: Confirmed → Fix Released
David Lerch (alemariusnexus) wrote :

I'm still getting the GFX_FIFO_UNDERFLOW error on Ubuntu Oneiric using Kernel 3.0.0-1205-omap4. Also, the fix with CTRL-ALT-F1/F7 doesn't work for me: Still only a black screen on X11. It happens with my LG W2443. Before Oneiric, this monitor didn't display anything at all on my Pandaboard. With Oneiric, it works on DVI (except for the underflow thing), but HDMI still displays a black screen only.

I can't really tell when it happens, though I haven't seen it happen when I run the monitor at 1280x1024 (normally it's 1080p). Often it happens when I only start the system monitor in XFCE, but I've also seen it happen when I do nothing at all.

Please tell me if you need any more information.

Pete Graner (pgraner) on 2012-04-26
Changed in ubuntu-release-notes:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers