Release Notes for Ubuntu

brasero crashed with signal 5 in g_variant_new_va()

Reported by Tormod Volden on 2010-09-15
176
This bug affects 33 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Medium
Unassigned
brasero (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: brasero

This is running today's daily. I opened Brasero, chose "Disc copy", then inserted a normal music CD. After pressing "Copy" brasero died and apport kicked in.

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: brasero 2.31.92-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Uname: Linux 2.6.35-21-generic i686
Architecture: i386
Date: Wed Sep 15 22:00:46 2010
ExecutablePath: /usr/bin/brasero
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100915)
ProcCmdline: brasero
ProcCwd: /home/ubuntu
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: brasero
StacktraceTop:
 ?? () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 g_variant_new_va () from /lib/libglib-2.0.so.0
 g_variant_new () from /lib/libglib-2.0.so.0
Title: brasero crashed with signal 5 in g_variant_new_va()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Tormod Volden (tormodvolden) wrote :
visibility: private → public
Tormod Volden (tormodvolden) wrote :

This is what I see on the command line:

$ brasero

** (brasero:3732): WARNING **: ERROR loading background pix : Failed to open file '/usr/share/brasero/logo.png': No such file or directory

(brasero:3732): GLib-CRITICAL **: g_variant_builder_end: assertion `is_valid_builder (builder)' failed

(brasero:3732): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(brasero:3732): GLib-CRITICAL **: g_variant_type_is_array: assertion `g_variant_type_check (type)' failed

(brasero:3732): GLib-CRITICAL **: g_variant_get_type_string: assertion `value != NULL' failed

GLib-ERROR **: g_variant_new: expected array GVariantBuilder but the built value has type `(null)'
aborting...
Trace/breakpoint trap (core dumped)

Thomas Martin (tmartin-appa) wrote :

Can you please try to reproduce the bug and post the results here?

Changed in brasero (Ubuntu):
status: New → Incomplete
Tormod Volden (tormodvolden) wrote :

Thomas, what are you talking about?

Anyway, I think anyone with a music CD can reproduce it. I reproduced it running the live "CD".

Changed in brasero (Ubuntu):
status: Incomplete → New

StacktraceTop:
 ?? () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 ?? () from /lib/libglib-2.0.so.0
 g_variant_new_va () from /lib/libglib-2.0.so.0
 g_variant_new () from /lib/libglib-2.0.so.0

Changed in brasero (Ubuntu):
status: New → Invalid

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

python2.6: installed version 2.6.6-4ubuntu1, latest version: 2.6.6-5ubuntu1
libasound2: installed version 1.0.23-1ubuntu1, latest version: 1.0.23-1ubuntu2
cpp-4.4: installed version 4.4.4-14ubuntu3, latest version: 4.4.4-14ubuntu4
libpython2.6: installed version 2.6.6-4ubuntu1, latest version: 2.6.6-5ubuntu1
libindicator0: installed version 0.3.12-0ubuntu1, latest version: 0.3.13-0ubuntu1
gcc-4.4-base: installed version 4.4.4-14ubuntu3, latest version: 4.4.4-14ubuntu4
libdbusmenu-gtk1: installed version 0.3.13-0ubuntu1, latest version: 0.3.14-0ubuntu1
initramfs-tools: installed version 0.98.1ubuntu2, latest version: 0.98.1ubuntu3
libdbusmenu-glib1: installed version 0.3.13-0ubuntu1, latest version: 0.3.14-0ubuntu1
python2.6-minimal: installed version 2.6.6-4ubuntu1, latest version: 2.6.6-5ubuntu1
libappindicator1: installed version 0.2.7-0ubuntu1, latest version: 0.2.8-0ubuntu1
initramfs-tools-bin: installed version 0.98.1ubuntu2, latest version: 0.98.1ubuntu3

Please upgrade your system to the latest package versions. If you still
encounter the crash, please file a new report.

Thank you for your understanding, and sorry for the inconvenience!

tags: removed: need-i386-retrace
col reilly (lupinehorror) wrote :

tried to make a simple audio cd from 15 mp3 files...

Conor Curran (cjcurran) wrote :

I can reproduce this every time I try to burn a CD from a WAV file. amd64, Maverick up to date as of this morning.

Conor Curran (cjcurran) wrote :

gnomebaker works ...

Changed in brasero (Ubuntu):
status: Invalid → Confirmed
Gabriele Monti (psicus78) wrote :

Me too, I can reproduce this every time I try to burn a CD from MP3 files. amd64, Maverick up to date as of this morning. Gnomebaker is ok

Tormod Volden (tormodvolden) wrote :

For the sake of Apport retracing service I filed bug 649245 which is a duplicate.

Pedro Villavicencio (pedro) wrote :

Thanks for the report, I cannot reproduce this with today iso/packages, could somebody having this with latest packages please provide a Backtrace? for instructions please read https://wiki.ubuntu.com/DebuggingProgramCrash ; Thanks in advance.

Changed in brasero (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
Tormod Volden (tormodvolden) wrote :

Pedro, the stacktrace in bug 640481 seems to be more complete.

Tormod Volden (tormodvolden) wrote :
Changed in brasero (Ubuntu):
status: Incomplete → Confirmed
Tormod Volden (tormodvolden) wrote :

From this stack trace it seems to me that it crashes while it wants to install toc2cue, which does not exist in maverick.

Tormod Volden (tormodvolden) wrote :

Correction, toc2cue is available from the cdrdao package (I thought the string I saw in gdb was supposed to be a package name).

Tormod Volden (tormodvolden) wrote :

Pedro, I can reproduce this with the 10.10 RC Desktop CD, so I am not sure you tried hard enough :) I can not see that hardware plays a difference here. I get the same crash both with a music CD and a data CD to copy.

maik stolle (ms090780) wrote :

hi,

can't reproduce this.
opend brasero---> copy CD/DVD----> insert AudioDisc--->press copie
then following message appaers:
Bitte installieren Sie die folgenden manuell und versuchen Sie es dann erneut:
cdrdao (Anwendung).

this means brasero cant find cdrdao, but cdrdao is installed!
reinstall cdrdao didnt help.

regards maik

maik stolle (ms090780) wrote :

edit

ubuntu 10.10 x64
2.6.35-22-generic

regards maik

Tormod Volden (tormodvolden) wrote :

maik, are you running the 10.10 RC Desktop CD? Otherwise it might be that you have for instance the cdrdao package additionally installed on your system. AFAIK cdrdao is not installed by default.

maik stolle (ms090780) wrote :

hi,

yes cdrdao is installed!! but brasero plugin's sayd the version is to old.

brasero 2.31.92-0ubuntu2
cdrdao 1:1.2.3-0.1ubuntu1

regards maik

Tormod Volden (tormodvolden) wrote :

I installed cdrdao on my maverick system, but then ran into an "Unsupported type of task operation" internal error. I am afraid that once these bugs are resolved, there is still bug 639908 open, so it does not look good for CD copying in 10.10.

Tormod Volden (tormodvolden) wrote :

I meant bug 529696...

Alex Moldovan (alexmoldovan) wrote :

Using Ubuntu 10.10 i386 and today's updates, I successfully copied a Cd into an ISO and burned audio Cd's from both WAV and MP3 files. Brasero is working fine.

Tormod Volden (tormodvolden) wrote :

Alex, did you also try Copy Disc (from CD to CD)?

Tormod Volden (tormodvolden) wrote :

Alex Moldovan, you removed this issue from the 10.10 release notes. However, you have not confirmed that you have tested the Copy Disc functionality.

Fabián Rodríguez (magicfab) wrote :

@Tormod, yes, we did test such functionality too. Sorry it seems Alex forgot to inform about removal from the release notes. As this couldn't be consistently reproduced we removed it.

TRiSS (triss) wrote :

I had this problem when trying to copy a dvd to iso. Installing libdvdcss2 from the medibuntu repo fixed it, so I guess this error points to a missing dependency for the task brasero needs to perform. No idea what that would be for an audiocd though...

michal.gregor (michal.gregor) wrote :

I have one more thing to add: cdrdao comes preinstalled in most distros that include Brasero (e.g. Fedora 13) which I find rather logical considering that it is required for this feature to work. I mean - why on earth does the package rhythmbox-plugin-cdrecorder not depend on cdrdao for an instance? What is the point of integrating a copy audio CD option into rhythmbox when the packages required for it to work need not be installed?

So, either rhythmbox-plugin-cdrecorder or Brasero itself should definitely depend on cdrdao.

I faced the same problem while trying to copy an audio CD on an updated Ubuntu 10.10. After reading the comments, I installed the package 'cdrdao'. That actually solved the problem. Brasero has just successfully created an image file of the CD.

I tried to reproduce the bug by removing the package 'cdrdao', and the bug is back again. So I think 'cdrdao' should definitely be marked as a dependency for Brasero. Or one would at least expect a message displaying the missing dependency, like the one described in comment #20. But instead it crashes.

michal.gregor (michal.gregor) wrote :

I wonder how long it may take to change dependencies of a package and why this isn't fixed by now...

Dan Delaney (dan-launchpad) wrote :

I just downloaded and installed Ubuntu 10.10 on a brand new Dell Precision T3500 yesterday (2011-01-03) and I got this problem when I just tried to copy a DVD, so this bug is still not resolved.

cdrdao is installed.

I've attached the output from running it with "brasero --brasero-burn-debug --brasero-media-debug"

Kate Stewart (kate.stewart) wrote :

10.10 is EOL now, and not seeing evidence of it on later release. Closing this bug.

Changed in ubuntu-release-notes:
importance: Undecided → Medium
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers