Release Notes for Ubuntu

dovecot sieve plugin renamed from cmusieve to sieve

Reported by Matt Zimmerman on 2010-02-02
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
dovecot (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to the latest lucid, I noticed that dovecot delivery was failing with:

Feb 02 10:36:39 deliver(mdz): Fatal: Plugin cmusieve not found from directory /usr/lib/dovecot/modules/lda

My configuration had:

protocol lda {
[...]
        mail_plugins = cmusieve
}

but the plugin is now:

/usr/lib/dovecot/modules/lda/lib90_sieve_plugin.so

Steve Langasek (vorlon) wrote :

I don't use dovecot, so I'm not sure what the corrected syntax here should be - "mail_plugins = lib90_sieve_plugin"?

Changed in ubuntu-release-notes:
status: New → Incomplete
Matt Zimmerman (mdz) wrote :

Sorry, I should have specified.

The correct syntax is now:
 mail_plugins = sieve

because the file was renamed from:
/usr/lib/dovecot/modules/lda/lib90_cmusieve_plugin.so (karmic)
to:
/usr/lib/dovecot/modules/lda/lib90_sieve_plugin.so (lucid)

Changed in ubuntu-release-notes:
status: Incomplete → New
Steve Langasek (vorlon) wrote :

Thanks. Documented at <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#Dovecot%20cmusieve%20plugin%20renamed%20to%20sieve>:

The "cmusieve" plugin used in dovecot has been renamed to "sieve". Users who have the following set in their dovecot configuration:

        mail_plugins = cmusieve

should change this to:

        mail_plugins = sieve

Changed in ubuntu-release-notes:
status: New → Fix Released
Fawn (fawn) wrote :

I get this error:

May 3 12:25:31 mc01 dovecot: deliver(fawn): Fatal: Plugin cmusieve not found from directory /usr/lib/dovecot/modules/lda

mail_plugins is commented out in my dovecot.conf

Helmut Schmid (helmut-schmid) wrote :

Me too, I get the same error, even when mail_plugins = sieve is set.

Helmut Schmid (helmut-schmid) wrote :

Got the solution. I found /etc/dovecot/conf.d/01-postfix-dovecot.conf and there is cmusieve configured. I've changed it to sieve and everything ist working now.

But dovecot itself use /etc/dovecot/dovecot.conf when running (ps ax). This looks a bit strange to me. Don't know which file is really used?

But maybe conf.d/* will be used too when start/restart dovecot daemon itself and settings from dovecot.conf will be replaced from conf.d??

FYI, I've used the dovecot-postfix package.

It does not work for me :(

How can i fix it?

aanno (thomas-pasch) wrote :

I could confirm what Helmut said: it is wrong in /etc/dovecot/conf.d/01-postfix-dovecot.conf . For me, this was a bummer as I thought the dovecot-postfix package would manage it all for me.

Steve Langasek (vorlon) wrote :

Looks to me like this is a bug in the dovecot-postfix package which provides /etc/dovecot/conf.d/01-postfix-dovecot.conf, not dovecot? Reassigning.

Matt Zimmerman (mdz) wrote :

The dovecot-postfix issue is bug 573345. This bug is NOT a duplicate of that one (but has been addressed in the release notes).

Changed in dovecot (Ubuntu):
status: New → Invalid

Hi Matt,
if "this bug is not that bug", than what bug is this you mean?
I'd experienced the same bug, and easily fixed by editing the .conf which you guys mentioned, too.
Just wanna make it clearly.

On Mon, May 10, 2010 at 09:27:29AM -0000, BlueT - Matthew Lien - 練喆明 wrote:
> Hi Matt,
> if "this bug is not that bug", than what bug is this you mean?
> I'd experienced the same bug, and easily fixed by editing the .conf which you guys mentioned, too.
> Just wanna make it clearly.

This bug is about the fact that the plugin was renamed, and this affects
people who have configured dovecot to use the plugin (including those who do
not use postfix-dovecot).

The other bug is about the fact that postfix-dovecot refers explicitly to
the old name, and needs to be changed to use the new name.

--
 - mdz

Laurent Dinclaux (dreadlox) wrote :

I installed a fresh server today and ran into than issue, so as of today the fix is not available ....

Ante Karamatić (ivoks) wrote :

On 16.05.2010 08:21, Lox wrote:

> I installed a fresh server today and ran into than issue, so as of today
> the fix is not available ....

If you did a fresh install, you couldn't have experienced this bug. This
bug is about change in configuration scheme for dovecot between two
Ubuntu releases, where one would get non working dovecot if one doesn't
accept changes from new config. Since you did a fresh install, you got
new config from start.

You are probably referring to similar bug in dovecot-postfix, for which
fix exists and is pushed to -proposed repository. If that's the case,
enable proposed repository and add a comment to bug 573345 about how
that fix works for you.

Thanks

zeckenleger (gho-nexgo) wrote :

After upgrading to lucid my dovecot does not work anymore, too.

When I try to start it I get the following message:

 * Restarting IMAP/POP3 mail server dovecot
Error: Error in configuration file /etc/dovecot/dovecot.conf line 691: Unknown setting: sieve
Fatal: Invalid configuration in /etc/dovecot/dovecot.conf
                                                                         [fail]

Line 691 in dovecot.conf says:
            sieve=~/.dovecot.sieve

Changing of cmusieve to sieve in /etc/dovecot/conf.d/01-postfix-dovecot.conf does not help on my machine.

Can anybody help?

Bill Weinel (bweinel) wrote :

>Fatal: Invalid configuration in /etc/dovecot/dovecot.conf [fail]
>Line 691 in dovecot.conf says: sieve=~/.dovecot.sieve

I experienced this same issue after a distro upgrade from 9.10 to 10.04 LTS. I found that this problem is being caused during upgrades from earlier versions by retaining the old dovecot.conf file during the upgrade. A number of config statements have been moved around in the dovecot.conf file for the new version included in 10.04 LTS causing the old dovecot.conf file to be incompatible. The solution is to use the latest version of the dovecot.conf file included with the distro during upgrade and then manually add your local configuration changes. Examples of the new format are included and loaded during the upgrade in the etc/dovecot directory for ucf-dist, db, dict-sql, sql, and ldap.

Cheers

Ben Jordan (bjordan555) wrote :

A followup to Bill's comment above:

I upgraded from 9.10 to 10.04 and dovecot failed to start, claiming to have problems with the sieve configuration in line 691. After some fooling around, I found Bill's comment above, and decided to backup the existing dovecot.conf and replace it with a new one found here: http://www.dovecot.org/doc/dovecot-example.conf. The ssl certs specified in this file are incorrect, and I replaced them with:

ssl_cert_file = /etc/ssl/certs/ssl-cert-snakeoil.pem
ssl_key_file = /etc/ssl/private/ssl-cert-snakeoil.key

I then restarted dovecot and everything worked.

Hope this helps.

For the ssl_cert_file issue, you should do the following:

dpkg-reconfigure dovecot-common

The ssl cert problem is documented at the end of the file /usr/share/doc/dovecot-common/README.Debian. The "snakeoil" cert is just a generic certificate, you should never use it at production sites.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers